Avatar

David Ford

  • Total activity 14
  • Last activity
  • Member since
  • Following 0 users
  • Followed by 0 users
  • Votes 1
  • Subscriptions 5

Activity overview

Latest activity by David Ford
  • Avatar

    David Ford commented,

    I reached the end of the Luminar 3 road when 3.0.2 did not deliver a usable result. I feel cheated having paid for Luminar 2018 on the promise of the new Luminar 3. It is indeed totally unusable in...

  • Avatar

    David Ford commented,

    I installed the patch as soon as it was released - it did not address any of the issues listed at the top of this thread and, to be honest, I have no confidence that Skylum will be able to get L3 w...

  • Avatar

    David Ford created a post,

    Luminar 3 - list of issues

    Worked Luminar 3 quite hard during the last 5 days. (Using Win10 on i7, 16GB, Nvidia 1030.) These are my top ten issues: 1. Creating a library - Imported folders with 1,500 images into an empty cat...

  • Avatar

    David Ford created a post,

    Using Luminar 3 productively

    As many here have found, L3 does not work with a large library of images. However, that doesn't mean that it can't be used productively. The trick is to run it without a library - this YouTube vide...

  • Avatar

    David Ford commented,

    If you have read the MAC forum, you'll see they are just as P***ed off as us Windows users. I can't see any amount of 'hot fixes' addressing this. It's like they have designed a car with only two w...

  • Avatar

    David Ford commented,

    @Leila Evans Thanks, I had worked out that solution on the fourth install! It now runs - sort of. However, the program is not fit for purpose - it is very slow, unpredictable, and missing very basi...

  • Avatar

    David Ford created a post,

    Luminar 3 Stuck on splash screen

    Luminar installed ok on the 3rd try and displayed my catalogue ok. When closed down, however, Luminar will not start again and hangs on the splash screen. Have tried rebooting the machine several t...

  • Avatar

    David Ford commented,

    Same problem here - Luminar stuck on splash screen after apparently running ok with my catalogue initially. Have reinstalled three times now and the problem persists.  Pictures folder and catalogue...