Comments

30 comments

  • Avatar
    Alf Altendorf

    Luminar AI 1.5.3  has a bug if used as an extension for apple photos (Ventura): it shows an endless "processing" message.

    This bug was already mentioned here in the forum for NEO as well.
    https://community.skylum.com/hc/en-us/community/posts/6952839920274-Mac-OS-13-0-Ventura#_=_

    So better do not upgrade. I did unluckily.

    1
    Comment actions Permalink
  • Avatar
    Margaret Bright

    While the official compatibility was not implemented, the app should be running fine on macOS Ventura.

    -1
    Comment actions Permalink
  • Avatar
    ALESSANDRO CAVALLIN

    Con l'installazione di VEntura, Luminar non si apre piu

    0
    Comment actions Permalink
  • Avatar
    Agatha Winter

    Hi ALESSANDRO,

    Let's try the following solution:

    1. Make sure Luminar Neo/AI is closed.
    2. Locate your Luminar Neo Catalog/Luminar AI Catalog folder. The default location is %username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    3. Rename the Luminar Neo/AI Catalog folder as well as the Luminar Neo Catalog.luminarneo (luminar.ai) file inside this folder. Choose any name you like.
    4. Launch Luminar Neo/AI and choose to Create a New Catalog. Leave the location of the catalog at the default (in the Pictures folder). 

    Let me know how it goes.

    0
    Comment actions Permalink
  • Avatar
    Joseph Feeks

    I am having the same problem since installing Ventura.  I tried the above suggestions but they did not solve the problem. The Processing message continues and I can't access the Luminar tools through Apple Photos.

    1
    Comment actions Permalink
  • Avatar
    Member

    Same problem here.

    1
    Comment actions Permalink
  • Avatar
    Daniel Szumilas

    I need a help as well. I got stuck right before the end of editing photos for my client. Luminar 4 have some problems as well

    1
    Comment actions Permalink
  • Avatar
    Mark Rosher

    Luminar AI is failing to open under Ventura 13.0

    I'm having to fall back to Luminar Neo. Not a happy bunny.

    1
    Comment actions Permalink
  • Avatar
    Joseph Feeks

    I tried Agatha's recommendation above, where you rename the Catalog folder and then reopen the Luminar app.  It worked for Luminar Neo, which is back to normal, but not for Luminar AI (which I prefer),  Make sure you've downloaded the latest update for Neo through the Luminar Neo app before doing any of the above.   Once that's installed, quit the app and reopen Photos.  Restart your Mac, if needed.

    0
    Comment actions Permalink
  • Avatar
    Maksym Hlushko

    The same!

    0
    Comment actions Permalink
  • Avatar
    Mark Rosher

    Skylum reached out and offered this solution:

    • Hold down the Option key on your keyboard and start Luminar. Keep holding Option until you see a window with a list of available backups appear.
    • Select a backup that was created before you encountered the issue with the crashes and click Restore from Backup.

    By that time though I had deleted my installation and successfully reinstalled from scratch. No big thing for me since I don't rely on the DRM, but you might try the Skylum way first... ;-)

    0
    Comment actions Permalink
  • Avatar
    Alan Moore

    Upgrading Neo to 1.4.2 solved this problem for me. But oddly, upgrading AI to 1.5.3 had no impact.

    Perhaps AI to receive another update?  

    0
    Comment actions Permalink
  • Avatar
    Agatha Winter

    Hi Alan,

    Could you please specify what issue with Luminar AI you've encountered? 

    0
    Comment actions Permalink
  • Avatar
    Alan Moore

    Hi Agatha - same as the OP's description.

    Basically I am opening AI from within Photos (on newly upgraded MacOS Ventura). The AI interface opens but the "Processing" dialogue box never disappears. The target image remains greyed out. 

     

    1
    Comment actions Permalink
  • Avatar
    Dave Ulane

    Same issue here as Mr. Moore with AI on OS Ventura.  Incredibly frustrating. Please fix this.

     

    1
    Comment actions Permalink
  • Avatar
    Domenico Trezza

    Ok, ho seguito il consiglio di Mark, ora funziona, naturalmente ho dovuto ricreare il catalogo.. grazie.

     

    1
    Comment actions Permalink
  • Avatar
    Dave Ulane

    Neither uninstalling and reinstalling AI fixed this for me, nor did restoring from a previous catalog.  Come on Skylum-  in other posts you acknowledged you know of this issue, and would correct once a final version of Ventura was released.  It has been, so let's get this corrected please.

    1
    Comment actions Permalink
  • Avatar
    Joseph Feeks

    As previously reported, the steps Skylum's Agatha posted 8 days ago resolved the problem with Luminar Neo after I upgraded to Mac OS Ventura. I followed the same steps again today with Luminar AI (my preferred platform) and I still get the "Processing" message. Hope that's addressed soon.

    1
    Comment actions Permalink
  • Avatar
    Elena Blum

    Hi Joseph , Dave,

    The full compatibility for the latest macOS has not yet been implemented in Luminar AI. 

    Please stay tuned for the compatibility update, we're working on it right now. 

    In the meantime, you should be able to use Luminar AI as a standalone app.

    0
    Comment actions Permalink
  • Avatar
    Hanneskaschmir .

    Dear Elena! MacOs Ventura is more than 2 weeks old, but no plugin is working. I think it would be fair to grant us Luminar Ai users a special discount on upgrading to Luminar NEO. Please talk to your boss.

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi Hanneskaschmir .,

    The fix is in the works right now and will be available shortly. 

    Meanwhile, please contact us at https://skylum.com/support   
    I'm positive we'll be able to find a special deal for you.
    Kindly make sure to include the link to this post as a reference.

    0
    Comment actions Permalink
  • Avatar
    Hanneskaschmir .

    Puh, Ventura 13.0.1 is out and Luminar Ai still not functioning properly. When will the update be finally available, please?

    1
    Comment actions Permalink
  • Avatar
    Hanneskaschmir .

    I wish to to get a discount code and purchase the functioning Neo edition. PLEASE!

    0
    Comment actions Permalink
  • Avatar
    Elena Blum

    Hi Hanneskaschmir ,

    Please contact our support team and we will do our best to assist you https://skylum.com/support

    0
    Comment actions Permalink
  • Avatar
    Tobias S

    Luminar AI is not working in Ventura MacOS-

    same problem here!

     

    0
    Comment actions Permalink
  • Avatar
    Member

    Luminar AI still not working in Ventura MacOS, please give me a date when I can expect Luminar AI to be operational.

     

    1
    Comment actions Permalink
  • Avatar
    Dave Ulane

    Yep.  And neither is Aurora HDR- same issue as Luminar.  But somehow Skylum keeps sending me promos for trying to get me to buy Neo! 🤨  Why in the world would I buy another piece of software from a company that can't even fix things like this that have been known for weeks?  At this point, I'll be looking elsewhere.

    0
    Comment actions Permalink
  • Avatar
    Anastasiia Moore

    Hi all!
    Recently we released the compatibility update for Luminar AI (with the support of macOS Ventura). Kindly ensure that you're running the latest version of the app:

    https://manual.skylum.com/ai/en/topic/keeping-luminar-up-to-date?q=update

    If, after updating Luminar AI to version 1.5.4, you still have issues, kindly reach out to our support team at https://skylum.com/support, describing the issue in detail.

    0
    Comment actions Permalink
  • Avatar
    Tobias S

    how to get version 1.5.4?? your link does not work and in the download section under my paid apps there is only version 1.5.3 not 1.5.4.. 

    Download link?

     

    0
    Comment actions Permalink
  • Avatar
    Tobias S

    i see, i have alread 1.5.4 but still not working with VETURA macOS

    always crash when editing photos on network drive, or exporting photos

    0
    Comment actions Permalink

Please sign in to leave a comment.