Luminar Neo 1.4.2 not working on mojave

Answered

Comments

2 comments

  • Avatar
    Member


    Hi Wolfgang,

    according to the Skylum minimum requirements Luminar NEO runs from MacOS 14.6. So it should actually run. However, NEO may not run with such an old version of Lightroom.

    I recommend getting rid of "old fashions" and just switch to a newer version. MacOS alone offers so much that is new in the latest version. And so does Lightroom. Meanwhile, Lightroom also masters masking and various AI functions. It is also possible to work in multiple layers. For one or the other, further software will then not be necessary at all. But NEO has also grown up in the meantime and offers so many new and unique possibilities that perhaps one or the other can do without other software. 

    0
    Comment actions Permalink
  • Avatar
    Margaret Bright

    Hi Wolfgang,

    The app should still be running on your OS. If you need assistance in getting the app up and running again, please get in touch with our support team at https://skylum.com/support. They will be happy to help! 

    0
    Comment actions Permalink

Please sign in to leave a comment.