Luminar Neo not working

Answered

Comments

10 comments

  • Avatar
    Anastasiia Moore

    Hi christian nielsen,

    Kindly reinstall drivers for the Intel GPU. 

    Make sure to fully uninstall your current graphics drivers before proceeding. How to uninstall drivers (click this text to open the link)
    In addition to uninstalling the device, make sure to select the Delete the driver software for this device option

    Download and install drivers from the manufacturer's website:

    Please let us know how it goes.

    0
    Comment actions Permalink
  • Avatar
    christian nielsen

    I uninstalled the Graphics drivers completely and reinstalled. I am still getting the same issue. Almost non responsive

     

    1
    Comment actions Permalink
  • Avatar
    Alina Skylum

    christian nielsen,

    In this case, please, get in touch via skylum.com/support and let us know your hardware configuration:

    However, please, kindly note. that due to the war in Ukraine, it might take us longer to reply, since our Team is located here. However, we're trying our best to continue working and get back to you as soon as we can.

    You can check these credible sources regarding the current situation here: https://ukraineworld.org/articles/ukraine-explained/what-read

    Here is how you can help: https://how-you-can-support-ukraine.super.site/

    0
    Comment actions Permalink
  • Avatar
    christian nielsen

    Please see the google drive link, I already had that in my post 

    0
    Comment actions Permalink
  • Avatar
    Agatha Winter

    Hi Christian,

    In this case, could you please disable hardware acceleration following the steps below?

    1.Type CMD in the search field on your Taskbar, right-click on the Command Prompt line and choose Run as administrator. 

    2.In the Window that opens, copy and paste the line below: 

    reg add HKCU\SOFTWARE\Microsoft\Avalon.Graphics /v DisableHWAcceleration /t REG_DWORD /d 1

    3. Press Enter on your keyboard.

    Launch Luminar and check how it works for you.

    0
    Comment actions Permalink
  • Avatar
    christian nielsen

    Still very slow. 

    0
    Comment actions Permalink
  • Avatar
    Alina Skylum

    Christian Nielsen,

    Please, note that performance speed is influenced by several factors.

    How many photos do you have in your catalog? Are they stored on internal or external drive?

    Do you run any other apps when you edit your photos? How much free space do you have on your drive, where Luminar is installed?

    0
    Comment actions Permalink
  • Avatar
    Danijel Boksan

    I have this problem, and i was reading what i could do, so i try everthing what i found. but it´s still not working. can someone help me pleas ?

    0
    Comment actions Permalink
  • Avatar
    Helga Rowles

    Hi Danijel,

    Could you please try to update your Nahimic drivers? We can recommend following either method 1 or 2 in this article: https://www.drivereasy.com/knowledge/update-nahimic-audio-driver-quickly-easily/ 

    If updating the drivers does not help, could you please try to disable Nahimic (or nahimicservice.exe) in your Task Manager? (How to run a task manager: click here)

    If you're prompted to restart the computer after you disable this service, please make sure to run Task Manager once again after the restart and verify that this service is still disabled. 

    Once you've made sure that Nahimic is not active, please try to run Luminar and check whether the issue persists. 

    0
    Comment actions Permalink
  • Avatar
    Annmarie

    HI! I too have the Samsung Pro Book 360 and have been having the same issues for the last month and a half. I have uninstalled, reinstalled the program, removed and reinstalled the drivers... I went to sites to download things and still to no avail Neo isn't working like its supposed to.

    I only have 2 images in catalog, which I ended up deleting. NO other programs or apps running. It is a brand new computer and nothing but basic programs installed to run. I haven't installed anything yet, other than Neo.

    I have images saved to external hard drive, although I Have 1 TB of memory on the computer. 

    So you aren't alone in this. IF it can't get working by end of this month, I have no choice but request a refund and suck it up to pay for the other editing programs, I really don't want.

    0
    Comment actions Permalink

Please sign in to leave a comment.