Luminar neo on macbook pro retina 2015 LAGG

Answered

Comments

3 comments

  • Avatar
    Alina Skylum

    Hi there,

    I'm terribly sorry to hear that you had issues with running Luminar Neo. Having checked our inbox, I noticed that you sent your request as a response to our newsletter, which is sent from no-reply address. This is why you didn't receive a reply. If you need help, please, reach us directly via https://skylum.com/support 

    When creating your support request, please, include the link to this thread as well as your system info. Here is how to collect it: click on Apple logo in the upper left corner of your screen, click About This Mac, and make a screenshot of the window that opens. Check out this article (click this text to open link) about making screenshots on Mac if you need help with that. 

    Did you also notice any common pattern, which leads to the crashes? What kind of steps do you follow before this happens? Appreciate your cooperation.

    1
    Comment actions Permalink
  • Avatar
    Don Landwehrle

    I also find it very slow on my 2014 MBP. I've tried it with and without the GPU acceleration with no observable difference. Opening a 43mpx image it took 12 seconds just to apply enhance and then over 50 seconds for Develop exposure adjustment.

    0
    Comment actions Permalink
  • Avatar
    Member

    hey Alina Skylum thank you for the reply. I did try to contact you guys before on feb 17th but that would have been a busy day for all of you regarding the launch of Luminar Neo.

    I have followed your instructions and contacted you guys through another email with all the details given, I'm willing to cooperate so either in the end I can use Neo myself or atleast help you guys in the right direction to make it smoother for others.

    0
    Comment actions Permalink

Please sign in to leave a comment.