NEO will not launch

Answered

Comments

11 comments

  • Avatar
    Tania Taylor

    Hi Henry P!

    Sorry to hear you've faced this issue.

    Could you, please, try to launch Luminar Neo this way: right-click on the application icon > Run as administrator? 

    If the issue persists, please try reinstalling the app in the following way:

    1. Go to “Apps and Features” by right click on the Start button;
    2. Find Luminar there and click [Uninstall] (you can also uninstall from the Control Panel);
    3. Type %appdata% in Search (folder Roaming should open);
    4. Find the folder “LuminarNeo” and delete it (it deletes your activation for Luminar Neo too);
    5. In the %appdata% folder, locate the folders of all previous Luminar versions (e.g. Luminar 4, Luminar AI, etc.) and move them to a different location (e.g. to the Documents folder or to the Desktop)
    6. Go to Pictures and rename the folder called Luminar Neo Catalog (if you have your Catalog anywhere else, find it and rename it).
    7. Install the app from your Skylum account once again and try to launch it.
    8. Activate the software by logging in to your Skylum account. Next, click Add Photos and add a small folder with images.

    If you're still unable to start Luminar Neo, please provide us with the new event logs:

    1. Reproduce the issue.
    2. Press the Windows logo key + R.
    3. Type eventvwr in the dialog box that opens and hit Enter on your keyboard.
    4. In the window that opens click the triangle next to Windows Logs on the left. A directory tree should open.
    5. Click Application in the directory tree. 
    6. In the main part of the window find the two topmost entries marked with Error named Application Error and .NET Runtime.
    7. Hold CTRL and click your left mouse button on each entry to select them both.
    8. Right-click on any of the two selected entries and click Save Selected Events.
    9. Name the file, save it, and attach it to your message to skylum.com/support 
    1
    Comment actions Permalink
  • Avatar
    Karl Buckholtz

    "top" one worked for me

    1
    Comment actions Permalink
  • Avatar
    Karl Buckholtz

    they give me the same old same old workarounds,nothing works to launch Neo...and they still claim it's fixed?...can't even launch Neo to see how troublesome the new program is..and perhaps there is a "method to the madness"

    0
    Comment actions Permalink
  • Avatar
    Andreas Ehmke

    Hi Henry, have you try this workaround: https://community.skylum.com/hc/en-us/community/posts/4419376944402/comments/4419408502802

    Many people have been helped this!

    0
    Comment actions Permalink
  • Avatar
    Karl Buckholtz

    this actually seemed to work

    0
    Comment actions Permalink
  • Avatar
    Andreas Ehmke

    Hi @Karl, I am glad; congratulation!

    Have a nice day!

    0
    Comment actions Permalink
  • Avatar
    Stefan Schulte-Kellinghaus

    Tania's hint worked!
    I have Luminar Neo running!

    0
    Comment actions Permalink
  • Avatar
    Felix

    @Stefan, there are 2 Tania's hints, which one that works (top or bottom?)

    Thanks!

     

    0
    Comment actions Permalink
  • Avatar
    Stefan Schulte-Kellinghaus

    Felix, it is top one, and the decisive step is probably step 5:

    In the %appdata% folder, locate the folders of all previous Luminar versions (e.g. Luminar 4, Luminar AI, etc.) and move them to a different location (e.g. to the Documents folder or to the Desktop)

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi guys, 

    Just had a chat with our devs. They've found the root cause of this issue and are already testing the fix. 

    We'll ship it as soon as all the major checks are completed. Please keep an eye out for the notification from us!

    Meanwhile, you can try the workaround shared by my colleague. 

    As Stefan has correctly stated, step 5 is the decisive one. 

    Thank you so much for sticking with us while we're working on it!

    0
    Comment actions Permalink
  • Avatar
    Ian Williams

    If you have had this same problem after updating to the latest version of Neo (mid May 2022) , as I did, you may find the above fix works.  It did for me. Vive Ukraine, and congrats on Eurovision!

    0
    Comment actions Permalink

Please sign in to leave a comment.