Neo crashes when opened – this works fine for me! :-)

Answered

Comments

58 comments

  • Avatar
    William Brooks

    Andreas:  I appreciate the effort put forth in this suggested solution - well done.

    But I'm not going to do anything more in terms of fixing Neo.  In my view that's Skylum's job.  I've bought every Skylum product since it became available, and pre-ordered when possible.   Basically I'm the definition of a loyal customer.  However that may be changing.  Ever since the debacle with upgrading Luminar 4.2 to 4.3, I hold my breath anytime there's a new Skylum update.  I purposely didn't install the Neo trial versions because I had no faith that they would perform as described.

    Having said that, I thinks it's ridiculous that a commercial product I purchased needs the user community to sort it out so that it will run.  Such a shame - I've enjoyed and used the different versions of Luminar and appreciated the innovation.  The bad press on Neo (and Skylum) has started to show up in User forums across the web.  I'm still hoping that Skylum will provide a fix (perhaps in the form of an offline installer as with Luminar 4.2), but I'm also realistic enough to know that may not happen.

    3
    Comment actions Permalink
  • Avatar
    andy gray

    Sadly this if not tesolved by Skylum themselves ( ( a clean install not a bodge ) could well be then end of the company.

    If as much time was spent of RND as they do on force feeding adertisement, maybe the product would have worked out of the box.

    For it not to be compatible with skylums own products ot Windows 11 for gods sake is unforgivable.

    So sad so disapointed

    0
    Comment actions Permalink
  • Avatar
    Andreas Ehmke

    @William, thanks for your answer and compliment!

    I get a lot of angry mails and I can understand that very well. It is also only a temporary solution, so that it runs. Of course, this can't be a permanent state, but we shouldn't forget that we all make mistakes. One of my favorite sentences of Jesus is: "He that is without fault among you, let him cast the first stone!" And suddenly nobody wanted to throw a stone anymore – why? What is wrong remains wrong, of course, but you do the right thing and forgive. And because what is wrong remains wrong, the other side must also want to do the right thing and thus do the right thing. The ball is now in Skylum's court!

    We all have a lot to learn. But the most important and difficult thing we can learn, is to forgive in the heart.

    -1
    Comment actions Permalink
  • Avatar
    Karl Buckholtz

    I'm not about to uninstall any working programs in the hope that Neo will launch.....I'd like to select the best program for my use,and as of now with Neo not launching there is no way to evaluate/compare products

    0
    Comment actions Permalink
  • Avatar
    YUNHO BAE

    After countless failures,
    I finally succeeded, too.
    Thank you.
    The problem was the existing Luminar 4 and AI.
    It seems to conflict with existing programs.
    I succeeded by changing the name of Luminar 4 and AI folder.

    0
    Comment actions Permalink
  • Avatar
    Andre Beuckelaere

    Hi Andreas (you have a beautiful name ;-) )

    Thank you so much!! It worked for me! Although I had some more little difficulties : I did all the steps you mentioned, but I already installed all previous Luminar version (from Luminar 3 on...), so I saw all those old folders (still there even if I uninstalled all those previous version except AI), and moved them. Another problem I had was that I had installed versions of Luminar on another drive too, due to (almost) a lack of space on one drive. But everything went well and my Luminar AI still works (even if I probably moved some things). Just for the record, I don't use the Luminar catalog because I prefer the LrC catalog, so fo me, Luminar works as a plug-in. So thank you very much. Herzlichen Dank!! Greetings from Belgium.

    0
    Comment actions Permalink
  • Avatar
    Londinense

    Since Skylum is based in Ukraine, they may have other things to worry about at present!

    0
    Comment actions Permalink
  • Avatar
    Andreas Ehmke

    @YUNHO, thanks for your answer and tip!
    I have adapted the instructions.

    Have a nice day!

    0
    Comment actions Permalink
  • Avatar
    Andreas Ehmke

    Hi @Andre, thanks for your answer and compliment!
    You have a beautiful name too! ;-)

    De beste wensen voor het mooie België!
    Salutations chaleureuses à la belle Belgique!
    Herzliche Grüße ins schöne Belgien!
    ... ;-)

    0
    Comment actions Permalink
  • Avatar
    Bo Seok Kim

    wow it really works!!

    Thanks and I don'y know why the hell should we do this

    So disappointing to Skylum

    0
    Comment actions Permalink
  • Avatar
    Andreas Ehmke

    Hi Be Seok, thanks for your answer!
    I am happy; congratulation!

    And correct but nobody is perfect; we are all humans.

    Have a nice day!

    0
    Comment actions Permalink
  • Avatar
    Member

    I'm not about to delete working programs in the hope that Neo will work.
    Skylum should be trying to fix this problem quickly.

    0
    Comment actions Permalink
  • Avatar
    Daryl P

    Hello all,

    Firstly, thanks to Andreas, as the solution he put forth did work for me and I now have Neo launching and seemingly working correctly.  

    I so rarely use Luminar Ai or 4 although having both, but when I have used them for the Sky Replacement functionality, it worked wonderfully.  It had been so long since my last use that Luminar 4 prompted for an update, but Ai was apparently still current.  Meanwhile, given the failure of Neo to launch, I had uninstalled it.  As such, my application of Andreas' solution differed in the context that I started off with Neo uninstalled.  So, the steps I follwed were:

    1.  From the AppData/Roaming (%appdata%) folder, move any existing Luminar product folders to another folder, the Desktop being a convenient location.
    2.  From the Pictures folder, move any Luminar Catalog folders from there to again, the Desktop or other convenient folder.
    3.  Ensure the Recycle Bin is empty.
    4.  Install Neo.   When I did so, it prompted me to log in for activation, so this was already looking better, and it did in fact work.
    5.  Launch Neo, confirm it is operational.  It was.
    6.  Launch other Luminar programs to confirm they appear unaffected.  I did, and I saw no obvious problems but did see Luminar 4 required an update which I applied and then successfully launched that program.
    7.  Close out of any open Luminar programs.
    8.  Restore Luminar folders moved from AppData/Roaming back to that folder, from where they were temporarily relocated, and likewise do the same for the Luminar Catalog folders, restoring them to the Pictures folder.
    9.  Relaunch all Luminar applications and confirm they all work.

    10.  Echo the truth of what others have said...that Skylum should have promptly acted upon this issue and posted a solution rather than wait for users to figure it out.  I also agree that Skylum should provide offline installers.

    To be clear, I did not uninstall either Luminar 4 or Ai, but I did already have Neo uninstalled since it was failing to launch.  So, the solution as described was relatively easy to perform.

    0
    Comment actions Permalink
  • Avatar
    Tan Li Teck

    Until this moment, Skylum hasn't done much in helping the community to solve the problem and this very disappointing. If they still have a tiny bit of responsibility, they should be making a video of the above solution and post it in the community as a temporary fix. Not everyone is well verse enough to follow all those instruction and solve the problem themselves. 

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi guys, 

    We've had a chat with our devs today. They've already created the fix and are testing it.  

    We'll ship it ASAP, as we understand how greatly it's affecting our Windows community. 

    Thank you so much for sticking with us while we're working on it, and I'm sorry for all the hassle you've had to go through so far. 

    We'll let you know once it's available globally. 

    UPD: The hotfix has been released. 

    0
    Comment actions Permalink
  • Avatar
    andy gray

    Hi Kate.
    I presume those of us who have sorted issue, do not need to reinstall?

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi Andy,

    That's correct.

    There's no need to reinstall the software. You can just install a new update by clicking Luminar Neo > Help > Check for updates, as it also contains some performance improvements. 

    0
    Comment actions Permalink
  • Avatar
    andy gray

    thanks kate......enjoying product by the way...lol

    installed update no issues....

    0
    Comment actions Permalink
  • Avatar
    Elmar Harbecke

    These piece of software is still annoying - after four times deleting and (re)installing it.
    Anyway, it stopped always at the point when it tries to connect to activate via internet. And believe me, I stopped the firewall and antivirus program to get a connection during installation.

    I have payed for it three month ago, now I have got a software that doesn't work!?! Very disappointing.
    So, Skylum please deliver a software that works. The ball is on your side.

    Hope to get a running software soon...

    0
    Comment actions Permalink
  • Avatar
    Member

    Hi Guys
    Just uninstalled Neo and Reinstalled using Luminar's new installer and Neo seems to be working properly.
    Thank you to all involved at fixing the problem.

    0
    Comment actions Permalink
  • Avatar
    Daryl P

    Confirmed for me as well...without uninstalling Neo after finally getting a successful launch of the product, I allowed the update to download and apply over the existing installation.  That worked without any issues and Neo continues to launch successfully.  Thank you Skylum.

    0
    Comment actions Permalink
  • Avatar
    Andreas Ehmke

    Thank you @andy gray for your inquiry and @Kate Williams for your quick reply and support!

    Andy, I now refer first to the Skylum update!

    Neo also runs much faster with this. But I still feel like I have to wait almost minutes for a new tool to run anywhere near smoothly. The main ones to mention here are Develop, Enhance, Details and Image Noise, and the Portrait AI tools. Switching between or to these tools requires a cup of coffee first ... ;-/

    It's the same when I want to hide them for a short time (eye icon/before and after function). Because I have to keep the mouse pressed all the time, I can't even get a coffee in that time. ;-D

    Is it the same for you?
    Maybe we should open a new post about that too?

    Thanks for your answer!

    0
    Comment actions Permalink
  • Avatar
    andy gray

    Andreas yes the delay is excessive, and Neo gets "locked" up if u remove mouse click and reapply. This delay does need sorting.

    And my hardware is i9 32mg ram

    A seperate thread for all operational issue would be useful.

    0
    Comment actions Permalink
  • Avatar
    William Brooks

    I received an email today from Skylum Support regarding my trouble ticket on Neo crashing at the splash screen.  I am attaching the body of the email, and most importantly it worked!  Hope this is helpful.

    ---------------------------------------------------------------------------------------------------------------------------------------------

    Email:  

    We're also sorry to hear the issue persists. Our developers have already come up with another update that includes the fix, so could you please try reinstalling the app in the following way once again? I'm afraid this is the only way we can replace the versions on your device and make sure the correct one is fully installed.

    1. Go to “Apps and Features” by right click on the Start button;
    2. Find Luminar there and click [Uninstall] (you can also uninstall from the Control Panel);
    3. Type %appdata% in Search (folder Roaming should open);
    4. Find the folder “LuminarNeo” and delete it (it deletes your activation for Luminar Neo too);
    5. Go to Pictures and rename the folder called Luminar Neo Catalog (if you have your Catalog anywhere else, find it and rename it).
    6. Install the app once again and launch the most recent update: https://downloads.skylum.com/luminarneo/win/Win_Luminar_Neo.msi 
    7. Activate the software by logging in to your Skylum account. Next, on the Welcome to Luminar Neo screen, click on the + button and add a small folder with images or a single image for editing. 

    Please, let us know how it goes now.

    Kind regards,

     

    0
    Comment actions Permalink
  • Avatar
    Andre Beuckelaere

    No, we are far from our sufferings! I'm trying to update Neo. The download starts, and the installation too. But then I get a message "Something went wrong, can not update. If problem persist, contact support". Maybe it's getting a little too much! for such a program. When will we be able to use the program. Why do I have the impression that the "early birds" served as guinea pigs.

    0
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hello Andre,

    I am sorry to hear about the installation issue.

    Could you please try using this installer - https://downloads.skylum.com/luminarneo/win/Win_Luminar_Neo.msi?

    0
    Comment actions Permalink
  • Avatar
    Jerry Hayter

    This is beyond a joke.

    Either fix it, or refund please.

    If you dont do one or the other quickly, i will use the credit card guarantee scheme here in the Uk, and have it refunded any way.

    Over to you!

    0
    Comment actions Permalink
  • Avatar
    Kevin Orchard

    Tech Support Team,

    I see these posts are from 4 months ago (March), but I now am getting this error/problem of not opening in stand a lone mode. I only purchased my version of L-Neo this month (June) and do not have any other skylum software on my PC (Windows 10).

    My questions are

    1) Why is there still an issue?

    2) Why as this not been fix in an update release?

    I am a photographer not a IT person and not willing to change my other software, computer settings to make Neo work and risk other errors with other software, that's your job.

    This brings me to my final couple of questions to you.

    3) How much more time do you need to fix this? Given you've already had 4 months and it's still happening.

    4) How do I get a refund?

    Back to you Tech Support.

    0
    Comment actions Permalink

Please sign in to leave a comment.