Luminar Neo doesn't work...at all !!!!

Answered

Comments

37 comments

  • Avatar
    David Larsen

    Same here/ Splash Screen stays on monitor for a couple minutes and just goes away.

    Re-installed the 'newer' msi version -- same thing.

    1
    Comment actions Permalink
  • Avatar
    Pablo Esvertit

    Hi everybody,

    Same here in Windows 10. It's anoying when you look by Internet, so many people with the same issue! How can it be?

    Anyway, I have send the error log files to Skylum support...Hope Skylum provides a solution soon.

    Cheers

    0
    Comment actions Permalink
  • Avatar
    Todd Browning

    I am having the same problem.  I get the splash screen and then nothing.  Any suggestions would be greatly appreciated.

    0
    Comment actions Permalink
  • Avatar
    Byron Thomas

    Same o same o.

    I downloaded and installed the "hot fix" today. Still crashed after launching. I uninstalled Neo and the exe. file and downloaded again. Still crashed. Makes one wonder????

    Sent logs to Support.

    Hopefully!!!

    0
    Comment actions Permalink
  • Avatar
    Vincent Serge

    I've managed to launch it finally by following the procedure recommended by Skylum and by usingthe .msi installer. BUT... ther's now a new downside, I'm stuck at the activation windows! I use a linked FB account and when I click on the icon in tha activation window I'm redirected toward a page that tells me the activation is ok, but still the programm stay on the activation process and doesn't go further!

    That new Luminar is a real pain in the....

    3
    Comment actions Permalink
  • Avatar
    Roy Blackwell

    Vincent Serge - do not know if this is your issue, but to properly activate your software, you must use the same email address you used when you purchased the software.

    0
    Comment actions Permalink
  • Avatar
    Pablo Esvertit

    Vincent, what is the procedure recommended by Skylum? Do you mean the one related to change the name of the catalog folder and file?

    0
    Comment actions Permalink
  • Avatar
    FRED LUYT

    I have th same problem. When Neo is activated I get the logo with a message "Update to Windows 10 to use <AppName>

    0
    Comment actions Permalink
  • Avatar
    Elena Blum

    Hi FRED,

    Please do the following:

    1. Right-click on the Luminar icon.
    2. Go to Properties > Compatibility.
    3. Do you have the 'Run this program in compatibility mode for: Windows 8' checkbox enabled? If so, please disable it. 
    4. Press 'Ok'.
    -1
    Comment actions Permalink
  • Avatar
    Vincent Serge

    Pablo Esvertit : Yes, we speak of the same procedure, it worked for me and enabled me to launch the program. But I'm still can't activate it!

     

    0
    Comment actions Permalink
  • Avatar
    Pablo Esvertit

    Thanks Vincent. This workaround doesn't work for me... Let's wait for Luminar solution.

    0
    Comment actions Permalink
  • Avatar
    Tina Olympus

    I have the same problem. Installed Luminar Neo today. The start window appears for a few seconds. After that nothing more. The CPU is being used at 100% and is overwhelmed. I have Win 10Pro with Intel Core i-8700K 6 cores at 3.7GHz.Luminar AI works.

    0
    Comment actions Permalink
  • Avatar
    Tina Olympus

    Excuse me. That can't be the problem. The CPU is also stressed when launching Luminar AI. I just tested it.

    0
    Comment actions Permalink
  • Avatar
    Vincent Serge

    SO I've finally managed to solve my activation problem, here's what I did to fix it, hoping it helps others.

    The problem seems to be connected with the "linked account" like FB. So, firts I logged out from the Skylum website and then created a new account using the "Sign up with email", of course you have to use the same email adress you used when you bought Luminar. In the fileds enter your mail adress and then create a password. And... that's it, it worked just fine after that!

     

    1
    Comment actions Permalink
  • Avatar
    Tania Taylor

    Hi everyone!

    Vincent, thank you for bringing the FB login issue to our attention and for sharing the solution!

     

    As for the crash on start, could you please try to launch Luminar Neo this way: right-click on the application icon > Run as administrator? 

    If it doesn’t work, please try reinstalling the app in the following way:

    1. Go to “Apps and Features” by right click on the Start button;
    2. Find Luminar there and click [Uninstall] (you can also uninstall from the Control Panel);
    3. Type %appdata% in Search (folder Roaming should open);
    4. Find the folder “LuminarNeo” and delete it (it deletes your activation for Luminar Neo too);
    5. In the %appdata% folder, locate the folders of all previous Luminar versions (e.g. Luminar 4, Luminar AI, etc.) and move them to a different location (e.g. to the Documents folder or to the Desktop)
    6. Go to Pictures and rename the folder called Luminar Neo Catalog (if you have your Catalog anywhere else, find it and rename it).
    7. Download the app from the Skylum account once again and try to launch it.
    8. Activate the software by logging in to your Skylum account. Next, click Add Photos and add a small folder with images.
    0
    Comment actions Permalink
  • Avatar
    Johnson Dsouza

    Hi Guys,

    Finally managed to get it working. Here is what i did -

    1. Uninstall Luminar Neo

    2. Reinstall - created a new folder for installation i.e c:\Program Files\NSkylum

    After installation the windows popup for activation appeared. Entered the login details and its up and running.

    Hope this helps.

    0
    Comment actions Permalink
  • Avatar
    Johnson Dsouza

    Make sure to close skylum login page.

     

    0
    Comment actions Permalink
  • Avatar
    Jerry Hayter

    Very disappointing - Neo simply will not activate.

    Late delivery of a product that doesnt work; what on earth are Skylum playing at here?

    All this stuff about creating different folders etc etc is not acceptable. Skylum - you need to find a solution ASAP please!

    0
    Comment actions Permalink
  • Avatar
    Tania Taylor

    Hi Jerry Hayter!

    I'm sorry to hear that you can't activate the app. Please get back to us via skylum.com/support and describe the issue you're facing, and we'll do our best to help you. We can reset your password on our end if that is the case.

    0
    Comment actions Permalink
  • Avatar
    Jerry Hayter

    Its certainly not the password, its the same issue as all the other people are facing, why are you 'spinning' that this is a password issue?!

    Neo just doesn't work, it freezes at the splash screen!

    If Skylum wont even acknowledge the problem, then they obviously have no intention of finding a solution!

    0
    Comment actions Permalink
  • Avatar
    Tania Taylor

    Jerry Hayter could you please describe the issue in detail, so that we could be on the same page? It might be that your case is not connected with the one discussed in this thread as the activation issue can be solved with the above recommendations.  

    0
    Comment actions Permalink
  • Avatar
    Jerry Hayter

    Nero freezes at the splash screen - end of, and i can see that i am one of MANY purchasers out there with the same problem.

    I've tried installing it: normally, using your recommended links, the MSI file that you suggested, and have even renamed the installation directory and other things too. Nothing makes any difference.

    The solution is simple - either supply some software that functions, or arrange a refund please.

    Enough is enough!

    0
    Comment actions Permalink
  • Avatar
    Phitier Francisco

    @ jerry hayter I've also done all of those and I still can't log in. It's been days since I sent emails for help. But support never came around for me.

    I think I would like a refund as well. So far, it's pretty much a huge waste of time.

    0
    Comment actions Permalink
  • Avatar
    Jerry Hayter

    Here in the UK we have something called 'the credit card guarantee'. That means that if the supplier refuses to refund for faulty goods or services, the credit card company will do it for you and deduct the money from that supplier. See: https://www.which.co.uk/consumer-rights/advice/can-i-claim-on-my-credit-card-when-something-goes-wrong-amrSG5y3xh7b 

    So, Skylum have a choice - either refund, or provide some software that works!

    Personally, I would prefer the latter, but I see no sign whatever that Skylum are making any effort whatsoever to put this right.

    Good luck to you!

    0
    Comment actions Permalink
  • Avatar
    Ivan Azure

    Hi Jerry and Phitier,

    We are sorry to hear that you have such reflections. We also apologize for the late answers - during the last few days, an excessive number of requests was circulating. Hope for your understanding.

    Could you please specify whether you followed the reinstallation instructions Tania posted above? If the issue persists, could you please send us the following data via  support@skylum.com:

    Let us know your hardware configuration:

    N.B. The links are clickable and show the screenshots that can guide you, if necessary.

    Here is the video tutorial on how to retrieve your system infohttps://www.loom.com/share/97aff7951ee3412daa020f1d88eb36e8 

     

    Second, please send us event logs:

    1. Press the Windows logo key + R.
    2. Type eventvwr in the dialog box that opens and hit Enter on your keyboard.
    3. In the window that opens click the triangle next to Windows Logs on the left. A directory tree should open.
    4. Click Application in the directory tree. 
    5. In the main part of the window find the two topmost entries marked with Error named Application Error and .NET Runtime.
    6. Hold CTRL and click your left mouse button on each entry to select them both.
    7. Right-click on any of the two selected entries and click Save Selected Events.
    8. Name the file, save it, and attach it to your reply to this email.

    Here is the video tutorial on how to collect logshttps://www.loom.com/share/d7d8325cb83b4539a0a2dae3ebf286f6 

    0
    Comment actions Permalink
  • Avatar
    Jerry Hayter

    Even your response here is unacceptable. The first part of your technical instructions I can do, but the second half doesn't seem to work.

    So, for the avoidance of doubt, ENOUGH IS ENOUGH, Neo is clearly not fit for purpose! Either, provide some software that works, within say 10 days from 24.02.2022, or arrange a refund.

    I look forward to hearing from you.

    0
    Comment actions Permalink
  • Avatar
    Member

    I can't register the product either. After I enter my email and password, it just sits there forever. It's clearly the right password since I logged in to download!

    0
    Comment actions Permalink
  • Avatar
    Jerry Hayter

    My problem exactly; Neo is clearly not fit for purpose.

    However, it appears that Skylum are based in Ukraine, a so I'm going to stick with them until they are able to deal with this.

    It must be a very minor irritation, compared with the terrible things that their country is going through.

    0
    Comment actions Permalink
  • Avatar
    Member

    Hey Jerry - completely agree. Somehow I found the forum but not the Ukraine banner. I hope they are all okay and that peace will prevail quickly!

    0
    Comment actions Permalink
  • Avatar
    Ivan Azure

    Hi Jerry and Member,

     

    We appreciate your understanding. 

     

    Jerry, we have answered you via support@skylum.com.

     

    Member, don't hesitate to get in touch with our support team via support@skylum.com or https://skylum.com/support and we will investigate your case more thoroughly.

    0
    Comment actions Permalink

Please sign in to leave a comment.