Luminar has a number of bugs, and not much support

Answered

Comments

3 comments

  • Official comment
    Avatar
    Helga Rowles

    Hi Member,

    I haven't been able to locate your ticket with the email address that is associated with your account here.
    Did you use another email to contact our support team? If so, could you let us know which one? We'd like to review your case.

    When we receive a bug report, we try to reproduce the issue on our end following the steps outlined by the customer.
    If the issue cannot be reproduced, we need to collect additional information that might have been unnoticed at first glance and screen recordings are perfect for this. 

    > The catalog issue seemed to have went on for quite some time. - are you referring to the issue with images being lost after Big Sur updates? If so, it has already been fixed for Luminar AI.

     

    Comment actions Permalink
  • Avatar
    Black Eyes

    In best case, Skylum team will give some workarounds "try this, then try that ...". They also give customers "empty promises", mostly the bugs are not fixed. That's it!

    1
    Comment actions Permalink
  • Avatar
    Brad Slama

    My only gripe has been the apparent removal of Wacom tablet support following the 1.5 update. It worked with every iteration prior including the original Luminar, Luminar 3, 4 and the initial release of AI.  Why their stance now is that they don't officially support Wacom tablets in this software is other-worldly at best. I might have other complaints yet, I don't use the software due to what I've listed above. If Neo is the same way, I won't use that either.

    0
    Comment actions Permalink

Please sign in to leave a comment.