Luminar AI Update 5: Recommended skies and minor bug fixes

Pinned

Comments

19 comments

  • Avatar
    Sam Walker

    I went from AI 4.1 to 5 as I've been using Luminar 4 mostly because of the loading and speed issues with AI. So I missed the 4.3 updates.
    I still haven't built my newer system, so this is running on an older system with only 6 cores and 32 GB of DDR3 memory. So my times may be slower than on a newer system.

    Load time on splash screen went from 5 minutes to 1.5 minutes. The program is more responsive and not so laggy. Big improvement. You're almost there.

    To me this was a big step forward. However, if you want me to shell out money for NEO, optimize the speed of the AI a bit more. 

    Kudos to the programmers for this update though. They obviously did some extensive work.

    0
    Comment actions Permalink
  • Avatar
    Ulrich Goetze

    I found the added Icon for preorder NEO right in the upper Menu bar a bit annoying and outrageous.
    I really don`t like such annoying marketing,
    (Only my personal opinion..)

    2
    Comment actions Permalink
  • Avatar
    Harry Conte

    @Ben Smallbone.  I feared this happening since for me they have never been able to solve the same problem with Ver.1.4.1.  I'm not loading Ver. 5 until they work out the bugs.

    1
    Comment actions Permalink
  • Avatar
    Ben Smallbone

    Harry Conte I Think I've sorted it not loading. Just before the crash I had tried to locate a folder that I had moved and pointed it in the right direction. Now I've moved the folder to a new directory to see if this would help and now back up running. Still not a good experience though.

    0
    Comment actions Permalink
  • Avatar
    Harry Conte

    Great to hear.  I'm still going to wait a while.

    2
    Comment actions Permalink
  • Avatar
    Thomas Yager

    The program will not export a file now that I have added Update 5.  It just keeps trying (100% CPU use, not out of memory).  

    0
    Comment actions Permalink
  • Avatar
    Harry Conte

    Thomas, let me know how that turns out and what steps they take to solve the problem.

    0
    Comment actions Permalink
  • Avatar
    Prakash Sampath

    Is the offline installer updated to the latest version? And also how is the compatibility with Windows 11? 

    0
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hello Prakash,

    Here is the offline installer for Windows - https://downloads.skylum.com/luminarai/win/Win_Luminar_AI_Release.msi

    Luminar AI works on Windows 11 just fine!

    0
    Comment actions Permalink
  • Avatar
    Scott Battaion

    I have looked through the posts for information on how to best photograph my own skies to use. I've followed the instructions regarding size, resolution, angle, perspective, direction, etc. No matter what I do when the sky is replaced it is definitely pixilated (the rest of the image is not) and it appears pretty obvious that the sky in the photo has been replaced and is not the original. As an experiment I shot a landscape photo with a cloudy sky and definite horizon. I then shot the same scene at the same time but only captured the sky. I then used that sky to replace the one in the photo and it too was pixelated. This should not be the case as it was exact same scene shot at the same time of day with the same lighting using the same camera/lens at the same settings. The only difference is that the original photo was raw and the sky had to be converted to jpg as required by the software. Conversion was a 85% quality and full size (not scaled). I have tried other skies that I have downloaded and nearly all of them are pixelated too even though when viewed just by themselves they seem to be reasonably good quality. Is Luminar AI doing something to the sky image when adding it to the photo? Thoughts?

    0
    Comment actions Permalink
  • Avatar
    Elena O'Brien

    Hi Scott Battaion,

    Are you, by any chance, working with high resolution images?

    0
    Comment actions Permalink
  • Avatar
    Scott Battaion

    Both images are Lumix GX-85 camera raw files at the same resolution. However, per requirements the sky has to be converted to jpg before it can be imported and used. In Luminar AI I open the raw file and then replace the sky using the jpg file. It seems this is the only way it can be done. I can use a tiff or jpg instead of the raw as the base image file format but it seems pointless to have to convert the raw to jpg first before replacing the sky. I didn't see anything in the documentation stating that both file formats (base image and sky image) had to be the same. Am I missing something here?

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Ji Scott Battaion,

    SkyAI will work with your own photos if they are in one of the following formats: JPEG, JPG, PNG, and TIFF. 

    Thus, you can also try using TIFF images as custom Skies to preserve the maximum quality.

    1
    Comment actions Permalink
  • Avatar
    Scott Battaion

    I also tried TIFF but without any luck. After some experimenting I found a process that works pretty well:

    • Take original photo in Large/High Quality JPG format.
    • Do not process the image in any way--only crop if necessary.
    • Export at maximum resolution, 85 percent quality, no sharpening on export.

    Once I did this the sky replacement worked much better and appeared to be much more natural. Any modification to the sky (hue, saturation, sharpening, etc.) can take place when processing the full, composited image. The result was a seamless merging of the sky without any pixilation or artifacts.

    0
    Comment actions Permalink
  • Avatar
    Victor Abalos

    Hello:

    Is there any chance LuminarAI servers are down? I am unable to use it. For the past few days, LuminarAI (as plugin for Lightroom Classic) had been working fine. But last night and today, LuminarAI stopped making changes to edited image back to Lightroom. The Apply button disappears for a while after clicking, then the app closes. But the image is not showing as processed in LuminarAI back to Lightroom Classic. Previously, when I clicked Apply, there would be a line going back and forth to indicate that LuminarAI is processing it. But now, I don't see it anymore. I have uninstalled and reinstalled LuminarAI from Skylum web account - still same problems.

    I have emailed Skylum support regarding the above and just checking here if someone else is experiencing the above and/or has suggested solutions.

     

     

    0
    Comment actions Permalink
  • Avatar
    Tania Taylor

    Hi Victor Abalos!

    We have received your request and will process it asap. 

    0
    Comment actions Permalink
  • Avatar
    Wilfried Bicher

    Hallo,

    where can I find the current offline version of Luminar AI, not 4 weeks old?

     

    0
    Comment actions Permalink
  • 0
    Comment actions Permalink
  • Avatar
    Diana Day

    I finally found a way to close a single image without saving it. Click on LuminarAI in the upper left corner, then click on Image, then click on Remove from Single Image Edits.

    Hey, Skylum developers, could you create a keyboard shortcut for that sequence. Ctrl-W, like Photoshop uses would be a good Shortcut.

    0
    Comment actions Permalink

Please sign in to leave a comment.