Luminar A1 very slow after update

Answered

Comments

11 comments

  • Avatar
    Margaret Bright

    Hi Ken,

    Please kindly try resetting your PRAM to improve the performance. Here is how you can do that:

    https://support.apple.com/en-us/HT204063 

    Please note that you might be asked to reset some of your computer adjustments such as date and time, mouse settings, etc.

    If the issue persists, please get in touch with our support team at https://skylum.com/support. They will assist you further.

    As for Luminar Neo, it has a brand new core that was developed specifically to provide better performance.

    -2
    Comment actions Permalink
  • Avatar
    Black Eyes

    Pram Reset has not improved Luminar AI performance, even 1 second, on my computer.

    When I see Luminar AI performance, I would not spend any money for Skylum product.

    With the release of Luminar Neo, I wonder if Skylum will let Luminar AI in the current condition: poor performance, high resources consumption, unreliable ???

    1
    Comment actions Permalink
  • Avatar
    Cathy Greene

    Thieve these issues are so disheartening. It feels like the folks atSkylum are on to their next great thing without making sure the current product is running smoothly. So disappointed.

    1
    Comment actions Permalink
  • Avatar
    Ken McEwen

    Still very slow when starting up. Looking at activity monitor the strange thing is the amount of time it now spends with very low CPU usage of single figures as activity monitor shows the application is not responding. Then it gives a few bursts of double figures before hitting three figures and eventually opening the app.

     
    The other noticeable thing is that, if I follow one Luminar AI edit quickly after another it opens quite quickly. Leave it for any length of time and I am back to an eight minute “application not responding” before it finally opens.
     
    Disappointing since the previous versions were reasonably quick to open. 
    2
    Comment actions Permalink
  • Avatar
    Michelle Russell

    I thought my MacBook pro was the problem.  I have been having the same issues for the last few days.  I have so many photos to process and edit I feel like I ave no choice but to jump to another program.  I have wasted so much time on each photo this has been so disheartening! I have really loved using the Luminar products. Please fix this so I can come back to Luminar!

     

    0
    Comment actions Permalink
  • Avatar
    Anastasiia Moore

    HI Black Eyes!

    I'm sorry to hear that you're experiencing an issue with the app's speed. Let me kindly note that performance depends on various factors, such as the number of photos in your Catalog, their format, size, storage location, etc. We are always ready to troubleshoot the performance issue if it is convenient for you. Would you be so kind as to reach us at https://skylum.com/support so we could assist you further?

    Looking forward to hearing from you.

    0
    Comment actions Permalink
  • Avatar
    Anastasiia Moore

    Hi Ken McEwen!

    I'm sorry to hear that the issue persists. I could not find your support request regarding it. Would you be so kind as to contact the support agents at https://skylum.com/support so they could investigate it further? Many thanks for considering my request. Hope to hear from you soon.

    0
    Comment actions Permalink
  • Avatar
    Anastasiia Moore

    Hi Michelle Russell !

    I'm terribly sorry to hear that you've had an unpleasant experience working in Luminar AI.

    Could you please clarify whether you tried resetting your PRAM as Margaret advised? If yes, could you please inform us if the issue appears using Luminar AI as a Photos extension or using the app in a standalone mode? How many images are there in your Library? Where are they located (on an internal or external drive)? What's the format and size of files you're working with? 

    Can you please kindly reach us via  https://skylum.com/support ? We'll gladly troubleshoot the performance issue so you could enjoy the editing in Luminar AI. 

    Looking forward to hearing from you.

     

    0
    Comment actions Permalink
  • Avatar
    Ken McEwen

    Hi Anastasia

    Will post a support request as you suggest as – at the moment – with RAW images taking 8-9 minutes to open and simple jpegs 5-6 minutes, Luminar AI is virtually unusable. That's a shame, because, on the occasions I have asked it to open an image and had the luxury to go and do something else for ten minutes while it opens, it works as impressively as before, but with the obvious enhancements. 

    Thanks

    Ken

    0
    Comment actions Permalink
  • Avatar
    Black Eyes

    Hi Anastasia,
    Perhaps you should check my file before to ask me to contact your support. Again you mentioned that performance depend on the customer computer configuration. My computer matches Skylum's requirements. I think the poor performance is due to the low performance of the software.

    Your support proposed only PRAM reseting, which did help at all. Then they proposed some free stuffs ... that's it.

    Skylum team affirmed now already 9 months that performance improvement and optimizing the use of resources are your top priority ... After 9 months, we do know see any improvements. I wonder if Skylum do not tell the truth or your developers really need trainings.

    Regards

    1
    Comment actions Permalink
  • Avatar
    Ken McEwen

    Well, that is a surprise. I was in correspondence with support. They suggested deleting and reinstalling and some other steps, to try to resolve the issue. I knew that would take some time and decided to leave it a couple of days. In those couple of days the issues have resolved themselves, without any action from me. Even before I downloaded update 5, Luminar AI was opening in a minute or less (either the app or the plugin on Apple photos). I don't know how that improvement happened, but, I am happy. 

    Regards

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.