LuminarAI Update 4.1: We’ve caught some bugs!

Pinned Featured

Comments

12 comments

  • Avatar
    Mark Barnes

    Will this update prevent Catalog corruptions in DAM going forward? 

    0
    Comment actions Permalink
  • Avatar
    Stan Corpuz

    A Serval attempt to download this version returns an error. There is no specific message error other than saying there is an error and try again. I get the error approximately 1.3 GB into the download.

    0
    Comment actions Permalink
  • Avatar
    Helga Rowles

    Hi Mark - Are you referring to the issue with the incorrect synchronization of images and folders in the catalog after Big Sur updates? If so, the issue was fixed in Update 4 for Luminar AI. However, although the fix will prevent the catalog from corrupting after future Big Sur updates, it won't fix the catalog that has already been corrupted. Therefore, we recommend working with a new catalog. In case you need to finish important edits in the previous catalog, you can revisit it by clicking File > Catalog > Open (recent.

    0
    Comment actions Permalink
  • Avatar
    Helga Rowles

    Hi Stan - I'm sorry to hear you're having issues updating Luminar AI.
    Please try installing the latest version using the installer below:
    https://downloads.skylum.com/luminarai/win/Win_Luminar_AI_Release.msi 

    If further assistance is needed, please reach our support team at skylum.com/support

     

    -1
    Comment actions Permalink
  • Avatar
    Stan Corpuz

    Hi Helga,

    I'm getting a 404 Error (Page not found) when selecting the link below

    https://downloads.skylum.com/luminarai/win/Win_Luminar_AI_Release.msi 

     

     

    -1
    Comment actions Permalink
  • Avatar
    Dominic Bopp

    Try this, Helga's link has some weird ASCII stuff at the end:

     

    https://downloads.skylum.com/luminarai/win/Win_Luminar_AI_Release.msi

    1
    Comment actions Permalink
  • Avatar
    Andy S

    Urm Skylum support, you've given Stan the Windows download when he's posted for support in the Mac area of the forum... 

    Also for some reason for every version of Luminar AI after 1.2.0, when I try to use Luminar as an Apple Photos extension - I click edit with -> Luminar and the following error pops up:

    --------

    Couldn't communicate with a helper application.

    Try your operation again. If that fails, quit and relaunch the application and try again.

    --------

     

    This is MacOS Big Sur, all versions up to latest patch.

    Nothing works to get it to open; I replace Luminar.app with the AI 1.2.0 version and it works fine again.

    I contacted Apple who stated that it is a problem with 'the vendors application'.

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Andy S,

    I'm sorry you've faced this issue. Please, reach us via https://skylum.com/support so we could help you with this.

    0
    Comment actions Permalink
  • Avatar
    Carmen Falkenburg

    Hi hi I’m very upset as my Luminar 4 keeps constantly crashing on my Mac  OS , it’s never done this before . I use it for most of my photo editing . Please explain why this is all of a sudden happening 

    0
    Comment actions Permalink
  • Avatar
    Ivan Azure

    Hi Carmen,
    Please contact our support team via support@skylum.com or https://skylum.com/support and we will consult you in a more detailed way.

    0
    Comment actions Permalink
  • Avatar
    Colin Tume

    updated to the new version and now the app won't load. it crashes after showing the flash of Lunimar AI and won't open. I tried deleting the catalogue and it started a new catalogue and worked for a day then failed again. I have deleted and shut down. restarted my Mac and downloaded again still won't work. I have had the program since it was released with no issues. 

     

     
    Process:               Luminar AI [2580]
    Path:                  /Applications/Luminar AI.app/Contents/MacOS/Luminar AI
    Identifier:            com.skylum.luminarAI
    Version:               1.5.3 (12191)
    Code Type:             X86-64 (Native)
    Parent Process:        launchd [1]
    User ID:               501
     
    Date/Time:             2022-11-13 13:01:31.4251 +1030
    OS Version:            macOS 13.0.1 (22A400)
    Report Version:        12
    Anonymous UUID:        *****************
     
     
    Time Awake Since Boot: 4700 seconds
     
    System Integrity Protection: enabled
     
    Crashed Thread:        9  Dispatch queue: com.skylum.DBCoreWrapper.block-dispatcher.<MPDBCatalog: 0x60000022c5c0>
     
    Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
    Exception Codes:       0x0000000000000001, 0x0000000000000000
     
    Termination Reason:    Namespace SIGNAL, Code 11 Segmentation fault: 11
    Terminating Process:   exc handler [2580]
     
    VM Region Info: 0 is not in any region.  Bytes before following region: 4345626624
          REGION TYPE                    START - END         [ VSIZE] PRT/MAX SHRMOD  REGION DETAIL
          UNUSED SPACE AT START
    --->  
          __TEXT                      103050000-1031b4000    [ 1424K] r-x/r-x SM=COW  ...OS/Luminar AI
     
    Thread 0::  Dispatch queue: com.apple.main-thread
    0   CoreFoundation                    0x7ff810cd1f58 __CFStrHashEightBit2 + 46
    1   CoreFoundation                    0x7ff810cd1eb8 __CFSearchStringROM + 31
    2   CoreFoundation                    0x7ff810cd1954 __CFStringCreateImmutableFunnel3 + 1961
    3   CoreFoundation                    0x7ff810cde749 CFStringCreateWithBytes + 27
    4   CoreFoundation                    0x7ff810df86d9 ____CFBinaryPlistCreateObjectFiltered_block_invoke + 53
    5   CoreFoundation                    0x7ff810d093a0 __CFBinaryPlistCreateObjectFiltered + 964
    6   CoreFoundation                    0x7ff810d0a549 __CFBinaryPlistCreateObjectFiltered + 5485
    7   CoreFoundation                    0x7ff810ceb192 __CFTryParseBinaryPlist + 237
    8   CoreFoundation                    0x7ff810de89ec _CFPropertyListCreateWithData + 155
    9   CoreFoundation                    0x7ff810ceb038 CFPropertyListCreateWithData + 51
    10  DiskArbitration                  0x7ff818090a20 _DAUnserializeDiskDescription + 28
    11  DiskArbitration                  0x7ff81809097c _DADiskCreateFromSerialization + 48
    12  DiskArbitration                  0x7ff81809067d _DADispatchCallback + 60
    13  DiskArbitration                  0x7ff81809042e _DASessionCallback + 259
    14  CoreFoundation                    0x7ff810d7b486 __CFMachPortPerform + 282
    15  CoreFoundation                    0x7ff810d4e101 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE1_PERFORM_FUNCTION__ + 41
    16  CoreFoundation                    0x7ff810d4e03e __CFRunLoopDoSource1 + 540
    17  CoreFoundation                    0x7ff810d4ccbb __CFRunLoopRun + 2705
    18  CoreFoundation                    0x7ff810d4bbb0 CFRunLoopRunSpecific + 560
    19  HIToolbox                        0x7ff81a62dbd6 RunCurrentEventLoopInMode + 292
    20  HIToolbox                        0x7ff81a62d9e6 ReceiveNextEventCommon + 679
    21  HIToolbox                        0x7ff81a62d723 _BlockUntilNextEventMatchingListInModeWithFilter + 70
    22  AppKit                            0x7ff813e6eb37 _DPSNextEvent + 909
    23  AppKit                            0x7ff813e6d9b8 -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1219
    24  AppKit                            0x7ff813e5fff3 -[NSApplication run] + 586
    25  AppKit                            0x7ff813e34058 NSApplicationMain + 817
    26  Luminar AI                           0x103053a54 main + 217
    27  dyld                              0x7ff810942310 start + 2432
     
    Thread 1:
    0   libsystem_pthread.dylib          0x7ff810c6ec58 start_wqthread + 0
    0
    Comment actions Permalink
  • Avatar
    Anastasiia Moore

    Hi Colin Tume,

    Please try the following steps:

    • Hold down the Option key on your keyboard and start Luminar. Keep holding Option until you see a window with a list of available backups appear.
    • Select a backup that was created before you encountered the issue with the library and click Restore from Backup.

    Here is the video tutorial that may also be helpful: https://www.loom.com/share/2fad8457bbb34faa948ea766a002aad8

    Let us know how it worked.

    0
    Comment actions Permalink

Please sign in to leave a comment.