Image doesn't update when I apply changes via filters or 'collections'

Completed

Comments

3 comments

  • Official comment
    Avatar
    Helena Carter

    Hi Michael,

    Please try fully reinstalling drivers for all graphics cards on your system.

    Make sure to fully uninstall your current graphics drivers before proceeding. How to uninstall drivers (click this text to open link). You'll need to do this for all devices under Display Adaptors on your system:

    Download and install drivers from the manufacturer's website:

    After you have updated your graphics card drivers, make sure to set your discrete graphics card to run Aurora by default (usually this concerns laptops). Refer to your graphics card's manufacturer's website if you need help with that.

    If your discrete card is Nvidia, you can find the instructions here. 

    If your discrete card is AMD, the video instruction is accessible here. 

     

    If this doesn't help, please, reach us via https://skylum.com/support so we could help you with this in a more effective way. Thanks in advance!

    Comment actions Permalink
  • Avatar
    Michael Ryan

    Thanks so much Helena -- that solved it!

    I uninstalled the default Intel Iris Xe graphics device and downloaded the latest driver directly from the Intel site.  Installed this Intel driver and presto! the image updates are now visible.

    Much appreciated.

    Michael

    1
    Comment actions Permalink
  • Avatar
    Kate Williams

    Great news, Michael! 

    Glad to hear we were able to help! 

    1
    Comment actions Permalink

Please sign in to leave a comment.