M1 Macbook Masking (Gradient/Radial) Freeze

Answered

Comments

15 comments

  • Official comment
    Avatar
    Helga Rowles

    Thank you, Ognjen.
    I have reported the issue to our tech team and they have reproduced it on their M1 Mac. We will do our best to sort it out quickly. 
    Thanks a lot for bringing the issue to our attention!

    Comment actions Permalink
  • Avatar
    Helga Rowles

    Hi Ognjen,

    Could you please let us know your version of Luminar AI (to check it, go to Luminar AI > About Luminar AI)?

    0
    Comment actions Permalink
  • Avatar
    Ognjen Marceta

    Helga Rowles

    Luminar AI Update 4
    Version 1.4.0 (9639)

    0
    Comment actions Permalink
  • Avatar
    Ognjen Marceta

    Helga Rowles

    You're welcome.
    I'm a software developer my self so I know how helpful it is to get this kind of information. Kudos to the tech team they built great software.

    0
    Comment actions Permalink
  • Avatar
    Helga Rowles

    We really appreciate your understanding! I will be happy to share your kind words with the tech team :)

    0
    Comment actions Permalink
  • Avatar
    Graham Jackson

    Same problem here. Every time I use the gradient tool the app just hangs. Only way to resolve is to force quit but lose all editing I’ve done.

    0
    Comment actions Permalink
  • Avatar
    Manuel Dittko

    Same for me. As this is one of my most used functions, I am currently not able to work with the new version. Do you already know, when a bugfix will beavailable?

    0
    Comment actions Permalink
  • Avatar
    Member

    Same for me every time I use it.

    0
    Comment actions Permalink
  • Avatar
    Perry Kibler

    +1, I'm demoing the program, sucks that I only have 7 days and it's not fully functional. 

    ---

    Hey, just because these forums get read (kudos to Luminar for that) and this seems as good a place as any to provide feedback: 

    I'm trying to leave Lightroom. Luminar is (by far) the best looking photo DAM/editor. I don't care about replacing skies, no problem with it, just not my bag. However, I do care about software that's nice to look at and easy to use. 

    Luminar AI (on an M1 MBPro w/ 16gb of RAM) is very spotty (e.g. radial masks don't work), quite slow vs Lightroom, and the M1 conversion itself took a lot longer than it should have. 

    I only bother to write this because I really feel Skylum has the best chance in this market if they can figure out the backend.  

    0
    Comment actions Permalink
  • Avatar
    Francesco Locorotondo

    Hello i also have the same problem, when will it be possible to solve it? I really like Luminar AI! I would like to point out that on another Mac, but with an Intel processor, the problem does not exist, it works perfectly!

    0
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hello all!

    Our tech department is currently working on fixing this issue! Please stay tuned!

    0
    Comment actions Permalink
  • Avatar
    Manuel Dittko

    Hi,

    is it already clear when the next update will be released? I am not familiar with your update strategy, I would have expected that there would be hotfixes available for the most critical defects quite soon, especially when it is about functions that have already been working in 1.3.

    Will it be like that or do we have to wait for a 1.4.1 version that will be released in weeks or months?

    I need to know because otherwise I might decide for other tools to do my workflows. 

    0
    Comment actions Permalink
  • Avatar
    Katherine Nelson

    Hi,

    Of course, we understand that this issue is critical and we are planning to release a hotfix soon. Stay tuned!

    0
    Comment actions Permalink
  • Avatar
    Tara Bagayas

    Following up for any updates? Still experiencing the issue. It works every once in a while but constantly have to force close and go back in. 

    0
    Comment actions Permalink
  • Avatar
    Anastasiia Moore

    Hi Tara!

    I'm glad to inform you that in our latest updates for Luminar AI, we have released a hotfix for the issue. Please ensure that you have the latest update installed. Here's how you can update the app: launch Luminar AI > click on Luminar AI > Check for updates.

    Once you update the app, please check if the issue persists.

    Looking forward to hearing back from you.

    0
    Comment actions Permalink

Please sign in to leave a comment.