Magic Mouse issue still not fixed in 3.1.3

Answered

Comments

11 comments

  • Avatar
    Peter Gladstein

    Bad News - Magic Mouse issue not resolved

    Good News - We have a new Splash Screen

    See last comment in this post - Kirk Osborn Please Respond

    https://community.skylum.com/hc/en-us/community/posts/360034174132-Luminar-3-with-Magic-Mouse 

    1
    Comment actions Permalink
  • Avatar
    Wolfgang Jarcik

    .... und wieder mal ein Update bei dem Versprochenes nicht eingehalten wird. L3 ist mit Magic-Mouse unbrauchbar aber wir werden bestenfalls wieder auf eines der nächsten Updates vertröstet - eigentlich unglaublich.

    1
    Comment actions Permalink
  • Avatar
    Mr.E

    Agreed, not fixed.

    Promises, promises...

    1
    Comment actions Permalink
  • Avatar
    Jim West

    Same for me...very annoying. Does anyone know what WAS included in the update? I will say that the upgrade did go smoothly...but I can’t really tell what is different.

    1
    Comment actions Permalink
  • Avatar
    Peter Gladstein

    Is Kirk Osborn still employed by Skylum? If yes, then please respond to this thread. THANKS!!

    1
    Comment actions Permalink
  • Avatar
    Peter Gladstein

    As the originator of this issue, I have replied to several threads regarding this issue and Skylum responses are whatever...

    I've been told

    - Use a different mouse

    - We cannot duplicate the problem

    - Can you replicate so we  can investigate

    - Its fixed but it has not been included in the code base  

    1
    Comment actions Permalink
  • Avatar
    Christian Poulton

    Although I've only had a very few issues with Luminar the Magic Mouse bug is one of the most annoying and I fail to understand why Skylum are finding it so difficult to fix? I use the Apple Magic Mouse all day, each and every day with a multitude of different software apps and Luminar is the only app that has this issue. I don't want to use another mouse thank you.

    1
    Comment actions Permalink
  • Avatar
    Daniel Voulkos

    Working last night. Found this issue as well. Quite annoying I'd say.

    0
    Comment actions Permalink
  • Avatar
    Gene Flanigan

    You would think this would be a very simple thing to fix.

    I use Capture One, and the mouse movement if your cursor is on the image, zooms the image. They have an option in the Preferences with a simple check box to turn this feature off.

    Why can't Luminar do the same thing and turn off moving to another image.  The program as it is on Mac with a mouse is not really usable. It's just and exercise in frustration until you close it down.

    0
    Comment actions Permalink
  • Avatar
    Helga Egilsdottir

    Hello Gene Flanigan,

    Thank you very much for your feedback. Indeed, this would be a major improvement and we are adding it in our next updates.

    Could you please kindly contact us via https://skylum.com/support, so we can send you experimental build, where this issue should be resolved? Look forward to hearing from you.

    0
    Comment actions Permalink
  • Avatar
    Vereslavska Anna Veres

    Hi, 

    We are sorry to say but for now, we don't have any ETA regarding this issue. 

    Hope for your patience. 

    -1
    Comment actions Permalink

Please sign in to leave a comment.