Updating to Luminar 3 3.1.3 (3920) fails

Comments

40 comments

  • Avatar
    Daniel L

    @Jill +1

    Make the offline installer available

    2
    Comment actions Permalink
  • Avatar
    Daniel L

    Why not posting it? Is it a secret??

    2
    Comment actions Permalink
  • Avatar
    Pierre Alarie

    Helena, i have sent a post to the Support Team and i dont have a response. I ask them to send me the link for the full installer and no response. What i do wrong ! I need the full installer… Why no response ?

    2
    Comment actions Permalink
  • Avatar
    JP

    It does not appear to be a region issue as being physically located in Canada makes no difference. Looks like it is a problem with the deployed update files being 3.1.2 not 3.1.3 so naturally the computer has nothing to "update" so offers to "repair" instead.

    2
    Comment actions Permalink
  • Avatar
    Pierre Alarie

    JP Ok for the explanation. But whom in Skylum company is responsable to correct this issue … I am not very happy with this problem who take precious time...

     

    2
    Comment actions Permalink
  • Avatar
    Daniel L

    To summarize:

    There is an update

    Update cannot be installed

    Link is not posted public

    Link is not provided by Email

     

    Seriously??

    2
    Comment actions Permalink
  • Avatar
    Jacques Demers

    It looks like it is very difficult for Skylum to do something right the first time.

    2
    Comment actions Permalink
  • Avatar
    Marcella Fostey

    Thank you for your latest reply however I had a luminar3 installer from June 6, 2019 still on my hard drive. I installed it and as a result I now have 3.1.3.3920 installed.....on both computers. Thanks 

    2
    Comment actions Permalink
  • Avatar
    Daniel L

    Will the offline installer https://luminar3.s3-accelerate.amazonaws.com/win/Luminar_3_Release.msi  be updated?

    1
    Comment actions Permalink
  • Avatar
    Neil Harris

    Found the installer ("Luminar 3_Installer.exe") in the temp folder. Tried installing using "Run as adminstrator" option, but still fails to update. Extracted the contents of data.zip that is generated during the installation; "Luminar 3.exe" still shows ver. 3.1.2.3606 in installer!

    1
    Comment actions Permalink
  • Avatar
    Daniel L

    Path is: C:\Program Files\Skylum\Luminar 3

    Location is Germany (also tried with VPN several countries -> same result)

     

    Anyway: What about the offline installer I mentioned in my previous post? Uninstalling Luminar and installing it with the offline installer solved my issues last time.

     

    Cheers
    Daniel

    1
    Comment actions Permalink
  • Avatar
    Daniel L

    Meaning we have to VPN to Canada, update, uninstall, grab the installer from download folder and install again...Nice way to deploy updates :(

    1
    Comment actions Permalink
  • Avatar
    Jill Edwards

    I will wait for the full offline install file to be made available before I even try to update as the online installers always result in spending time to fix problems. Just make the offline installer  available in our accounts EVERY TIME there is an update. Please!

    1
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Neil,

    Please reach out to us at www.skylum.com/support and we'll be happy to help you with this.

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi, 

    Please, try installing the update and then run Luminar 3 from the following folder:  C:\Program Files\Skylum\Luminar 3

    0
    Comment actions Permalink
  • Avatar
    Neil Harris
    Please, try installing the update and then run Luminar 3 from the following folder:  C:\Program Files\Skylum\Luminar 3

    Same result. The installer isn't updating. File properties after installing the update:

    0
    Comment actions Permalink
  • Avatar
    Lloyd O'Daniel

    You are not alone, Neal. The same thing happened to me. Typical for this crew.

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Everyone,

    Could you please all specify which folder do you have Luminar 3 installed into?

    Also, please, kindly contact our Support Team to report this issue, it would help us a lot:

    https://skylum.com/support

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Also, please, let us know where are you located? 

    0
    Comment actions Permalink
  • Avatar
    Lloyd O'Daniel

    I'm in the USA, but VPN'd to Canada to get it. I have successfully done that before. The installation folder is default: C:\Program Files\Skylum\Luminar 3.

    0
    Comment actions Permalink
  • Avatar
    Lloyd O'Daniel

    I just tried again and got the repair or uninstall dialog box. This time I uninstalled. I then found Luminar_Installer.exe that I had saved in my downloads and reinstalled. Boom! It installed 3.13.

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Please, note that soft launch update will work only for the ones in Canada, Australia ans Austria. 

    @Lloyd, please, kindly wait till the end of the week for the update to be live in the US.

    For everyone who's facing this issue - please, contact our Support Team and we'll send you the link to the full installer.

    0
    Comment actions Permalink
  • Avatar
    Pierre Alarie

    Here my problem:

    0
    Comment actions Permalink
  • Avatar
    Neil Harris

    C:\Program Files\Skylum\Luminar 3

    Canada

    0
    Comment actions Permalink
  • Avatar
    Neil Harris

    Lloyd: Did you lose your database and previous edits when you uninstalled 3.1.2 and then installed 3.1.3?

    Thanks, Neil

    0
    Comment actions Permalink
  • Avatar
    Pierre Alarie

    Daniel +1

    0
    Comment actions Permalink
  • Avatar
    Daniel L

    Nope, those files are located in your appdata folder and (database) in your luminar catalog folder. Anyway, I always make a backup before uninstalling -- there should be no impact when uninstalling and installing again

    0
    Comment actions Permalink
  • Avatar
    Lloyd O'Daniel

    @Helena: Too late. I have it now and I'm certainly not going back.

    @Neal: No, miraculously in view of recent history, everything was intact.

    @JP: You get "Install" instead of "Repair" the first time you do it. Then you find out that the version is still 3.12. Any subsequent attempt to update produces "Repair". So, the files are being loaded they just aren't executed. But the system knows you have attempted to update before.

    0
    Comment actions Permalink
  • Avatar
    Lloyd O'Daniel

    @Neil: Sorry for the misspelling of your name!

    0
    Comment actions Permalink
  • Avatar
    Dave Galliers

    I am having exactly the same problems as Neil here in the UK. Is the problem been sorted?

    0
    Comment actions Permalink

Please sign in to leave a comment.