Luminar 3.1.1 Slow to enable Edit tab

Comments

5 comments

  • Avatar
    Jean-Christophe Dichant

    I just did a measurement to give you additional feedback.

    I have a 6 seconds delay when switching from picture to picture in edit tab.

    This is a bit long if you frequently switch, more acceptable when you spend some time on a picture.

    Reactivity has to be improved, for sure.

     

    0
    Comment actions Permalink
  • Avatar
    Tomas Nilsén

    When im using Raws theres 15-30 sec delay for jpg 3-5 sec. That´s really slow.

    0
    Comment actions Permalink
  • Avatar
    lv photography

    Same duration for me. Each RAW takes between 14 and 15 seconds to display before activating the Edit tab.

    Same problem to display RAW in full screen in the library tab.

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Everyone,

    We're improving Luminar 3 performance with each update.

    Nevertheless, it might depend on several factors such as your hardware configuration, Library size and images format (it can take a bit more time to load RAW/TIFF/DNG files and generate the previews)

    Could you please let us know the following

    • How many images are there in your Library?
    • Are they located on the internal or external drive?

    Also, as a workaround, I can suggest you to try dividing your Library into several Catalogs. it will improve Luminar 3 speed.

    0
    Comment actions Permalink
  • Avatar
    Tomas Nilsén

    For me i have the "main" catalogue in internal mechanical drive. 

    But it´s the same even if i use small catalogues with 10-50 images from an external SSD. theres no difference in speed.

    0
    Comment actions Permalink

Please sign in to leave a comment.