Very very high RAM usage!

Answered

Comments

15 comments

  • Avatar
    Member

    Hello,

    I have the same problem on my computer.

    I have the impression that by browsing the folders the previews load in memory and are never unloaded. Suddenly the use of RAM increases, increases ... until the crash of Luminar.

    maybe this problem only occurs with the windows version ?

    1
    Comment actions Permalink
  • Avatar
    Jean-Christophe Dichant

    I have no explanation for this but just checked my 53.000 photos catalog to compare.

    Luminar 3 takes 988 Mb from my 16Gb RAM W10 computer.

    Far from you.

    Something to check with support I guess.

     

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Peter,

    Please contact us at www.skylum.com/support so we can investigate this issue. Thanks in advance!

    0
    Comment actions Permalink
  • Avatar
    Achim Boening

    Hi,
    Same problem with me
    Windows 10 32gb ram
    Just sent a request to support.
    Addidional frequently freezing luminar 3
    Any news to these points in this tread?
    Achim

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi Achim, 

    We've detected a memory leak happening when you're toggling between photos in your gallery. This will be fixed in the update that's coming within a week, so I kindly invite you to try it out. 

    Our team will process your support request shortly in order to take a look at your particular case. 

    0
    Comment actions Permalink
  • Avatar
    Peter Reichert

    Hi again to my topic.


    After update to newest Luminar 3 version I have always such very high RAM usage. And I don't toggling between the different gallery folders. I work long times in one gallery folder in order to work on photos.
    There was no improvement on RAM usage. 

    From my 32GB total RAM space, Luminar 3 always uses in average 20GB of RAM. 
    My photo galleries are mostly "stable/constant"...means: my number of photos don't change often.
    And I use Luminar 3 for long time. 
    I have to reboot Luminar 3 after around 45-60 minutes new, cause exports takes too long or on one point the export freezes. 

    I hope, this would be latest solved with Luminar 4.

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi Pete! Thanks for sharing this. We are working on a fix. We will do our best.

    0
    Comment actions Permalink
  • Avatar
    Kraken Photographic

    Hi, are we getting any closer to fixing this issue? I'm having the same problem with luminar taking up 24Gb of RAM within minutes of use.

    0
    Comment actions Permalink
  • Avatar
    Pascal Bieri

    Same here. Unable to work...Still no fix?

    0
    Comment actions Permalink
  • Avatar
    Elena Blum

    Hi,

    Our team is working right now to get this resolved and to ship the update.

    Please stay tuned! Thanks!

    0
    Comment actions Permalink
  • Avatar
    Ahmad J A Alnusif

    I think their dev team is busy with the impending v4 release and doesn't have time to tackle v3 issues now.

    That's why this issue is taking such a long time to address.

    0
    Comment actions Permalink
  • Avatar
    Pascal Bieri

    As long as v4 solves it, no problem with that😀

    0
    Comment actions Permalink
  • Avatar
    Elena Blum

    Hi @Ahmad ,

    Indeed, Luminar 4 release is really soon and we're trying to do it in the best way. However, we consider and plan the Updates for Luminar 3 too.

    0
    Comment actions Permalink
  • Avatar
    Ernest Caiko

    Hello!

    This problem is still exist. When next update is planned?

    Thank you very much

    0
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    We're aware of the performance issues, and we're truly sorry if you encountered them.

    There will be an update meant to target these issues at the end of this year. Please stay tuned.

    -2
    Comment actions Permalink

Post is closed for comments.