Luminar 3.1 SLOW

Comments

10 comments

  • Avatar
    Matej Peternel

    Hi !

    I'm a new user of Luminar 3 and i was also using Lightroom before, not long time, maybe few months, but i decided to leave monthly subscription from Adobe.

    But yes, like you mentioned.

    Loading time and switching between photos could take long time.

    I also have problems while exporting photos, sometimes nothing happens while clicking on export, so i must reload Luminar 3 again, then works.

    Otherwise i really like interface of Luminar 3 and overall i like it.

     

    Windows 10 64bit Home.

    Intel i7 2600k

    12gb ram

    nvidia gt1030

    Samsung 860 evo 500gb ssd

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi guys! Could you specify how big are your catalogs? How many images are there? Are they on your external or internal drive?
    You can try creating a smaller catalog:
    in the top bar menu choose File > Catalog > New

    0
    Comment actions Permalink
  • Avatar
    Matej Peternel

    I have images for editing always on my internal drive.

    I don't have any catalogs.

    I'm using Luminar 3 for editing images, so when editing is finished i move images to different location, 

    so there are no catalogs. And that should not be a problem.

     

     

    0
    Comment actions Permalink
  • Avatar
    Pedro Vieira

    My catalog has about 2000 images that are stored on a USB3.1 4TB external drive. 

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Matej, could you send us a screenshot of your Luminar library? Also, send us your full system info:

    • Press the Windows logo key + R.
    • Type msinfo32 in the dialog box that opens and hit Enter on your keyboard.
    • In the window that opens, make sure you have System Summary highlighted on the left.
    • Click File > Export.
    • Type the name of the file and save it somewhere where you can easily find it and attach this text file to via form here: https://skylum.com/support

    Pedro, could you try to create a new catalog with photos on your internal drive? This way, we will see if that is the issue.

    0
    Comment actions Permalink
  • Avatar
    Matej Peternel

    Full system info sended.

    Like i said, i don't have any Luminar library. All files, after editing are going to different location, so Luminar doesn't look for any files previously loaded in program. It's empty.

    0
    Comment actions Permalink
  • Avatar
    Vereslavska Anna Veres

    Hi Matej

    Thank you for sending us the file.

    We will do our best to reply to you soon. 

    0
    Comment actions Permalink
  • Avatar
    Pedro Vieira

    Uh excuse me, Matej isn’t the original poster, I am. Help me before you help him. I’m trying to find out why it’s so slow and instead you help him.

    1
    Comment actions Permalink
  • Avatar
    Vereslavska Anna Veres

    Hi Pedro, 

    It seems you haven't contacted us via https://skylum.com/support as my colleague suggested. 

    Please make sure to send the email to support@skylum.com so we could assist you in a more effective way. 

    Please also attach the PC info to your email. 

    0
    Comment actions Permalink
  • Avatar
    jeff crawford

    I also have issues with the slowness, It takes 2 min to startup after selecting the icon to have a thumbnail show up in the library.

    When selecting a photo to edit it takes a few sec to be able to edit.

    I love this program! It is as close to the Sony colors etc of any program I have used. 

    This started after the last update

    0
    Comment actions Permalink

Please sign in to leave a comment.