Luminar runs really slow

Comments

3 comments

  • Avatar
    Kate Williams

    Hi Oke,

    We are constantly working in order to improve the performance of the app. However, currently, it does depend on a number of factors, including your hardware, the number of photos in the Catalog and their location. 

    Please try creating a new catalog containing a fewer number of photos to see if the issue persists. Go to File->Catalog->New to create a new catalog. Try adding the folders one by one. 

     

    1
    Comment actions Permalink
  • Avatar
    Keith George

    I Agree I am running L3.1.0 on a Macbook pro 2.2 Ghz Intel Core i7 with 16Gb 100 Mhz DDR3 and Iris Pro 1536 MB graphics card. I have a few hundred photos in my library and L3 is running painfully slow!! Yesterday I deleted a photo, because I thought it was blurry, when the next one came up I knew there was a problem. It took between 5-10 seconds for each photo to load, then I had to wait to edit and applying edits was slow.  The previous version ran faster.  I have been using Luminar before it had libraries and have never seen it this slow or have so many problems freezing and crashing.. 

     

    0
    Comment actions Permalink
  • Avatar
    Todd Winters

    I enjoy this software but gosh it runs slow.  I am using a ThinkPad with a core i5 vpro and eight gigs of ram.  I shoot in raw and it takes 10-15 to move from one photo to the next.  My other photo editors run much faster.  Sometime the software just gives up and closes.  However, I have not lost any photos.  I sure hope improvements are on the way.

    0
    Comment actions Permalink

Please sign in to leave a comment.