Luminar 3.1 Stuck Updating Image Gallery

Comments

78 comments

  • Avatar
    Eduardo Mueses

    BTW, a progress bar that always stays at 0% is useless...

    1
    Comment actions Permalink
  • Avatar
    phil dyer

    Yves. Well done for all the work but the fix should have come from Skylum. They have let people down with a lack of information. I am seriously looking elsewhere now even though I love Luminar. I have no confidence in it being robust.

    1
    Comment actions Permalink
  • Avatar
    LeRoi Mines

    Hello Skylum,

    It is now TWO months since I tried upgrading my copy of Luminar 3 and I am STILL without working software.  Have you forgotten about me hoping I would just go away??

    While I have decided to move over to On1, I would still like Luminar 3 working so that I can review my Luminar edits and most importantly, have working software for which I paid for.

    Thanks.

    1
    Comment actions Permalink
  • Avatar
    Will Lockwood

    Bummer to hear this has not been fully resolved. It sounds like the software is stuck in some sort of recursive loop. Hope they solve it soon. I am staying away from Luminar until there is a clear understanding of the cause and a bulletproof fix. 

    1
    Comment actions Permalink
  • Avatar
    Eduardo Mueses

    As I can see the tumbleweeds, I decided to say the heck with it. I force-quit the applications and decided to create a brand new catalog losing all my edits. This time the progress bar seems to be working, who knew?

    0
    Comment actions Permalink
  • Avatar
    Ronald Skinner

    I had to do the same thing, progress bar never budged past 0% very frustrating, love the editor but the library needs work. I ended up creating a new catalog too and found the magic mouse issue still there and still no Lens info for Nikon cameras.

    0
    Comment actions Permalink
  • Avatar
    Kier Smith

    I"m having the same issue, even after uninstalling, restarting and reinstalling, still no progress on updating Image gallery.  I did a force quit and opened a single image through Lightroom and it started up and worked, but other than that it is stuck.

     

    0
    Comment actions Permalink
  • Avatar
    Kevin Ford

    I've had the same issue and don't want to loose my edits, so I guess that I'll stick with "Updating Image Gallery... 0%" until a fix is posted someplace and I can find it in the forum or it finally updates. I can see that there is no drive activity so I'm not holding my breath. I use DVORAK for my keyboard layout and can't wait to see if they fixed the image rotation issue that I had seen with my keyboard layout.

    I so want to ditch the quest for other image managers and editors.

    0
    Comment actions Permalink
  • Avatar
    Kevin Ford

    I went ahead and blew away my edits, not sure how many times I have had to do this recently, it's a bit frustrating.

    I should mention that I'm running MAC OSX mojave with a library of 100,000 images.

    0
    Comment actions Permalink
  • Avatar
    Konstantin Latsunas

    The same here it seems that the updating Gallery nerve ends....

    for Edition the Software is Great .... but the for dam not usable.... 

    0
    Comment actions Permalink
  • Avatar
    Bill Kyle

    During the upgrade to Luminar 3.1 a similar result here. The install went fine but the catalog  backup & update made it to 98% and stay there for a few minutes. Luminar would then crash. Tried several times to launch 3.1 but it would never finish updating/loading the current catalog. To be sure the app was OK I created a new catalog, loaded some folders of test images,  Not sure what the answer is for my previous catalog but fixing it may not be worth it in my case. The updated AI filter is really a big time saver. 

    Mac OSX 10.13.6

    0
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    Try the following solutions:

    1. Make sure Luminar is closed.
    2. Locate your Luminar Catalog folder. The default location is %username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    3. Rename the Luminar Catalog folder. Choose any name you like.
    4. Start Luminar. Click File > Catalog > Open > navigate inside the folder you renamed in Step 3 > double-click Luminar Catalog.catalog file.

    If the 4 steps above don't help:

    1. Make sure Luminar is closed.
    2. Locate your Luminar Catalog folder. The default location is %username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    3. Rename the Luminar Catalog folder. Choose any name you like.
    4. Open Finder.
    5. Navigate to Applications > Utilities.
    6. Launch Terminal.
    7. Paste the following string into the Terminal window: defaults delete com.macphun.luminar3
    8. Press Enter on your keyboard.
    9. Close Terminal.
    10. Launch Luminar. It will ask you to complete the initial setup. Go through the initial setup. Leave the location of the catalog at the default (in Pictures folder).
    0
    Comment actions Permalink
  • Avatar
    Eduardo Mueses

    This is no different than hitting the Alt key while clicking on the Luminar App to create a new Catalog. BTW, it did not work for me.

    I am right now content with the new catalog I've created. Not looking for a solution for this anymore. Not sure what the common denominator is for this issue, but the fact that is happening to a few of us, warrants a look by Skylum.

    0
    Comment actions Permalink
  • Avatar
    Yves Royer

    Same for me ... Stuck updating the catalog ...I will try the proposed fix 

    Catalog was conrtaining around 35 000 picture 

    with more than  4 000 édits 

     

     

    0
    Comment actions Permalink
  • Avatar
    Yves Royer

    Sorry .. proposed fix is useless !!!

    good evening

     

    0
    Comment actions Permalink
  • Avatar
    Kier Smith

    I nuked my catalog, on the up side I was just getting started really using Luminar, so I didn't loose much of anything, BUT none of the fixes worked for me w/o totally deleting the old catalog and starting from scratch.  Now it seems to be working fine.

     

    0
    Comment actions Permalink
  • Avatar
    Mitchell Weitz

    I am having the same problem. Renaming the catalog didn't help. Renaming the catalog and nuking the config to force Luminar to set up from scratch may have helped -- at least now the "Creating Image Gallery" progress bar is moving.  It's up to 21% now. Of course, that means I lost all previous edits in my original catalog. Gee, thanks, Skylum.  

    0
    Comment actions Permalink
  • Avatar
    phil dyer

    Same here. Fix did not work- had to create a new catalogue

    0
    Comment actions Permalink
  • Avatar
    Konstantin Latsunas

    same here. Creating a new catalogue helps and speed up Luminar. BUT every time I open LUMINAR it tries to update the catalogue and this takes about 10 minute (see my post luminar 3.1 only a short pleasure)...... PLEASE FIX THIS!!!!!!!!!

    0
    Comment actions Permalink
  • Avatar
    Anna Veres

    Hi Everyone,

    I am sorry for the inconvenience.

    We will do our best to fix that in the upcoming updates. 

    Please contact us at http://www.skylum.com/support so we could assist you in a better way.

     

    0
    Comment actions Permalink
  • Avatar
    Ole Wissing

    I have only 3000 pictures in my catalog, but each is a TIFF at 180Mbytes. The catalog update have taken 10 minutes now, with ZERO progress. The CPU is not busy (0.1-0.5%), the Luminar 3 Process has read ONLY 100Mbytes in the 10 minutes and written 888 KILOBYTES. 

    Why don't you (Skylum) test your roll-outs before deploying. It would have been EASY to spot this before. It seems, that Your are using your customer base as testing ground. My edits are too important for this, so I hope, that this will be fixed in the future.

    My computer is a MacBook Pro with i9 CPU, 32Gb RAM og 1Tb disk.

    Update:

    No activity after 20 minutes and I killed the proces. Tried the steps mentioned above, but same result: when opening the catalog it stalls.

    Found a log file with the following:

    EE | 2019/04/27 13:00:29:559 MPPresetToLookMigrationService:31 "+[MPPresetToLookMigrationService migrateForPresetDirectoryLocation:]": Error Domain=NSCocoaErrorDomain Code=260 "The folder “Presets” doesn’t exist." UserInfo={NSFilePath=/Users/ole/Library/Group Containers/DPA6233TPQ.com.macphun.luminar3/Presets, NSUserStringVariant=(

        Folder

    ), NSUnderlyingError=0x6000034e98f0 {Error Domain=NSOSStatusErrorDomain Code=-43 "fnfErr: File not found"}}

    EE | 2019/04/27 13:00:29:566 MPPresetToLookMigrationService:59 "+[MPPresetToLookMigrationService migrateForPresetDirectoryLocation:]": Error Domain=NSCocoaErrorDomain Code=4 "“Presets” couldn’t be removed." UserInfo={NSFilePath=/Users/ole/Library/Group Containers/DPA6233TPQ.com.macphun.luminar3/Presets, NSUserStringVariant=(

        Remove

    ), NSUnderlyingError=0x60000342eca0 {Error Domain=NSPOSIXErrorDomain Code=2 "No such file or directory"}}

    0
    Comment actions Permalink
  • Avatar
    phil dyer

    In the end- I deleted the Luminar Catalog and my renamed one out of the computer.

    I added an entirely new (blank) catalog and imported my folders from the hard drive.

    Luckily I had ensured all my edits went into sub-folders in L3- they are duplicated on the hard drive automatically so able to retrieve them and reload- nothing has been lost

     

     

    0
    Comment actions Permalink
  • Avatar
    phil dyer

    Forget my last post. the edits in the hard drive have not been changed from the orginal file- you have to export a file for this to happen

     

    Apologies

    0
    Comment actions Permalink
  • Avatar
    Anna Veres

    @Ole,

    I am sorry to hear that. 

    Please try reinstalling Luminar. Follow the steps below:

    Download AppCleaner from here:

    http://www.freemacsoft.net/appcleaner

    AppCleaner is a free app that automatically removes not only the applications themselves but also the related files, making 'clean' uninstall easy.

    When removing Luminar 3, mark all the files and folders in the list, except for DPA6233TPQ.com.macphun.luminar3.

    Once you're done uninstalling the app, restart your Mac and download a fresh version from here:

    https://luminar3.s3-accelerate.amazonaws.com/mac/Luminar3Installer.zip

    If you need help with the installation, check out this page:

    https://support.apple.com/kb/ph25083?locale=en_US

    0
    Comment actions Permalink
  • Avatar
    phil dyer

    Anna- the fix doesn’t work!

    the problem is the upgrade. 

    0
    Comment actions Permalink
  • Avatar
    Bill Kyle

    I tried both suggested methods to complete the catalog update. No go, but the new catalog seems to work well. If you come up with a fix here I would be interested but using my old catalog is not that important to me.

    0
    Comment actions Permalink
  • Avatar
    Kevin Ford

    At this point i'm going to need a "Library Edit Merge Utility" I created a new catalog and moved on, certainly upgrades are going to need to be more stable in the future to consider it a "final tool" to replace other products, subscription based, that I am trying to avoid.

    Luminar is improving, however there are still some gaps.

    0
    Comment actions Permalink
  • Avatar
    Ole Wissing

    I have several hundreds of hours invested in my edits. I am scanning and repairing a huge amount (thousands) of Dia-slides and losing the old catalog with the edits will be catastrophic.

    As a minimum, Skylum should supply a tool to import the edits from the old catalog structure.

    I will help test it, if that would ensure that I gained access to my work sooner.

    Luminar could be the very best that we photographers have seen in a very long time, but right now it is a threat to our existing work, because we cannot be sure, that updates/upgrades will not harm our data.

    Please give an estimate time for a fix or workaround?

    0
    Comment actions Permalink
  • Avatar
    phil dyer

    They keep sending “fixes” out that dont work. They dont seem to be listening . I have sent the community conversation link to them- dont think they are changing anything they offer us.

    0
    Comment actions Permalink
  • Avatar
    Konstantin Latsunas

    Please create the possibility to Switch the Database Update Manuale on and off!!!!!!

    This could be a quick Update that helps a lot

    0
    Comment actions Permalink

Please sign in to leave a comment.