Luminar 3.1 Stuck Updating Image Gallery

Comments

78 comments

  • Avatar
    Helena Carter

    To Everyone who is facing this issue.

    Please, send the following info to support@skylum.com

    1. The version of Luminar 3 build. Click Luminar 3 o the left top corner>About Luminar.
    2. Where are your photos and Catalog located? Are they located on the internal or external drive?
    3. How many photos are there in your Luminar Library?
    4. If you can recall, when was your Catalog created in terms of Luminar updates? Was it created in the version 3.0.1/3.0.2?

    Also, could you please try to give your Catalog which freezes on Updating Image Gallery more time to load? If possible, just leave your Mac for some time. It helped some of our customers in such cases.

    Looking forward to hearing from all of you.

    0
    Comment actions Permalink
  • Avatar
    Kathleen Petersen

    This is all very confusing to me.  I was loving my Luminar 3, was using it, and then was out of the country for about a month,  opened it today, on my return, to edit and and organize photos, but I can't organize them, or do anything, and it just seems to want to be a full-time image gallery updater.  I am not as tech-savvy as many others here.  But I can follow a list of directions.  I have tried them all and now realize that I must give up.  Is there any hope?  

     

    0
    Comment actions Permalink
  • Avatar
    phil dyer

    Kathleen

    I’m like you. Nothing has worked so wont be using L3 until they have sorted out and issued an upgrade. I have changed over to ON1- which I am finding fits the bill. Such a shame as was loving Luminary’s. 

    0
    Comment actions Permalink
  • Avatar
    Dmytro B.

    Our tech team has released a fix for the users experiencing the freeze while Updating the Image Gallery: 

     

    Please try reinstalling Luminar. Follow the steps below:

    Download AppCleaner from here:

    http://www.freemacsoft.net/appcleaner

    AppCleaner is a free app that automatically removes not only the applications themselves but also the related files, making 'clean' uninstall easy.

    When removing Luminar 3, mark all the files and folders in the list, except for DPA6233TPQ.com.macphun.luminar3.

    Once you're done uninstalling the app, restart your Mac and download a fixed version from here:

    https://s3-us-west-1.amazonaws.com/luminar3/mac/Luminar3_Distribution_v3_1_0_3747.zip

    0
    Comment actions Permalink
  • Avatar
    Fabio Cunha

    Like all of you, I am frustrated about the slow response from the Luminar team. I am also stuck on "Updating Image Gallery 0%". I have a brand new iMac i9 running the latest Mojave update. This probably is keeping me from using Luminar for more than a month. Both Kirk and Anna copy and paste the same solution text in these forums every now and then and ignore what everyone is saying. It's messed up. Of course, you can just ignore all your edits and start over but I paid for this software and expect it to work. I bought Luminar on Black Friday last year thinking that it would be a solution against paying for a Lightroom subscription. I would take my money back if that would be an option.

    0
    Comment actions Permalink
  • Avatar
    Ronald Skinner

    While the Luminar editor is great, the library needs work, I moved to ON1 photo Raw

    0
    Comment actions Permalink
  • Avatar
    Colin Grant

    Don't see too much positive feedback here @Kirk Osborn. Clearly Skylum live in a parallel universe.

    0
    Comment actions Permalink
  • Avatar
    Maryna Skylum

    @Fabio Cunha

    We're sorry for the inconveniences.

    Please send us your catalog at support@skylum.com:

    1. Locate your Luminar Catalog folder. The default location is %username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    2. Right-click the Luminar Catalog folder > click Compress and wait for the process to finish.
    3. Send us the .zip file you created in Step 2. We recommend a free service WeTransfer for that.

    If you can recall, it would help us a lot if you could tell us which folders were added to your Luminar Catalog and where they were located: on an internal or external drive. 

    0
    Comment actions Permalink
  • Avatar
    Rick Sperry

    I was having the same issue with LUminar 3.1 - It was stuck on 0% while showing it was updating the gallery.  I have close to 300,000 photos.  I just brought my whole library into the catalog...not realizing what the potential problem this could be.  

    Well, I got stuck doing a project for about an hour and came back to Luminar and found that about 50% of the images have been updated. At this rate, the entire library should be updated in less than an hour.  Quick update... it only took 10 more minutes to upload and update. 

    The downside is that I cannot use Luminar until this is over. 

    0
    Comment actions Permalink
  • Avatar
    LeRoi Mines

    Hello Skylum,

    It is now TWO months since I tried upgrading my copy of Luminar 3 and I am STILL without working software.  Have you forgotten about me hoping I would just go away??

    While I have decided to move over to On1, I would still like Luminar 3 working so that I can review my Luminar edits and most importantly, have working software for which I paid for.

    Thanks.

    1
    Comment actions Permalink
  • Avatar
    Vereslavska Anna Veres

    Hi, 

    I am sorry for the inconvenience.

    Please contact us at http://www.skylum.com/support so we could assist you in a better way.

    -1
    Comment actions Permalink
  • Avatar
    Will Lockwood

    Bummer to hear this has not been fully resolved. It sounds like the software is stuck in some sort of recursive loop. Hope they solve it soon. I am staying away from Luminar until there is a clear understanding of the cause and a bulletproof fix. 

    1
    Comment actions Permalink
  • Avatar
    phil dyer

    It’s happening on the last update as well. Mine was fixed by force quitting and adding an old catalogue. Luminar sent the usual fix email which didn’t work,

    0
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    Hi Chris,

    We need to be able to reproduce the issue on our end in order to understand at which point it occurs and troubleshoot it. Please send us a screen recording of the issue. Here's how to record your screen on Mac: https://support.apple.com/guide/quicktime-player/record-your-screen-qtp97b08e666/mac

    Here's how you can send us the file with the recording:

    1. Visit https://wetransfer.com/
    2. If it's your first time visiting this website, it might ask you to purchase a subscription. Simply select to proceed with the free version.
    3. Click Add your files.
    4. Select the file(s) on your computer.
    5. After you see all the files you need to send appear in the list, click the icon to the left of the Transfer button (the icon looks like a circle with three dots in it).
    6. In Send As select Link.
    7. Click Transfer.
    8. After the files have finished uploading, click Copy Link and send it to support@skylum.com

    Looking forward to hearing from you.

    0
    Comment actions Permalink
  • Avatar
    phil dyer

    Chris- well said- they keep sending the same “fix” which doesn’t work and then get you to send a video- to try and troubleshoot, but they surely must know what is going wrong. It’s not universal but seems to effect several people each time they update.

    fortunately mine is behaving itself, but wont be updating any more.

    such a shame as its a great programme- when it works!!!

    0
    Comment actions Permalink
  • Avatar
    Will Lockwood

    They should be getting stack crawls on the affected machines to show where the code is stuck. An engineer should also be able to remote into your machine for diagnosis. 

    0
    Comment actions Permalink
  • Avatar
    LeRoi Mines

    @Chris Cole - Yesterday Skylum Tech Support gave me a solution that got Luminar 3 up and running again.  Once it was, I opened my original catalog from version 1 of Luminar 3.  After running for six hours the "Updating gallery" was still at 0%!!  After forcing the program to quit I was then told by the Tech Support that: "I m sorry to hear that. It seems your catalog was too big or contained some third-party files that corrupted the catalog." And, I have approximately 7,000 photos.  Not a lot really.

    The only saving grace is that the edits I've done since the upgrade to Luminar 3 have been small.  I'm now using On1.  I still have Luminar 2018 to look at earlier edits.  But, I won't be looking at or using Luminar 3 again!  I only hope they don't screw up Aurora next! 

    0
    Comment actions Permalink
  • Avatar
    Kah Fok

     

    I faced the same problem "Updating Image Gallery.......0%"

    1. Forced close Luminar 3.1 (3588)

    2. Rename catalog

    3. Reopen Luminar 3.1

    4. Able to add one folder (4000 photos)

    5. When try to add another folder (~1000 photos) ......"Updating Image Gallery.......0%"

    6. Follow instruction to use App cleaner and do a fresh install 3.1 (4280)

    7. Add 2019 folder ~10,000 photos (stored on another PC SSD)

    8. Add another folder ~56000 (stored on NAS) , successfully loaded

    Keep my finger cross 

    0
    Comment actions Permalink

Please sign in to leave a comment.