Luminar 3.1.0: Accent AI 2.0 + More Usability & Stability

Comments

36 comments

  • Avatar
    Rob Strower

    Thanks for the update Skylum!

    I just got it an hour ago in Germany.

    It speeds up Luminar 3 in a good way and improves many things, including the handling and switching from catalog to edit view and many speed improvements in the editing included (crop, transform etc.).

    I had one hard reset happening while dropping the Accent AI 2.0 to about 20% but I could not reproduce that error so it may had been an issue on my side (PC,CPU or most likely the GPU). I have to add I am on a preview version of WIN10 for the end of May release so maybe it was something with WIN10.

    I am very happy I got the update early.

    So far I am very pleased and it made Luminar 3 faster and more stable.

    All the best,

    Robin

     

    0
    Comment actions Permalink
  • Avatar
    Jonathan Meddings

    Not too pleased so far with the update. Trying to edit some images and it keeps crashing. It was fine before the update. It also seems a lot slower.

    I'm really considering going back to Lightroom. Luminar seems to have problem after problem, then updates are released to solve the issues and the updates cause more issues. Grrrr 

    7
    Comment actions Permalink
  • Avatar
    Ian Hargreaves

    I've just installed this latest version and Luminar no longer works. All i'm getting is the initial splash screen, then nothing. It just doesnt run. I've uninstalled the update and then reinstalled. Again with no success. I'm really questioning why I wasted my money on this product..

    7
    Comment actions Permalink
  • Avatar
    Leah Burgess

    Mine stopped working after I clicked update yesterday I've downloaded the eve from my software and the trial and still getting Oops. 

    0
    Comment actions Permalink
  • Avatar
    Alex Young

    Thanks for the update - I just installed it and it is working well. I had a couple of very brief glitches at first, but I'm fairly certain that these were due to my PC and not the software.

    I like what I've seen with the improved AI filter - will this be available soon for those of us using Luminar Flex?

    Again, thanks...

    Cheers,

    Alex

    0
    Comment actions Permalink
  • Avatar
    Jill Edwards

    Here we go again. Where can we download the FULL INSTALL file?

    1
    Comment actions Permalink
  • Avatar
    Michał Puczyłowski

    Please share full installer archive (MSI) with us. Many users are unable to install new builds of Luminar as the default (25MB Luminar3_Installer.exe) installer crashes with "Oops! Something isn't working at the moment" just after choosing install location and downloader progress bar shows up. There is no any additional explanation about the error... I use Windows 8.1, graphics driver updated, gigabytes of free disk space.

    3
    Comment actions Permalink
  • Avatar
    Fabien BERINI

    I would like to try this but the updated installer is blocked on 1% for 1h now ...

    I tried a restart, uninstalled Luminar, cleaned registery, cleared directories (like appdata, programms etc), launched as admin, etc

    But now I can't install it at all (still blocked at 1%) :/

    1
    Comment actions Permalink
  • Avatar
    Andrea Angelucci

    Updated but now after the splash screen nothing happens... I've also tried to uninstall and reinstall after a clean with ccleaner but the result is the same... have you suggestions?

    Obviously before the update everything was ok...

    UPDATE: After a PC restart seems works properly

    0
    Comment actions Permalink
  • Avatar
    Bernard Cadieux Cadieux

    My update also didn't work. Uninstall the sofware and reinstall, after every thing ok. Just backup your catalog first.

    0
    Comment actions Permalink
  • Avatar
    Ubo Pakes

    After the long, long, long installation process I start the program and after the startup picture nothing .... 

    Getting a bit tired of this

     

     

    2
    Comment actions Permalink
  • Avatar
    Dave T

    The update installed fine and worked well for a bit. I edited quite a few images and all was well until I exited then tried to restart it. Now I get the splash page then it just goes away, no error at all. I tried uninstalling and reinstalling with the full install from the link above but I get the same result. I'm glad I didn't uninstall the 2018 version. I can at least go back to using that.

    1
    Comment actions Permalink
  • Avatar
    Minh-Dang Bui-Nguyen

    I'm probably experiencing an anomaly, but the new update is actually less stable than my last version of luminar. Batching photos did not get any better and you still have to load files sequentially if you do not want to give your computer a stroke. Unfortunate but man, what are the devs up to? Instead of new features, I'd be content with software stability/frequent patches...

    2
    Comment actions Permalink
  • Avatar
    Bryan Phillips

    Memory leak - Testing scenario on Windows 10

    I really enjoy the tools provided with Luminar. I really like the new AI Accent 2.0.

    I have found, however, that Luminar crashes after editing some photos. I decided to test some simple examples.  You may be able to do these tests and aee for yourself. If not I can provide more information or do tests for you. I can even provide my sample images for testing.

    • Open a RAW image file
    • Apply 1 edit by setting Accent AI 2.0 to 100%
    • Use Ctl-C to copy the setting
    • Move to another RAW image
    • Use CTL-V to paste the setting
    • Repeat the two prior steps at least 35 times
    • You may need to continue but you should soon reach a point where Luminar crashes. 
    3
    Comment actions Permalink
  • Avatar
    David Reagan

    So, I was able to install the update just fine on Windows 10, and it seemed a bit faster. But, after poking around a bit, there are a bunch of small things that really should not have been missed. Which makes me wonder if the emphasis on AI is taking away time from quality of life features...

    First thing I noticed was that the export keyboard shortcut only works in library view. Why doesn't it work in edit view? I want to export my photo after editing it. So I'd naturally be in edit view when I want to export....

    I was happy to see that I can now import my photos directly in Luminar. Unfortunately, when I didn't select the correct import folder, and thus tried to move my pictures, Luminar couldn't figure out how to move them itself, nor could it figure out that I moved them in windows explorer. Even after manually renaming the folder (something that worked a week or two ago when I had the same issue...)

    If I were in charge of development, here's where I'd direct my energy:

    * General speed and stability.

    * Finish adding basic functionality to the DAM.

      * Import with full support for configuring folder structure and filenames based on metadata.

      * A clone of Lightroom 5's tagging feature. Try to improve it if possible. But, at the very least, it should not require more than 1 click in a text box to start adding multiple tags.

      * Add an option to manually rescan a directory to find pics that Luminar lost track of. (Well, ideally you'd figure out why this happens in the first place, then stop it from happening....)

      * A way to list pics that Luminar knows about, but can't find on the filesystem anymore.

      * Full metadata edit support.

      * The ability to save metadata to the raw files.

    * Snapshots of edits.

    * Don't erase metadata when exporting unless the user wants it erased.

    * Make sure keyboard shortcuts work the same across all versions of Luminar, and in all views.

    Anyway, I'm still really fond of how easy it is to make simple edits with the AI slider, and not having a subscription is essential. But, please, please, take some time to address the small things!

     

    3
    Comment actions Permalink
  • Avatar
    Vereslavska Anna Veres

    Hi Everyone, 

    I am sorry if you have experienced any difficulties with the update.

    Please contact us at http://www.skylum.com/support so we could assist you in a better way.

    @David, 

    Thank you for your great suggestion. 

    I have forwarded your comments to the technical department for further consideration. 

    Hope for your understanding and patience. 

     

    0
    Comment actions Permalink
  • Avatar
    Dirk Buerstätte

    After installing and 1st starting:  Database opening failed........

     

    It seems to be business as usual like the last 3 month update, error, support ....

    I feel like I am stuck in groundhog day!

    2
    Comment actions Permalink
  • Avatar
    David Reagan

    Just to add some context for why I think tagging and metadata is so important.

    I share a lot of my pics on SmugMug. SmugMug can use the Title, Caption, and Tags metadata automatically. It really adds to my albums when I can set those things.

    I also am just trying to submit my first pics to Dreamstime and Shutterstock. Both services pull in metadata automatically, and if the metadata is missing, you have to manually add it yourself. The Title, caption, and tags metadata specifically.

    Right now I have to export from Luminar 3 as TIFF, then import into Lightroom 5 so I can manage the metadata. So, yeah, I'd really rather not have to do that....

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi Dirk! 
    I am sorry for the inconveniences.

    Please do the following to get Luminar up and running:

    1. Make sure Luminar is closed.
    2. Locate your Luminar Catalog folder. The default location is C:\Users\%username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    3. Rename the Luminar Catalog folder. Choose any name you like. Don't remove this folder.
    4. Press the Windows logo key + R.
    5. Type %appdata%\Luminar 3 in the dialog box that opens and press Enter on your keyboard.
    6. In the folder that opens, locate the file called StateSettings and send it to us. 
    7. Next, remove all the contents in Luminar 3 folder you opened in Step 5. Please note that this will remove your user looks and workspaces, so back up the folder into the safe location before removing it if necessary. You can then put your looks and workspaces back later.
    8. Start Luminar. It will ask you to complete the initial setup. While performing the setup, leave the location of the catalog at the default.
    9. When Luminar has loaded, click File > Catalog > Open > navigate inside the folder you renamed in Step 3 > double-click Luminar Catalog.catalog file. Your previous catalog should load.
    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hey David! Thanks for pointing this out. We will work on it.

    0
    Comment actions Permalink
  • Avatar
    Vaibhav Dandavate

    Installed the latest update, here's the initial feedback based on a few hours of editing and exporting:

    1. Multiple crashes
    2. Copy/Paste adjustments does not copy/paste "Crop" settings. Used in the previous version and was working fine
    3. Exporting pictures was already slow, about a minute (or more) per picture and now it's even worse. I left it to export about 40 pictures and in about 2 hours it was done with just about 14 pictures. I had to kill the window and reboot. Trying again, let's see

    Luminar is a great tool. Please, please work on the performance issues.

    0
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    Hi Vaibhav,

    We'll pass this on to our tech team for further consideration.

    As for crop synchronization, we have disabled this feature due to many complaints.

    0
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    Hi Penelope,

    Please contact us via https://skylum.com/support and we will figure something out.

    0
    Comment actions Permalink
  • Avatar
    Diane Cotton

    Hi All, For me, since the update, masking has become virtually unuseable. Masking is extremely slow and often doesn't complete at all. When I click on the eye to see masking, it comes up as a red block and extremely slowly moves to where I have been masking, often only getting to a small part of what I have done. It seems that it struggles more with large raw files such as those from the Sony A7R2 while smaller files or jpg files seem to be better. I close everything else ( including my web browser) on my computer before I use Luminar and there are still frequent crashes. I have Capture One and Affinity and neither of these have this problem. I also use Aurora HDR which does crash now and then but has fewer glitches. I do like Luminar a lot and hope they can fix these problems but at the moment because of the masking problem , it has become virtualy unuseable for me. 

            

    0
    Comment actions Permalink
  • Avatar
    Terry Rogers

    Hi Diane. Please contact us via https://skylum.com/support and we will do our best to help you.

    0
    Comment actions Permalink
  • Avatar
    Peter Nowlan

    When I updated and launched all I got was the splash and an error message saying "data initialization failed" then it shut down. I tried this several times with the same results. I contacted support 3 times and have still not had a reply. I tried the cure suggested in the support forum and sent my state settting.xml folder and still nothing. I've come to the conclusion that if Luminar was a country it would be a banana republic without bananas. This after patiently going through similar problems with 18 and 3. On the few occasions that the programs worked I really liked it but....

     

    0
    Comment actions Permalink
  • Avatar
    Terry Rogers

    Hi Peter,

    Please do the following to get Luminar up and running:

    1. Make sure Luminar is closed.
    2. Locate your Luminar Catalog folder. The default location is C:\Users\%username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    3. Rename the Luminar Catalog folder. Choose any name you like. Don't remove this folder.
    4. Press the Windows logo key + R.
    5. Type %appdata%\Luminar 3 in the dialog box that opens and press Enter on your keyboard.
    6. Next, remove Luminar 3 folder you opened in Step 5. Please note that this will remove your user looks and workspaces, so back up the folder into the safe location before removing it if necessary. You can then put your looks and workspaces back later.
    7. Start Luminar. It will ask you to complete the initial setup. While performing the setup, leave the location of the catalog at the default.
    8. When Luminar has loaded, click File > Catalog > Open > navigate inside the folder you renamed in Step 3 > double-click Luminar Catalog.catalog file. Your previous catalog should load.

    Please note: File > Catalog > Open is for opening catalog files, not photos. If you try to open a photo like this, you will receive a Database Opening Failed error.

    0
    Comment actions Permalink
  • Avatar
    Burak ORMECI

    Hi,

    First of all thank you for the update.

    I have several problems with my luminar, 

    1. Crop tool has problems. Sometime when i click the tool, it is stucking one of the edges of the photo and it is very tiny. I can not select and enlarge it.

    2. Rotate tool or preview option has a problem. Sometimes, preview is return back to original photo or it shows a rotated photo but not aligned horizontaly to the screen. it is not a normal situation.

    3. When i use "open images for quick edit" and import a photo, luminar selects and shows another photo instead of imported one. i am reselecting the imported photo from the left import panel.

    4. Sometimes when the first opening of the luminar, the menus (luminar looks panel at the bottom, filters panel) not correctly loading. When this error occurs, i am closing and reopening the luminar.

    5. I can not see a performance improvement also, still its hang on with some filters.

    i hope they will be fixed with the new update.

    version of my luminar is: 3.1.0.2942

    windows10 - xps15 9560

    Thank you. 

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Burak,

    Please contact us at www.skylum.com/support and we'll investigate these issues.

    0
    Comment actions Permalink

Please sign in to leave a comment.