Luminar 3.1.0: Accent AI 2.0 + More Usability & Stability

Comments

49 comments

  • Avatar
    Hugo Campos

    I'm trying to install the new update but I'm having the same errors I had with the previous updates. "An error occurred in retrieving update information, Please try again later" I tried multiple times and nothing

    2
    Comment actions Permalink
  • Avatar
    Geoffrey Connor

    Downloaded from the Apple App Store yesterday. Currently on v3.02 on my Mac desktop. Have tried the 'launch Luminar 3, then in the Top Menu Bar choose Luminar 3> Check for updates' but that option isn't there. I take it all updates are through the App Store?

    Any ideas when the update will be available there please?

    2
    Comment actions Permalink
  • Avatar
    Jason Corica

    Having same issue as Hugo.  "An error occurred in retrieving update information"  This happened last update as well and a bit frustrating.  

    1
    Comment actions Permalink
  • Avatar
    Colin Grant

    @swapnil, to avoid updates use ON1 instead - sorry could not resist :-)

    1
    Comment actions Permalink
  • Avatar
    Dennis Stein

    Yeah. I had same issue. Support sent me a fix to it. But I don't understand how it could be so messed up after the update. I still had issues once I go it to open, and finally decided it wasn't worth it and bought ON1.

    1
    Comment actions Permalink
  • Avatar
    mary riley

    Thanks for pointing out where file name is

     

    respectfully it should be below the pic when its open for editing at all times - not in some other tab.

     

     

    1
    Comment actions Permalink
  • Avatar
    Remy van Haarlem

    Hello,

    Performed the update.

    Problem:
    by add folder, the folder is added into the library however the files can be accessed for edit.

     

    added in Mac 

    0
    Comment actions Permalink
  • Avatar
    Gal Steinberg

    So far (about 20 min of exploring) it does seem better and more stable... crossing my fingers

    0
    Comment actions Permalink
  • Avatar
    Dennis Stein

    Updated to 3.1 on 2017 iMac. Initially the install tried to install while Luminar was updating the gallery, and it got hung up and I had to force quit. I them deleted Luminar as previously done, with App Cleaner, keeping the required file. I reinstalled it and opened it. It finally stopped updating the image gallery. The folders in my library have the correct numbers of photos in each folder, but when I click on any of them, there are "0" photos that are viewable. Big problem getting to like this program with all the issues I've had.

    0
    Comment actions Permalink
  • Avatar
    Vereslavska Anna Veres

    Hi Dennis,

    I am sorry to hear that.

    Please contact us via https://skylum.com/support so we could investigate the issue. 

    0
    Comment actions Permalink
  • Avatar
    Jason Corica

    Kirk, I am running on a mac.  Now firewall or any such thing.  Shouldn't be this difficult to use a check for updates option that always encounters an error.

    0
    Comment actions Permalink
  • Avatar
    Peter Schlaufer

    It gets better with every update, what I am still waiting for are the ITPC possibilities, such as keywords and geotagging as well as the promised importing of the Lightroom catalog. But the software is on a good way. I am glad I had stopped with Lightroom

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi Geoffrey! Please contact our customer support so we will provide you with the latest version: https://skylum.com/support
    @Jason Are you logged in as an admin on your computer? 

    0
    Comment actions Permalink
  • Avatar
    Colin Grant

    Seems more stable but still sadly lacking in functionality. Glad I stayed with Lr, seems it will be years before Luminar gets anywhere close (if ever). L3 is still very sluggish compered to Lr, C1 and ON1 and why does it take so long to load the thumbnails for tiff images? In fact the general loading of 1300 images in "All Photos" view is terribly slow. Makes it so I cannot be bothered. Is it anything to do with caching thumbnails on the first run?

    0
    Comment actions Permalink
  • Avatar
    Colin Grant

    Update to above. It seems better now that everything has loaded once - seems like it may have ben cache building. I rather expected this version just to adopt the old database but I guess there may have been some changes to make. V2 of AI is better and can be helpful; although I do prefer the  more traditional adjustments it is a nice to have. Still needs keywording, sorting, exif et al to make it a serious contender. L3 does not necessarily have to be a Lr killer, but it does need the basic functionality to make it a useful alternative.

    0
    Comment actions Permalink
  • Avatar
    Jason Corica

    Anastasia. Yes I’m admin

    0
    Comment actions Permalink
  • Avatar
    swapnil deshpande

    after the 3.1.0 update i havent been able to use luminar at all. it just freezes on updating image gallery. i uninstalled , reinstalled but the problem just persists. how can i revert to luminar 3 original update? and how to make sure i dont get new updates? 

    0
    Comment actions Permalink
  • Avatar
    Vereslavska Anna Veres

    Hi Swapnil deshpande,

    We are sorry for the inconvenience. 

    Try the following solutions:

    1. Make sure Luminar is closed.
    2. Locate your Luminar Catalog folder. The default location is %username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    3. Rename the Luminar Catalog folder. Choose any name you like.
    4. Start Luminar. Click File > Catalog > Open > navigate inside the folder you renamed in Step 3 > double-click Luminar Catalog.luminar file.

    If the 4 steps above don't help:

    1. Make sure Luminar is closed.
    2. Locate your Luminar Catalog folder. The default location is %username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    3. Rename the Luminar Catalog folder. Choose any name you like.
    4. Open Finder.
    5. Navigate to Applications > Utilities.
    6. Launch Terminal.
    7. Paste the following string into the Terminal window: defaults delete com.macphun.luminar3
    8. Press Enter on your keyboard.
    9. Close Terminal.
    10. Launch Luminar. It will ask you to complete the initial setup. Go through the initial setup. Leave the location of the catalog at the default (in Pictures folder).

    I hope it helps. 

     

    0
    Comment actions Permalink
  • Avatar
    Member

    The roadmap is not updated yet after 3.1 release: https://skylum.com/luminar/roadmap

    It would be good to know what's coming in "Next Update".

    0
    Comment actions Permalink
  • Avatar
    swapnil deshpande

    @anna veres yes it works again 

    this process works 

    0
    Comment actions Permalink
  • Avatar
    Janne Langi

    Updated to 3.1, no problems.

     

    However, opening RAW photos still takes quite a while. First it seems to load a low-res preview, then updates it to high/full-res version (and also creates the looks previews). This takes a relatively long time. Opening a RAW photo is a lot slower than it was in Lightroom. Sometimes the UI never updates to the high-res version, you have to open some other photo and then re-open the one you wanted to open in the first place.

    Exporting RAW images is also still quite slow. I have Mac Pro with 2 x 2.66GHz Xeons, PCIe SSD and 64G of memory so the HW should not be the bottle neck. Besided, Lightroom was much faster with the same exact HW.

    Another thing, which has been an issue in earlier versions also, is that using Luminar with Magic Mouse is extremely annoying:

    - The photo I'm editing is open and on the left there is the list of (all) photos. All is good at this point.

    - I touch the mouse in some "wrong" way which causes the photo I'm editing to be changed to next/previous photo on the list.

    - Loading/opening raw images is slow and the UI is frozen until the new photo, which I do NOT want to edit, is loaded. So I wait. And then I have to re-load the image I actually want to edit, and since it's slow I have to wait some more.

    - I continue editing the photo and hope I'm not touching the mouse in a "wrong" way again.

    - This is issue alone would make me switch back to Lightroom, immediately, if Adobe didn't have the idiotic licensing model they now have

     

    I just noticed one issue I haven't noticed before: when you export photos to a folder to which you don't have write access, Luminar happily claims to export all the photos and never reports an issue with the write permission. Naturally, in this case the photos are in fact NOT exported. What makes this even more annoying is that exporting is slow.

     

    The app has a lot of potential, and I really want to like it, but based on my own experience and that of others I'm starting to believe there is something seriously wrong with your QA process. My advice based on 19 years in SW dev. business is that do NOT develop new features until existing problems are solved. Focus on bugfixing first, release the fixes to users and only when users are (in general) happy should you continue adding features.

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi, 

    Thanks for the feedback. 

    Firstly, I would like to assure you that performance is one of our top priorities and we will keep improving the speed of the app in order to provide you with a faster program in the future. 

    For now, a workaround will be to divide your gallery between several catalogs containing a smaller number of photos (to create a new catalog, choose File->Catalog->New). 

    As for the rest of the suggestions, including Magic Mouse sensitivity and the export to a folder to which you do not have write access - I have forwarded them for further consideration. Thank you for helping us make Luminar better! 

    0
    Comment actions Permalink
  • Avatar
    Jason Corica

    Still cannot update.  I am admin, using a mac, no firewall or any other anomalies.  Why would checking for an update be such a hassle?  Is there a reason Skylum doesn't post the update for download?

    0
    Comment actions Permalink
  • Avatar
    Member

    Jason,

    You can try to see if the update server is really accessible in your network. Run following command in Terminal to see if ping works:

    ping luminar3.s3-accelerate.amazonaws.com

    Please note that the domain here is for Luminar Trial download. I'm not sure if the update is also hosted in the same host.

    0
    Comment actions Permalink
  • Avatar
    Jason Corica

    PING luminar3.s3-accelerate.amazonaws.com (13.33.228.15): 56 data bytes

    64 bytes from 13.33.228.15: icmp_seq=0 ttl=243 time=17.011 ms

    64 bytes from 13.33.228.15: icmp_seq=1 ttl=243 time=20.449 ms

    64 bytes from 13.33.228.15: icmp_seq=2 ttl=243 time=14.972 ms

    64 bytes from 13.33.228.15: icmp_seq=3 ttl=243 time=13.643 ms

     

    0
    Comment actions Permalink
  • Avatar
    Terry Rogers

    Hi Jason. We are sorry for the inconveniences. Please contact us via https://skylum.com/support and we will help you with the update.

    0
    Comment actions Permalink
  • Avatar
    mary riley

    just updated to this. still ridiculously slow even on local folders,  (i have not yet connected it to my remote library)..

    but ..maybe i'm blind.. where did the image names go?  I have a looked all over.. but i don't see my file names anywhere.

    and the refresh of the 'styles' takes about a min per pic.. !

     

    thanks

     

    0
    Comment actions Permalink
  • Avatar
    mary riley

    and its crashed 3 times so far - in the past 2 hrs -- but i've only been actively using it for about 15 min each time.. better - no crash report.  it just.. disappears. 

     

    i think i bought a dud.

     

    reopen - 5;33pm -- loading images ...

    5;36pm opens finally

     

    there are about 22k images local - but 20k of these are low res (screenshots etc) .... 

     

    by 5;39.. i've scrolled down thru 5 images -- and tried to apply a style to one... and pooooof crash...  so now its completely unusable. 

    lmk where i can forward the crash report...

    0
    Comment actions Permalink
  • Avatar
    Vereslavska Anna Veres

    Hi Mary, 

    I am sorry for the inconvenience.

    Please contact us at http://www.skylum.com/support so we could assist you in a better way.

     

     

     

    0
    Comment actions Permalink
  • Avatar
    mary riley

    Anna -- where is the file name on the screen? were they removed?? or.. .... you didn't answer that question

     

    and the link you gave makes me fill out a forum.... so i filled it out asking, like i asked you.. where to send the crash reports. thanks for the wasted extra steps...

     

    I seriously have no more patience for this - i paid for a a fully working app nearly a year ago.. and i'm still using a broken unfinished beta..

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.