Luminar Flex is not being found as an extension to Photos

Comments

21 comments

  • Avatar
    michael durkin

    Luminar Flex is not being found as an extension to Photos.

    Did you honestly think it would ?

    0
    Comment actions Permalink
  • Avatar
    Robert Follis

    Well it should be! and for Affinity Photo.

    0
    Comment actions Permalink
  • Avatar
    Ken Korman

    In Photos, select edit with other, then select flex. It is working for me. It does not work as a plug in for Affinity Photo though.

    0
    Comment actions Permalink
  • Avatar
    John West

    Hi All

    Just installed and activated FLEX. Shut down MacBookPro and restarted and opened Photos, unfortunately no extension shown, also no extension shown in System Preferences.

    Should I uninstall and start again?

    Cheers John

    0
    Comment actions Permalink
  • Avatar
    Denis Joanisse

    Yep, this happened on one of my machines as well. It installed fine on my main computer running Mojave, but didn't install the extension on a machine running High Sierra. Still looking for a solution.

    0
    Comment actions Permalink
  • Avatar
    Ben Bloks

    As I recall you have to:

    1. Install  as administrator (in case you have more than one user).

    2. Start Flex and open a picture, then  close the app

    3. Reboot system

    4. Extension should  be available  and activated for each  user-account on your system separately.

    For me on Mojave it works. 

    HtH

    0
    Comment actions Permalink
  • Avatar
    Vereslavska Anna Veres

    Hi Everyone, 

    If the issue persists please contact us at http://www.skylum.com/support so we could investigate it in a more scrupulous way. 

    0
    Comment actions Permalink
  • Avatar
    Gunnlaugur Josefsson

    The issue remains for sure,the question remains is skylum on top of it and is a soluion forthcoming ?

    0
    Comment actions Permalink
  • Avatar
    Brian Ramage

    I have the same issue with using Photos for High Sierra. :(

    i see the plugin for PS and Aperture though,

    i can see it in Aperture but in trying t the return file went from 25mb to 95mb. eek!

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi!

    Follow the steps below:

    1. Remove Luminar Flex with AppCleaner: http://www.freemacsoft.net/appcleaner.
    2. Open Finder and navigate to Applications > Utilities.
    3. Launch Terminal.
    4. Paste defaults delete com.macphun.luminarflex in the Terminal window and press Enter on your keyboard.
    5. Close Terminal and restart your Mac.
    6. Download Luminar Flex here: https://luminarflex.s3.amazonaws.com/mac/LuminarFlexInstaller.zip 
    7. Double-click the zip folder to extract Luminar.
    8. Copy the extracted file to your Applications directory.
    9. Launch Luminar, activate it if necessary, and open any image in it.
    10. Navigate to System Preferences > Extensions and see if Luminar is displayed in the list for Photos Editing. Enable it if needed.

    In case Luminar isn't in the list when you're on Step 10, no worries: restart your computer one more time and make sure that Reopen windows when logging back in is unchecked.

    Launch Luminar, open any image in it, and navigate to System Preferences > Extensions one more time, Luminar Flex should be on the list now.

    I hope this helps.

    0
    Comment actions Permalink
  • Avatar
    Brian Ramage

    ^ NOPE, NADA, NOTHING THERE

     

    I still just see Luminar 2018. Do I need to install Luminar 3 first before installing FLEX?

    Every other extension I install works perfectly fine. just not FLEX.

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    The reinstall with terminal usually helps in similar cases.

    No, you don't need to uninstall Luminar 3 to use Luminar Flex. 
    Please reach our customer support so we investigate it more thoroughly: https://skylum.com/support 

    0
    Comment actions Permalink
  • Avatar
    Member

    I have registered versions of both Lumimar Flex and Aurora HDR and have the most recent versions of both.

    Has this issue been resolved yet? I too am using High Sierra (10.13.6) and although I've followed the steps as suggested by Anastasia, similar to Brian's situation I still do not see Luminar Flex in the list of extensions.

    Additionally, I've just discovered that Luminar Flex is not available as a plugin for Aurora HDR. When I select "Other -> Open Plugin", Luminar Flex is greyed out even when Flex is open.

    However, I can use Aurora HDR as a plugin while in Luminar Flex.

    This is becoming increasingly frustrating.

    0
    Comment actions Permalink
  • Avatar
    Member

    UPDATE: I repeated the steps described by Anastasia once again only this time instead of restarting my Mac, I did a full shut-down, waited a few moments then restarted. Luminar Flex now shows in the extensions and works with the Photos app.

    However, it is still greyed out when I try and use it as a plugin in Aurora HDR.

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi Bruce,
    Could you try the steps below? They are a bit modified and implies another Luminar Flex file. 

    1. Remove Luminar Flex with AppCleaner: http://www.freemacsoft.net/appcleaner.
    2. Open Finder and navigate to Applications > Utilities.
    3. Launch Terminal.
    4. Paste defaults delete com.macphun.luminarflex in the Terminal window and press Enter on your keyboard.
    5. Paste defaults delete com.macphun.luminarflex.photoextension in the Terminal window and press Enter on your keyboard.
    6. Close Terminal and restart your Mac.
    7. Download Luminar Flex here: https://luminarflex.s3.amazonaws.com/mac/LuminarFlex_Distribution_v1_0_0_5661.zip 
    8. Double-click the zip folder to extract Luminar.
    9. Copy the extracted file to your Applications directory.
    10. Launch Luminar, activate it if necessary, and open any image in it.
    11. Navigate to System Preferences > Extensions and see if Luminar is displayed in the list for Photos Editing. Enable it if needed.

    In case Luminar isn't in the list when you're on Step 10, no worries: restart your computer one more time and make sure that Reopen windows when logging back in is unchecked.

    Launch Luminar, open any image in it, and navigate to System Preferences > Extensions one more time, Luminar Flex should be on the list now.

    0
    Comment actions Permalink
  • Avatar
    Brian Ramage

    Hello,

     

    Trying to follow the directions listed above and when I try to download Luminar FLEX I get this message via Safari:

    AccessDeniedAccess Denied8551C77D86DF0C2464IrUJ93NmzZzqDNFJCelP7U4a2ymOn1nwUNN/WWd47CjuNMH0AovoMX+I71CxGZnK1l1dbTc44=

    0
    Comment actions Permalink
  • Avatar
    Brian Ramage

    I was able to just use my Account and Download a DMG....I can easily open FLEX for an individual file. but so far no luck in seeing in within System Preferences/Extensions.  

     

     

    0
    Comment actions Permalink
  • Avatar
    Brian Ramage

    is this something on MY end or YOUR end:

     

    AccessDeniedAccess Denied1FAB30DAD72BDA86ZvoMAJn8D6U5Q0mNy1wLhTZ7E5raT/ijg2qIP9ROjhhoe15+wESd4cORGbq5UtnkATAbx1OkfjM=

     

     

    I can take a screenshot if need be. I cannot access that. I can try and upgrade to Mojave tonight and see what happens

    0
    Comment actions Permalink
  • Avatar
    Brad Carlson

    I couldn't get Anastasia's directions to work on my Mac at first. Then I read them again very carefully.

    The key... I was not doing Step 9 correctly. After doing Step 8, I would install Flex from where it was extracted (Downloads), and then Flex would be installed in the Applications folder. When I read more carefully, I copied the extracted Flex App file from Downloads and pasted it into Applications. Then continued thru the steps. The copy and paste method worked.

     

    0
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    We are glad to hear that everything is alright now.

    Feel free to contact us if any questions arise.

    0
    Comment actions Permalink

Please sign in to leave a comment.