Luminar 3.0.2. is here

Comments

136 comments

  • Avatar
    Marc Horst

    After updating to 3.0.2 it is only possible to see images in max 2 child folders. I.E. "2019/01/24" will not show any picture!

    1
    Comment actions Permalink
  • Avatar
    PETER DAPRIX

    I just started watching the intro video after I installed this new update. Right at the start I was lost. What the heck is a "bus" button? I have used a Mac since it was first introduced and have never heard of a bus button. So I think if computer specific terms are used, a definition of terms is appropriate. I want to know how to open the new library but I am dead in my tracks.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    @Marc - I just tested on my Mac and I'm viewing images 4 subfolders deep. Can you verify that you're running Version 3.0.2 (3051)? Luminar 3 > About Luminar 3

    If so, please try quitting Luminar and restarting your computer (if you haven't already) and let us know if the issue persists.

    @Peter - Did you do a fresh install or just run the update? I didn't see a video at the launch, but I'll check with our team and see if I can get some clarification for you.

    0
    Comment actions Permalink
  • Avatar
    Marc Horst

    @Angela yes it is the correct version. Just restarted the Mac again, the issue persists. If i open it with the 3.0.1 (2571) everything is ok, except that all my changes to the images are lost.

    0
    Comment actions Permalink
  • Avatar
    Alina Skylum

    @Marc - Please contact us at www.skylum.com/support and we'll investigate this issue. Please specify if your images are stored locally on your computer or on an external drive. Looking forward to hearing from you!

    0
    Comment actions Permalink
  • Avatar
    Alina Skylum

    @Peter Schlaufer - Are the images you edited locally on your MacBook Air duplicates of the ones on your external drive or did you move them?

    0
    Comment actions Permalink
  • Avatar
    Andrew Hewitt

    As posted in the News section, I also see issues with nested folders. Some show up OK, others are blank, a relaunch changes the folders that can and cannot be viewed. Clicking the the root folder shows all the images contained.

    Mine are on an external FW800 connected HDD dedicated for my photo storage.

     

    0
    Comment actions Permalink
  • Avatar
    Jan Willem de Visser

    Works much better and faster. No issues until now...

    (27" iMac late 2015 with SSD)

    1
    Comment actions Permalink
  • Avatar
    Lorenzo Sampdo

    After I upgraded to the latest version Luminar crashes when opening. I'm a MacBook Pro 10.14.3 Mojave. Anyone with this problem?

    4
    Comment actions Permalink
  • Avatar
    Ron Standley

    Same here. Installed 3.0.2 and it crashes at startup.  Mac Mini, late 2012, Mojave 10.14.3, 16gb.

    4
    Comment actions Permalink
  • Avatar
    Norton Dudeque

    same here too. Crashes in opening, does not read library sufficiently fast, hang on and on and on...buggy!!

    Well, I will keep using Luminar 2018, which is quite good :-\

    4
    Comment actions Permalink
  • Avatar
    Tero H

    This is a much better version now, 3.0.1 and particularly 3.0.0 were next to unusable. 3.0.2 still a bit sluggish, particularly when opening an image. I spotted an issue, the preset thumbnails at the bottom of the screen may cease to show the preset look preview in the thumbnails but they all look the same with no effect in them. The presets work, though, and the issue seems eventually go away when changing to an other collection, but this does not happen every time I change the collection. I have only one experience on this issue, so can't say more about it.

    Is there any consensus on how much RAM this requires IRL, is there any point in upgrading from 16 GB to 32 GB in hope to reduce sluggishness? I can see that RAM usage is somewhere between 10 and 13 GB when I'm using Luminar and there's also a web browser open.

    My ride is iMac late '15, latest MacOS, 16 GB.

    1
    Comment actions Permalink
  • Avatar
    Rex Matthews

    Installed the 3.0.2 update. The update process went smoothly. The app opened without hanging but the catalog has lost ALL of my edits from 3.0.1.  All of them. Color me unhappy. I had saved copies of the 3.0.1 catalog and just tried to follow the instructions given elsewhere for deleting 3.0.2 and installing a fresh copy of 3.0.1, but what downloaded from your site was another copy of the 3.0.2 installer.

    1
    Comment actions Permalink
  • Avatar
    Robert Lancaster

    I just installed the 3.0.2 update.  Overall, I would say it is much improved!  I analyzed a number of issues I had noted with Luminar in the previous version to see if each is fixed.  All of my edits were preserved, so I did not have this issue that some had when they updated (but before I updated, I made a full backup just in case).

    1. Switching between photos with existing previews is much snappier, and in fact seems almost as fast if not faster than the other image editors I have tried.  In fact, I can click the down arrow key, and my time lapse sequences play just like a movie!  That is a huge improvement.  

    2.  The multiple color shifts that I observed in the previous version every time many images load are totally gone, when the image loads now, it loads with pretty much the correct colors from the start.  

    3.  The bug that I reported last month about images that I took with my iPhone in portrait mode loading too wide and then updating to the correct width after a moment still exists.  No improvements on that one.  Hopefully soon, since all the people I image with my iPhone look fat if only for a moment. . .

    4.  Luminar now opens in the same folder you closed it in!!!  Before, it used to open to the same photo you had open when you closed it last, but in "All Photos". This is a huge improvement.

    5.  There is a NEW bug with the "Show Original" Button that did not exist in the previous version.  When I click it, I see the first image in my catalog IMG_0001.jpg, no matter what image I click this button on.  The "before/after" button to the right of this button works as expected, it is only the "Show Original" button that has a problem.

    6.  There were several other bugs that I had found before, but I have not had time yet to verify that they are fixed.

    So that's 3/4 issues that I checked were fixed in this update, but one new issue was created.  However I will note that in my opinion the 3 issues that were fixed are very important ones but the one that was not and the new one created are just annoyances.   So overall I would say that this update improved the software significantly.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    @Lorenzo Sampdo, @Ron Standley,  @Norton Dudeque - We need to be able to reproduce the issue on our end in order to understand at which point it occurs. Please email us at support@skylum.com with a detailed step-by-step description of what you do in the software before encountering the issue. You can also make a screen recording:

    https://support.apple.com/guide/quicktime-player/record-your-screen-qtp97b08e666/mac

    If the issue occurs when you're working on an image, send us the image file. Here's how:

    1. Visit https://wetransfer.com/
    2. If it's your first time visiting this website, it might ask you to purchase a subscription. Simply select to proceed with the free version.
    3. Click Add your files.
    4. Select the file(s) on your computer.
    5. After you see all the files you need to send appear in the list, click the icon to the left of the Transfer button (the icon looks like a circle with three dots in it).
    6. In Send As select Link.
    7. Click Transfer.
    8. After the files have finished uploading, click Copy Link and paste it into your email.

    In order for us to directly track this issue, please send us your Hardware UUID:

    1. Click the Apple icon in the upper left corner of your screen.
    2. Click About This Mac.
    3. In the window that opens, click System Report.
    4. In the window that opens, make sure Hardware is selected in the column on the left.
    5. Locate the Hardware UUID string, copy it, and paste it into your email.

    In case the issue leads to a crash, send us crash reports:

    1. Open Finder.
    2. Click Go in the top menu > click Go to Folder.
    3. Paste the following path: ~/Library/Logs/DiagnosticReports and click Go.
    4. In the folder that opens find the most recent files with Luminar 3 in their names and attach them to your email.

    In case there are no crashes, collect the log from the console:

    1. In Finder, navigate to Applications > Utilities.
    2. Start Console.
    3. Type in Luminar in Console's search bar in the upper right and press Enter on your keyboard.
    4. Start Luminar and try reproducing the issue. Make sure to note all the steps you perform in the app that cause the issue.
    5. Go back to Console, select all entries in it (to do so you can press CMD+A on your keyboard) and press CMD+C on your keyboard to copy them to clipboard.
    6. Create a new text document and paste (CMD+V) the contents of the clipboard there.
    7. Send us the text document you created in Step 6.

    Looking forward to hearing from you.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    @Tero H - If it happens again, please note the steps that lead to the issue and email them to support@skylum.com. A screen recording would also very helpful.

    Screen recording instructions can be found here: https://support.apple.com/guide/quicktime-player/record-your-screen-qtp97b08e666/mac

    With regard to RAM - I run a 15" Late 2015 MacBook Pro and Luminar 3 runs pretty well. Would it be better with 32? Most likely yes, but your graphics card and whether or not your computer has an SSD are also significant factors.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    @Rex Matthews - I'm very sorry to hear that you're having this issue. Please contact us at support@skylum.com and we'll provide you with a link to revert to the previous version as well as troubleshoot the missing edits.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    @Robert Lancaster - Thanks for your detailed feedback! I'm glad to hear that the update is working (mostly) well for you. With regard to the issue with the Show Original button, please email us at support@skylum.com with the steps you took in the software that led to the issue. A screen recording would also be helpful. Here's how: https://support.apple.com/guide/quicktime-player/record-your-screen-qtp97b08e666/mac

    0
    Comment actions Permalink
  • Avatar
    Ario Arioldi

    After I upgraded to the latest version Luminar always crashes when opening. I'm a MacBook Pro 2018, OS 10.14.3.  I have already tried with a fresh install but the problem is still there. On my Windows machine it is ok

    2
    Comment actions Permalink
  • Avatar
    Richard Kane

    So happy to have the update. I was hoping that the issue of L3 not working as plug in/extension for Apple Photos would be resolved. Unfortunately it's the same, when attempting to use it this way just get "Unable to edit with Luminar 3 - an unexpected error occurred". Just as in previous version of L3. L2018 works perfectly in this way. I have contacted support previously, removed the software using the proper tools, re-installed multiple times, checked settings many times, to no avail. Just doesn't work. Very dissapointing indeed. This is how I must manage my workflow and if it doesn't work for me I have to just continue to use L2018 or another editing software package. 

    1
    Comment actions Permalink
  • Avatar
    Thomas Barrows

    Having the same issue with crashing on opening after an apparently successful update. From what I see of the responses in this thread, it seems like a widespread problem.

    2
    Comment actions Permalink
  • Avatar
    Peter Schlaufer

    Sorry for my comments with not beeing able to process further files on a external SSD on a different computer. It was that I was not on the same catalog. This edition is in any case much superior to the 3.01 update and I delete the initial claim above mentionned

    0
    Comment actions Permalink
  • Avatar
    Stefan Gutte

    Installed the update yesterday evening. The update itself looks good, but there is always a bug if I want to locate a Folder. Software crashes, and I am also not able to locate a subfolder. So in my opinion the catalogue is not usable, if you are working with different machines on an catalogue stored on a NAS. That is really sad because there are such a lot beautiful Tools and ideas in Luminar3. If you want I can send you a crash report, but this will take a while because first i want to test the issue on another Mac and second the Computers are out of reach for me in the Moment.

    1
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    @Ario Please try reinstalling the app.
    Follow the steps below:

    Download AppCleaner from here:

    http://www.freemacsoft.net/appcleaner

    AppCleaner is a free app that automatically removes not only the applications themselves but also the related files, making 'clean' uninstall easy.

    When removing Luminar 3, mark all the files and folders in the list, except for DPA6233TPQ.com.macphun.luminar3.

    Once you're done uninstalling the app, restart your Mac and download a fresh version from here:

    https://luminar3.s3-accelerate.amazonaws.com/mac/Luminar3Installer.zip

    If you need help with the installation, check out this page:

    https://support.apple.com/kb/ph25083?locale=en_US



    @Richard In order to fix Photos extension,  you should do a clean reinstall with terminal. Did you do it as we mentioned?

    @Thomas Please, try reinstalling the app as we suggested Ario.

    @Peter Great to hear that.

    @Stefan Sure, please send us a crash report to support@skylum.com

    1
    Comment actions Permalink
  • Avatar
    Richard Kane

    Nastia. No I never did the terminal re-install. I found it overwhelming.... to complicated. I will look for the previous email from support and think about it again but my opinion is that if I have to start working in terminal with all kinds of 1990's DOS commands, then Luminar is not the right answer for me.

    1
    Comment actions Permalink
  • Avatar
    Tommy Köhlbrugge

    After updating to the latest update Luminar crashes on startup every time :(

    Anyone having the same issue or has any solution or explanation to this? Before I updated it only crashed once in a while. Now it doesn't start up at all.

    3
    Comment actions Permalink
  • Avatar
    Richard Kane

    Dear Nastia. I have done the terminal re-install, carried out everything to the letter. It worked the first time but when I tried to start editing, it came up Unable to edit..... . Also, even using L3 as a stand alone, the favourites tab in the look up menu doesn't work. I've given up, I'll still use L2018 which works well for me and hope your guys fix all the bugs and keep issuing updated software.

    2
    Comment actions Permalink
  • Avatar
    Steven Eisenman

    On iMac 10.14.3. Takes longer to open. Getting longer spinning colored wheels. When I use Apple+W it quits the entire ap, rather than just removing the picture from the screen.

    Also, they have not brought back the revert to previous and history tool.

    And I hate the way it controls how I file pictures, rather than just being an isolated program.  If I delete a picture and empty it from trash, it takes it from the desktop folder I had it it, not just the Luminar Ap.

    It altered my Favorite settings.

    No real improvement over 2018, which is so much more user friendly.

     
    0
    Comment actions Permalink
  • Avatar
    Richard Kane

    I agree with Steven Eisman. L2018 is much better. L3 is a total disaster. I can't get it to access my photo library and do what I do in Apple Photos, that is edit, re-edit, change, ..... all working from the original .NEF or .DNG and using L as an editor without having to save multiple versions of .jpegs or Tiffs. That is what it's supposed to do but at the risk of repeating myself, again, it doesn't matter because it's full of bugs everywhere.

    1
    Comment actions Permalink
  • Avatar
    Jan Willem de Visser

    @Steven Eisenman The revert to previous and history tool can be found just above "LAYERS" in the edit right-side panel. It's the clock symbol.

    0
    Comment actions Permalink

Please sign in to leave a comment.