Luminar 3.0.2. Here's what's new.

Featured

Comments

63 comments

  • Avatar
    Andrew Hewitt

    It's much better here for me, managed to open folders and edit some images without a crash (so far!).

    I added a new folder set, adding another year's worth for 2018 images. All good there, but when I closed and relaunched Luminar, there was no selected folder, and the folder I had been working on no longer shows the sub-folders. I can click on the root folder, and see all the images inside.

    I relaunched again, and this time a different folder was not showing sub-folders, but the previous one was now showing OK.

    Still some work to do guys.

    It's usable now, but still no Lightroom replacement.

    All the best.

    Andy

    (using iMac and macOSX Mojave)

    2
    Comment actions Permalink
  • Avatar
    Colin Boyd

    Just updated and it's very unstable on my PC.

    Go to edit a photo and it crashes, not always the same point in the edit.

    Colin

    Windows 10 [insider]

     

    Event logs https://we.tl/t-NynXrh7fwm

     HIDE = 570aa884824d5d3d08154e1fdba297e7

    2
    Comment actions Permalink
  • Avatar
    John Newton

    Mac (27-inch, Late 2012) 2,9 GHz Intel Core i5 16GB ram

    Mac version: Crashed on first run after update ,Second run crashed on loading old catalogue ,created new cat  ,hung and crashed .. i give up ,going back to 2018 :-(

    2
    Comment actions Permalink
  • Avatar
    Andy H

    This update has done nothing again! What is happening?

    Still takes far too long to update the image gallery when loading. Better than the 15+ minutes I was getting with the 3.0.2 soft launch version, but still unacceptable. So, I decided to compare 3.0.2 with my other software that I use.  Times below are from click on icon to load until the time I was able to access my photos and begin editing:

    ON1 Photo RAW 2019.2: 15 seconds

    Topaz Studio: 19 seconds

    DxO PhotoLab 1: 22 seconds

    Affinity Photo: 14 seconds

    Luminar 3.0.2 (3051): 8 minutes 14 seconds

    I'm done, after over 5 years as a loyal customer. Farewell Skylum, so much for great photos in less time.

    UPDATE:

    Tried several times.  Clean install including removing the catalog folder. Loading times anywhere between 8 and 17 minutes! When eventually loaded, editing seemed to be a bit snappier, but frequently freezes or crashes as I move between Edit and Library modules.

    Luminar 2018: loads in 15 seconds.

    35,000 photos. Late 2015 iMac, 16 Gb RAM, >800 Gb of HDD space left.

     

    1
    Comment actions Permalink
  • Avatar
    Mark Skinner

    Very responsive for me after installing.

    Much quicker navigation and opening of images.

    To be fair it wasnt too bad at all for me with 3.0.1 other than a few crashes and some frustrations with features.

    1
    Comment actions Permalink
  • Avatar
    Shawn Pearce

    Much better than before but still has a bit to go. Startup is still painfully slow albeit much improved over the last update. Loading a photo and editing work good. It's getting there but still takes well over a minute to load on a SSD. 

    My system spec is Core i5 8600k @ 4.4 ghz, 16 gb DDR4 ram and a GTX 1080 graphics card so my system isn't at fault

    1
    Comment actions Permalink
  • Avatar
    John Barnett

    After over a month, I finally get to try out the program -- not getting any database failed to open error.  I will start testing the program and let you know how it goes.  The interface looks nice.  So kudos right now for correcting the major problem. 

    1
    Comment actions Permalink
  • Avatar
    Richard Browne

    Windows 10 version Luminar 3.0.2 library is pointed to my Pictures folder.  How can I get it to point to only a subfolder to speed up operation?  Also, You say that I can remove folders from L3 without deleting them from the hard drive.   How?  Right clicking on the folder only gives me the opportunity to "delete forever"

    1
    Comment actions Permalink
  • Avatar
    Bruce Cole

    I have sent you the event log report via email as requested, I have also sent you a copy of the photo as well via Wetransfer. Windows defender will not allow me to run the HID.exe file and I won't be attempting to circumvent that.

    FYI, Luminar 2018 managed to edit the photo without any problem.

    1
    Comment actions Permalink
  • Avatar
    Jerry Cheng

    After updating to 3.0.2

    I can not run the app anymore

    Please help me

    thank you.

    1
    Comment actions Permalink
  • Avatar
    Peter Sinnaeve

    The update broke Luminar for me too (mac, 2017 MBP mojave). I just get to see the splash screen and then it vanishes.

    Very, very dissapointed in T Skylum. Please get a fixed update out asap.

    1
    Comment actions Permalink
  • Avatar
    Freddie Thompson

    The 3.0.2. update on OS High Sierra is complete broken for me. I see the splash screen for a few seconds and then it's gone and I get a “problem report box” pop-up a few seconds after. I've also tried deleting the app, downloading and reinstalling but the outcome is the same. I can't edit any photos now. What are your refunds policy? 

    1
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi guys! If Luminar crashes on a startup (Mac) please try reinstalling the app.

    Follow the steps below:

    Download AppCleaner from here:

    http://www.freemacsoft.net/appcleaner

    AppCleaner is a free app that automatically removes not only the applications themselves but also the related files, making 'clean' uninstall easy.

    When removing Luminar 3, mark all the files and folders in the list, except for DPA6233TPQ.com.macphun.luminar3.

    Once you're done uninstalling the app, restart your Mac and download a fresh version from here:

    https://luminar3.s3-accelerate.amazonaws.com/mac/Luminar3Installer.zip

    If you need help with the installation, check out this page:

    https://support.apple.com/kb/ph25083?locale=en_US

    @Andy Please note that you can use the Quick Edit function if you don't want to use libraries. Also, you can use the app as a plugin.

    @Robert Could you send us a screen recording of the issue with zoom? It would be very helpful.

    If you are on Windows:

    You can use Monosnap to record your screen: https://monosnap.com/welcome

    If you are on Mac:
    Here's how to record your screen on Mac: https://support.apple.com/guide/quicktime-player/record-your-screen-qtp97b08e666/mac

    Here's how you can send us the file with the recording:

    1. Visit https://wetransfer.com/
    2. If it's your first time visiting this website, it might ask you to purchase a subscription. Simply select to proceed with the free version.
    3. Click Add your files.
    4. Select the file(s) on your computer.
    5. After you see all the files you need to send appear in the list, click the icon to the left of the Transfer button (the icon looks like a circle with three dots in it).
    6. In Send As select Link.
    7. Click Transfer.
    8. After the files have finished uploading, click Copy Link and send it to support@skylum.com

     

    1
    Comment actions Permalink
  • Avatar
    Hillman Lo

    Chetan, it happened to me in previous version. 

    1
    Comment actions Permalink
  • Avatar
    Alan Bee

    I figure I may as well document my trials and tribulations here.

    First issue - Luminar 3.0.2 wouldn't start. Just a momentary glimpse of the flash screen. SOLVED by Anastasia with her suggestion to remove Luminar and reload a new version (see her post above).

    Second issue - New version froze when cropping and correcting crocked horizon. As with version 3.0.1 I have to shut down Luminar. In 3.0.1 it completely locked my iMac and I had to KILL the iMac completely and restart. Always returned to the photo I was editing with cropping completed. In 3.0.2 at least I was able to close Luminar and reopen .... the first time it happened. However, the second time it froze, again while cropping, I closed Luminar but now it won't reopen. Clicking the app shows Luminar in the application menu bar at the top of the screen but there is no application window actually open to work from - just my screen background. Will go through the process of removing Luminar again and reloading a new version.

    I can't keep using this app if it is not stable and I have to kill the iMac each time it freezes or have to remove the app and reload. I actually like Luminar but these issues are taking my forbearance to new heights.

     

    1
    Comment actions Permalink
  • Avatar
    Phong Thai

    I had already sent the files but it seems no one has ever tried to reproduce the issue at your end? (instead blindly guiding me to try something not very logically - I'm a programmer myself). Please try the files I sent you, and confirm if you can reproduce the bug (I believe you'll see the bug as I do). Thanks.

    1
    Comment actions Permalink
  • Avatar
    Bruce Cole

    Brilliant... it crashed opening the first ever photo I opened to edit.

    You couldn't make it up...

    So when is the next update that will address stability issues?

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Bruce,

    I'm very sorry to hear that you had a crash with the first photo you edited using the update!

    We need to be able to reproduce the issue on our end in order to understand at which point it occurs. Please email us at support@skylum.com with a detailed step-by-step description of what you do in the software before encountering the issue. You can also make a screen recording. You can use Monosnap to record your screen: https://monosnap.com/welcome

    If the issue occurs when you're working on an image, send us the image file. Here's how:

    1. Visit https://wetransfer.com/
    2. If it's your first time visiting this website, it may ask you to purchase a subscription. Simply select to proceed with the free version.
    3. Click Add your files.
    4. Select the file(s) on your computer.
    5. After you see all the files you need to send appear in the list, click the icon to the left of the Transfer button (the icon looks like a circle with three dots in it).
    6. In Send As select Link.
    7. Click Transfer.
    8. After the files have finished uploading, click Copy Link and paste it into your email.

    In case the issue leads to a crash, send us event logs:

    1. Reproduce the issue.
    2. Press the Windows logo key + R.
    3. Type eventvwr in the dialog box that opens and hit Enter on your keyboard.
    4. In the window that opens click the triangle next to Windows Logs on the left. A directory tree should open.
    5. Click Application in the directory tree. 
    6. In the main part of the window find the two topmost entries marked with Error named Application Error and .NET Runtime.
    7. Hold CTRL and click your left mouse button on each entry to select them both.
    8. Right-click on any of the two selected entries  and click Save Selected Events.
    9. Name the file, save it, and attach it to your email.

    n order for us to directly track this issue, please send us your HID1 and HID2 codes:

    1. Download this application: https://www.dropbox.com/s/3pf15jdigd0mgt4/ViewHID.exe.zip?dl=0 
    2. Launch it.
    3. Copy the HID1 and HID2 codes from the application's window and send them to us.

    Looking forward to hearing from you.

    0
    Comment actions Permalink
  • Avatar
    Alina Skylum

    @Andy H, @Colin Boyd - Please follow the instructions above to send us a screen recording and/or image, crash and/or event logs, and HID1 & HID2 codes.

    @Richard Browne - Please right-click on the parent folder to get the Remove From Catalog option. You can then go back and add the subfolder(s) you wish specifically.

    @John Newton - We need to be able to reproduce the issue on our end in order to understand at which point it occurs. Please email us at support@skylum.com with a detailed step-by-step description of what you do in the software before encountering the issue. You can also make a screen recording:

    https://support.apple.com/guide/quicktime-player/record-your-screen-qtp97b08e666/mac

    If the issue occurs when you're working on an image, send us the image file. Here's how:

    1. Visit https://wetransfer.com/
    2. If it's your first time visiting this website, it might ask you to purchase a subscription. Simply select to proceed with the free version.
    3. Click Add your files.
    4. Select the file(s) on your computer.
    5. After you see all the files you need to send appear in the list, click the icon to the left of the Transfer button (the icon looks like a circle with three dots in it).
    6. In Send As select Link.
    7. Click Transfer.
    8. After the files have finished uploading, click Copy Link and paste it into your email.

    In order for us to directly track this issue, please send us your Hardware UUID:

    1. Click the Apple icon in the upper left corner of your screen.
    2. Click About This Mac.
    3. In the window that opens, click System Report.
    4. In the window that opens, make sure Hardware is selected in the column on the left.
    5. Locate the Hardware UUID string, copy it, and paste it into your email.

    In case the issue leads to a crash, send us crash reports:

    1. Open Finder.
    2. Click Go in the top menu > click Go to Folder.
    3. Paste the following path: ~/Library/Logs/DiagnosticReports and click Go.
    4. In the folder that opens find the most recent files with Luminar 3 in their names and attach them to your email.

    In case there are no crashes, collect the log from the console:

    1. In Finder, navigate to Applications > Utilities.
    2. Start Console.
    3. Type in Luminar in Console's search bar in the upper right and press Enter on your keyboard.
    4. Start Luminar and try reproducing the issue. Make sure to note all the steps you perform in the app that cause the issue.
    5. Go back to Console, select all entries in it (to do so you can press CMD+A on your keyboard) and press CMD+C on your keyboard to copy them to clipboard.
    6. Create a new text document and paste (CMD+V) the contents of the clipboard there.
    7. Send us the text document you created in Step 6.

    Looking forward to hearing from you.

    0
    Comment actions Permalink
  • Avatar
    Gareth Murran

    Great work team. The update is excellent.  I have gone from frustration to being very happy with the app.  I now look forward to focusing on editing some photographs. 

    0
    Comment actions Permalink
  • Avatar
    Andy H

    Thanks for the information Alina.  I've submitted an event log to the support team. After 20 minutes, Luminar still had not loaded - so hopefully the log will reveal some useful information. I could not provide HID1 and HID2 codes as the file dowloaded is Windows only and I'm on a Mac.

    0
    Comment actions Permalink
  • Avatar
    Richard Huggins

    What's not new is a recurrence of the same problems I told Skylum about after the soft launch. Identical to my previous post. All edits gone. Luckily I don't trust the program so there was only a few trial edits there. I see others are now having the same problem.

    0
    Comment actions Permalink
  • Avatar
    Nicolas Dehaine

    So far, the upgrade seems to have addressed the major issue I had with 3.0.1 - random crashes experienced while browsing through pictures.

    Switching between pictures is also much, much faster (OSX Mojave on 2017 iMac).

    0
    Comment actions Permalink
  • Avatar
    Robert Turner

    Getting better but way short of what I would expect for a usable DOM.

    The Rotate shortcuts are working now - thank you

    I would still like a way to filter out .jpg sidecar files when a raw file is present.

    If a picture is rotated, when entering edit mode it will  look correct then zoom out then zoom back to the same level as it was when entering edit mode, what gives?

    Still no way to sort Albums or get sub albums

     

    0
    Comment actions Permalink
  • Avatar
    Andy H

    I decided to do a fresh install of Luminar 3.0.2, and didn't sync any of my photos with it. Luminar loads much quicker.  Opened a photo for a quick edit, and it was very fast and no crashes or freezing.

    Seems to me that the Libraries module is causing all the issues for me. The excessive load times, the instability using Luminar when switching between Edit and Library modules. I wish Skylum would give you a choice whether to use Libraries or not in the set up. Will be interesting to see what the Support Team come back with after reviewing my event log.

    0
    Comment actions Permalink
  • Avatar
    Alessandro Miele

    Broken for me too. I can just see the splash screen and then crashes... :(((

    0
    Comment actions Permalink
  • Avatar
    Alan Bee

    Just downloaded 3.0.2 and complete no go. A momentary flick of the splash screen then gone. Downloaded 3.0.2 twice and same result. Unable to use Luminar3 at all now. This is serious! How do I go back to 3.0.1 which truth be told would freeze on me several times a night and was getting very frustrating but better than nothing at all.

     

    0
    Comment actions Permalink
  • Avatar
    Alessandro Miele

    @Nastia, thanks, following the instructions fixed the issue.

    Have a good day

    0
    Comment actions Permalink
  • Avatar
    Mary Shelsby

    I have no clue if it is faster or more stable because I can not get the update to install.  I've tried at least 20 times and it gets to about 66% and crashes.  And when I contacted skylum, they simply send me a form letter telling me to check their libraries for an answer.  Not very good customer support at all.

     

    0
    Comment actions Permalink
  • Avatar
    chetan panchal

    in the grid view, after rotating an image it is not refreshing to proper shape, like from portrait to landscape or vice versa. also bring back the auto example attached

    0
    Comment actions Permalink

Please sign in to leave a comment.