Editing Panel Greyed Out

Comments

26 comments

  • Avatar
    Jakob Beclin

    Same problem here. This problem also occurs if you have already edited the image. For unedited images the editing works for me - but only very, very, very ... slowly.

    I hope the important update 3.1 will be released soon.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    HI Brent and Jakob,

    We've identified that the AI Sky Enhancer doesn’t allow to continue adding filters after it’s been applied to a RAW.

    It will be fixed in 3.1.0.

    0
    Comment actions Permalink
  • Avatar
    Jakob Beclin

    Thanks!

    Are the bugs fixed in version 3.1 or 3.0.2? The roadmap now contains something else ...

    1
    Comment actions Permalink
  • Avatar
    Brent Wilson

    The problem that I have is not related to a previously edited image.  When I attempt to edit a JPG, TIFF, or RAW file, the editing panel is greyed out, so I can't do anything.  The info tab works, but that is all.  I don't know if it is greyed out for a previously edited image because I can't do an initial edit.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Jakob,

    The roadmap was just recently updated. To the best of my knowledge the AI Fix will be coming in 3.1.0, but I'll see if I can get an update from our tech team.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Brent,

    Has it worked previously, or have you never been able to edit images in Luminar 3?

    0
    Comment actions Permalink
  • Avatar
    Andrew Amster

    I'm having the same issue as Jakob above. If I've edited an image in any way, I cannot get the Editing Panel back for that image. So far, those are all RAW images on which I did NOT use the AI Sky Enhancer; the problem is not confined to that specific filter.

    0
    Comment actions Permalink
  • Avatar
    Brent Wilson

    After reading some other comments, I decided to open an image for editing and then wait.  After waiting over 5 minutes (I timed it), I was able to use the filter panel.  After clicking on one of the filters to edit the image, after 10 minutes (again timed) the filter adjustment showed on the edited image.

    I guess I just need to be patient in my editing and also patient in waiting for the next update which will hopefully speed up the program.  Luminar 2018 works fine on my Windows system without any delays in opening or editing.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    @Brent - Glad to hear you're up and running, even though it's slow. Performance improvements are coming soon.

    @Andrew - Are you using any of the AI filters on your images?

    0
    Comment actions Permalink
  • Avatar
    Andrew Amster

    Hi, Angela. I just tested it for five minutes. I opened a RAW image and only applied non-AI filters (so... it isn't just the Sky Enhancer, right?). I went back to the Library and opened a different RAW image. When I did, the Edit Panel inherits the filters from the photo I had before, but the entire panel is grayed out, elevator doesn't work, no way to remove the filters that are there. And, if I go back to the Library and try to reopen the first photo, I get no photo visible in the main window and the Edit Panel still grayed out. In short, not usable. I'm done doing QA here. I'm going to stick with Luminar 2018 until you announce the next Luminar 3 revision. Thx.

    1
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi Andrew! I am sorry to hear that. If you could cooperate with us and send screenshots/screen recording of the issue we would be glad to investigate the case. We are aware of the issue with AI Sky Enhancer, but not the other filters.

    You can use Monosnap to record your screen: https://monosnap.com/welcome

    Here's how you can send us the file with the recording:

    1. Visit https://wetransfer.com/
    2. If it's your first time visiting this website, it might ask you to purchase a subscription. Simply select to proceed with the free version.
    3. Click Add your files.
    4. Select the file(s) on your computer.
    5. After you see all the files you need to send appear in the list, click the icon to the left of the Transfer button (the icon looks like a circle with three dots in it).
    6. In Send As select Link.
    7. Click Transfer.
    8. After the files have finished uploading, click Copy Link and send to skylum@support.com
    0
    Comment actions Permalink
  • Avatar
    Rodolphe EGRET

    I have the exact same issue as Andrew and when I contacted support I was told this was a performance issue that should be fixed soon. What annoys me is that it is clearly not a performance but a corruption issue (of the .lmnr file I assume) and no troubleshooting whatsoever was made. 

     

    0
    Comment actions Permalink
  • Avatar
    Vereslavska Anna Veres

    Hi Rodolphe, please note that the greyed out edit panel means that the image is currently processed by Luminar 3. If it is a small JPEG file without edits, the edit panel will be active after a few seconds for example. 

    In case if the issue persists, please send us the screen recording as Nastia Devis suggested. 

    Please send it to skylum@support.com

    0
    Comment actions Permalink
  • Avatar
    Andrew Amster

    Anna, a grayed-out edit panel should not happen for any photo. If I've edited it before and am reopening it, your .lmnr file should tell Luminar exactly where things left off. Is it trying to apply the entire editing history before it restores the edit panel? On a very good PC, that should take... seconds. Not... never. AND... when I open a new photo that's NEVER been opened by Luminar before, there's NO excuse for the panel to be grayed out. It should not be processing that new photo at all... no inherited filter choices, no history, nothing. I hope this is all performance issues, but I wonder.

    1
    Comment actions Permalink
  • Avatar
    Colin Grant

    Have had this in Mac when going into images edited on L3. If I switch away from the image and then come back to it it seems to correct itself. I think it is a performance issue, the slow updating of previously edited images.

    0
    Comment actions Permalink
  • Avatar
    Denis Kotsee

    @Andrew Amster the fact that there aren't any filters applied doesn't mean that there won't be any processing: the RAW converter has load and process the file before Luminar can apply edits to it. We'll address issues with performance in the update at the end of Jan - beginning of Feb.

    0
    Comment actions Permalink
  • Avatar
    Leila Evans

    Hi Georgios - Please contact us at support@skylum.com with a detailed description of your issue.

    0
    Comment actions Permalink
  • Avatar
    Peter Blair

    Same problem. Not using AI. Not impressed.

    0
    Comment actions Permalink
  • Avatar
    Chris Crayton

    So for me the AI Sky Enhancer is disabled for certain images, for no apparent reason. I can apply any other filter, but not sky enhancer. I have tried deleting the filter and re-adding it, and it is still grey. Just like my mood after dealing with all of these little issues all day. 

    0
    Comment actions Permalink
  • Avatar
    Terry Rogers

    Hi Chris,

    Please try to reinstall Luminar. We recommend doing a full uninstall with AppCleaner. AppCleaner is a free app that automatically removes not only applications but also the related files, making 'clean' uninstall easy.

    • Download AppCleaner from here (click this text to open link).
    • Install AppCleaner and start it.
    • Drag Luminar from your Applications folder into the AppCleaner window. When removing Luminar, mark all the files and folders in the list, except for DPA6233TPQ.com.macphun.luminar3.
    • Once you've uninstalled Luminar, restart your Mac and download a fresh version of Luminar from here (click this text to open link).

    Let us know if that helps. As an alternative, you can always contact us via https://skylum.com/support and we will do our best to help you.

    0
    Comment actions Permalink
  • Avatar
    Stefan Schmied

    Hi,

    perhaps this issue is solved, but personally I still have  the  problem ( Luminar 3.1.3), that I can't edit raw files. The edit section ist grey out and no input is possible. Further the raw (Fuji and Canon) are not geeting sharp.  For me, it seems that Luminar stucks while processing the raw image. Only if I want to edit raw files! I have no problem to edit a jpg.

    This problem seems to be an issue after the last updates. If I close Luminar and restart it,  I can edit a raw, sometimes!

    What I have notices is that the problem seems to depend on the plattform. Primary I use a surface pro (2017) form Microsoft. On this plattform the editing is limited. Sometimes the sliders are not visible (in that case I only see the histogramm and the two filter buttons). When they are visible they are greyed out. 

    After a restart of Luminar (and with some luck) I can edit the picture, which was previously locked.

    I hope you can fix this issue. I like to work with Luminar and I'm very excited on version 4. Of course I hope this bug isn't there.

     

    Best regards,

    Stefan

     

     

    0
    Comment actions Permalink
  • Avatar
    Anna V

    Hi Stefan, 

    I am sorry for the inconvenience.

    Please contact us at http://www.skylum.com/support so we could assist you in a better way.

     

    0
    Comment actions Permalink
  • Avatar
    Tomasz Gomolka

    Same here, I've been using Luminar 3 since the beginning with my Nikon full frame camera. After upgrading my mac to catalina I cannot edit RAWs anymore, only JPEGS.

    I'm using the system for my business so I can't wait till end of the year for the fix...

    I tried to reinstall Luminar but that didn't help

    @support guys, please help!

    Best,

    Tomasz

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Tomasz,

    Please contact us at http://www.skylum.com/support so we could assist you.

    0
    Comment actions Permalink
  • Avatar
    Kevin Matton

    Did you got any help? Same issue here on windows 10!

    0
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    Please contact us via https://skylum.com/support and we will help you.

    0
    Comment actions Permalink

Please sign in to leave a comment.