Luminar3 edit function all frozen after 2 phto edit

Comments

6 comments

  • Avatar
    Enebolsa Ene

    Same here. Windows 10.

    0
    Comment actions Permalink
  • Avatar
    Roy Blackwell

    From what I have read here and tested myself, if you use the AI Sky Enhancer on a raw file, then come back to it later you can not edit it any longer. You must reset your adjustments and start over. Skylum has said they are aware of the issue and it is on the fix list.

    1
    Comment actions Permalink
  • Avatar
    Winfield Terry

    So I ran into the same issue and luckily I have just started using v3 and have only done like 6 edits late last night before running into the issue where I couldn't pick back up on the edits.  Finding the reason here was very helpful as I was able to create a workaround.

    I took a "dummy image" then copied the adjustments from the real picture and pasted to the dummy image and removed the sky AI filter.  Next reset the image adjustments on the real image and make sure you can again edit the image.  Copy the adjustments from the dummy picture back to the real picture and you should then have an image you can edit multiple times assuming you don't add the Sky AI filter back in.

    Hope it helps someone.

     

    0
    Comment actions Permalink
  • Avatar
    Gaby Armitage

    It seems that I have a similar problem like you, I post the bug in another post (https://community.skylum.com/hc/en-us/community/posts/360037157211-Big-problem-with-L3-Windows-10 ) ...

    But, I didn't use the Sky AI filter, just some basic settings.

     

    0
    Comment actions Permalink
  • Avatar
    Chris Wu

    Anyone know have they resolved this issue?

    If not when are they looking at it, I don't see any response from support acknowledge this issue.

    What the point of posting if they (support) do not acknowledge the issue

    It taking too long and now Luminar 3 is like a white elephant residing on my PC.

    sigh

    sigh

    sigh

     

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Everyone,

    When the filters are greyed out and the Looks are not visible, this means that Luminar 3 is still processing your Library. Please, wait a bit or, if this doesn't help, remove your Luminar 3 Catalog and add the folders again starting with the smaller ones and adding the rest later (Library>Add Folder).

    This issue also occurs when you apply an AI Sky Enhancer to a RAW file, like @Roy said.

    To remove Luminar Catalog:

    1. Make sure Luminar is closed.
    2. Locate your Luminar Catalog folder. The default location is C:\Users\%username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    3. Remove the Luminar Catalog folder.

    Note that the albums you created in Luminar and edits you made will be removed. Your photos on disk won't be affected in any way.

    We're aware of the performance issues, and we're truly sorry if you encountered them.

    We will release an update meant to target these issues at the beginning of February.

    Sorry for the temporary inconveniences and thank you all for bearing with us while we fix this.

    0
    Comment actions Permalink

Please sign in to leave a comment.