Luminar 3.0.1 is here

Comments

35 comments

  • Avatar
    Jose Castro

    This patch isn't working. I can hear my 24Gb RAM machine accelerate but it's hung on the initial loading dialog. After it finally loaded, it showed that my trial has kept counting down. I guess yo're not offering an option there. I have not been able to use this software from the very same day I installed, but guess the only thing working really good is the trial timer. At least you got something working right. I love Luminar 2018, but L3 is a total disappointment. My plans to get it at this moment have completely vanish. I would not pay for a software still in beta mode, yet alone one that have no clear date for the resolution of it's many, many problems. I guess that when you come out with a version where I get to read excellent reviews, I might decide to consider purchasing your product. I see some responses to the language issue but to when the software will be market ready, none, just speculation about patches that "may fix" some issues.

    2
    Comment actions Permalink
  • Avatar
    Russell Heller

    I've tried the 3.0.1 hot fix...and it fixed nothing.  Catalog does not work correctly.   Reads network drive...randomly loads subfolders and catalogs some of the images in them.  Does not display anything in any subfolder....takes for ever for the Luminar 3.0.1 to load up...can not begin editing anything....Real shame you released this before it was ready...you've just made a joke out of using Luminar 18, as there is NO migration upgrade path...Will be uninstalling Luminar 3 and 18 from my systems...will try again when and if you get it working in 3.1 or 4.0   

     

    1
    Comment actions Permalink
  • Avatar
    Claude Beauchemin

    I will be watching in further video what he will say or explained about the Luminar 3.

    He just put a new video (Jan 4, 2019)   https://www.youtube.com/watch?v=8cakDs4ARS0&feature=em-uploademail

    0
    Comment actions Permalink
  • Avatar
    Stefan Kremer

    I had the same problem with the program not starting after the update. I tried everything I could within an acceptable amount of time. Finally I ended up deleting the contents of the program folder and the appdata\roaming\luminar 3 folder. Then I copied those two directories from my last file backup - and luminar 3 started again with the old version. So, whoever has a backup of those two folders should be very lucky ;-)

    Personally, I will check off the purchase as a bad investment until further notice and continue working with Zoner until there is an executable update from Luminar.

    Greetings
    Stefan

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    If you're having difficulty with the patch please contact us at www.skylum.com/support and we'll sort it out.

    0
    Comment actions Permalink

Please sign in to leave a comment.