Luminar 3 Update From Support Team 2

Comments

22 comments

  • Avatar
    Larry Moore

    "Edit > Plugins > Other > Open Plugin doesn’t work from the gallery view.

    Workaround: invoke third-party plugins from the single image preview. Will be fixed in 3.1.0."

    Please explain. I still see no way to invoke third-party plugins.

     

    0
    Comment actions Permalink
  • Avatar
    Guy Meacham

    For 3.1 please change it so that Luminar doesn't automatically show all the photos all mixed up of the chosen folder and  all its sub folders. We put photos in sub folders for a reason! It's impossible to work with files like this especially when you can't even see the file name easily!

    Photos in a Subfolder should not show when looking at the photos in the folder above. At least there should be the option to turn that strange behavior on and off.

    Thanks.

     

     

    4
    Comment actions Permalink
  • Avatar
    François Hamon

    Agree with Guy-Meacham. This option of importing or not sub folders (so to choose which folders to import into DB) is a basic one and whithout it I would not use L3 at all. It is that simple !

    If a reason has to be given : I put my raw files to the main folder then only processed images go to a sub, that has NOT to be mixed up with the above one (or it would be a mess - the kind of mess L3 produces).

    4
    Comment actions Permalink
  • Avatar
    Denis Kotsee

    @Larry Moore third-party plugins are coming to Windows in one of the upcoming updates for Luminar.

    @Guy Meacham you can navigate subfolders in the right panel while in library mode.

    0
    Comment actions Permalink
  • Avatar
    Colin Grant

    @Guy Meacham, why is so difficult to navigate through the folders in Library mode? The current behaviour is the same as in Lr and it seems perfectly sensible to me. If I want to see all photos I go to the highest folder appropriate and if I want to be more selective I can select a sub folder or use the 'Go To' option to see all images of the same date.

    0
    Comment actions Permalink
  • Avatar
    David Rossi

    Flip is lost when exporting.  Please fix...

    Thanks

    0
    Comment actions Permalink
  • Avatar
    Guy Meacham

    @Denis Kotsee @Colin Grant, so perhaps I'm missing something?

    All my raw files for a specific event are in a folder, when I export edited images of those files I export them into a sub folder. Yes I can see only the edits if I navigate to that subfolder but if I want to look at the original raw files again and move up one folder it shows all the original raw files and all the edits all mixed up together. 

    Couple this with the fact that there is no easy way to see full filenames in library mode how am I supposed to know which version I am looking at?

     

     

     

    3
    Comment actions Permalink
  • Avatar
    Denis Kotsee

    @Guy Meacham I see what you mean, in this case subfolder navigation doesn't really cut it. You may want to try one of the following:

    • change your organization a bit, so that you have a folder structure like this:
      -event
      --RAW
      --EDITED
    • or, if you'd rather not change anything in your organization, select the event folder and sort by file type.
    0
    Comment actions Permalink
  • Avatar
    Denis Kotsee

    @David Rossi can you consistently reproduce the issue with the flip not being exported? If yes, please send us a step-by-step description of what you do in Luminar before encountering the issue. If this happens only to a particular file, send us the file as well.

    Here's how you can send us the file:

     

    1. Visit https://wetransfer.com/
    2. If it's your first time visiting this website, it might ask you to purchase a subscription. Simply select to proceed with the free version.
    3. Click Add your files.
    4. Select the file(s) on your computer.
    5. After you see all the files you need to send appear in the list, click the icon to the left of the Transfer button (the icon looks like a circle with three dots in it).
    6. In Send As select Link.
    7. Click Transfer.
    8. After the files have finished uploading, click Copy Link and paste it into the reply to this post.

     

    0
    Comment actions Permalink
  • Avatar
    David Rossi

    Denis, to what email address do you want me to WeTransfer my example files?

    Yes, I can recreate this bug with this specific DNG file every time.

     

    0
    Comment actions Permalink
  • Avatar
    David Rossi

    Never mind, I just reread the LINK instruction above.  Sending now.

     

    0
    Comment actions Permalink
  • Avatar
    David Rossi

    Note about that DNG file, it was converted from Nikon NEF raw file to DNG about six years ago using LightRoom.  I no longer have the NEF file.  I also tested this flip bug with a recent conversion from NEF using the current version of Adobe DNG Converter App, current DNG directly from Leica MD, and a current conversion from a three year old Cannon raw file.  All flipped fine but the old one.

     

    0
    Comment actions Permalink
  • Avatar
    Guy Meacham

    @ Dennis Denis Kotsee, yeah there are work arounds like changing how I store my files. I just think though that if Luminar is mirroring the File structure of how we have sorted our photos in file manager it should behave in the same way as when you are using filemanager or other imaging software like ON1. Every other imaging viewer software I've ever used also does not open subfolders automatically when in the folder above. I am seeing other requests for this too in other threads.

     

    thanks. 

    2
    Comment actions Permalink
  • Avatar
    Denis Kotsee

    @David Rossi I thought you sent us the WeTransfer link via email but I couldn't find anything related to this thread in the communications from your nc.rr.com email. Were you going to post the link here?

    0
    Comment actions Permalink
  • Avatar
    David Rossi

    https://we.tl/t-1yQ2kk0sAj

    Thanks

     

    0
    Comment actions Permalink
  • Avatar
    David Rossi

    Here are two of my original NEF files that also fail to flip on jpeg export.

    https://we.tl/t-NFOG5W8TeR

     

     

    0
    Comment actions Permalink
  • Avatar
    David Rossi

    The issue appears to be with older NEF files.  I will also test exporting to other file types to determine if the bug is only in the jpeg export.

     

    0
    Comment actions Permalink
  • Avatar
    David Rossi

    They all fail to flip....

    0
    Comment actions Permalink
  • Avatar
    Denis Kotsee

    Thank you for sending us the files, David, I was able to reproduce the issue and have already filed it with the QA team. We'll do our best to fix this as soon as possible.

    0
    Comment actions Permalink
  • Avatar
    Phil Hurd

    @Guy Meacham I think your issue is more about how you store your original images rather than an issue with Luminar. I like being able to see all my files from a top level folder, something you can't do in FINDER.

     

    Best wishes, Phil

    0
    Comment actions Permalink
  • Avatar
    Guy Meacham

    @Phil Hurd, That maybe Phil, but it's just counter intuitive to me. It's not how any other windows image viewer / editor I've ever used works. I mean when you open a folder in windows file manager it doesn't show you every file in every sub folder too with know way to know which file is which. If there was something like filename mouseover it might not be so bad but even finding the name of the file is a slow multi mouse click process one file at a time!

    To me L3 for Windows lacks even the most basic functions of Digital Asset Management. I'll be sticking with ON1 for file management and most of my editing because it mirrors perfectly my windows file structure & more importantly it works! I've pretty much given up on Luminar after this latest release.

     

    I just cant fathom how L3 was released in such an incredibly poor state after 14 months of promises which are still not being realized.

    Example.

    Just a couple of days before L3 release windows users were told we would finally be able to use third party plugins

    After release we were told sorry that was a mistake it will be in 3.1

    Yesterday we were told it wont make 3.1 - now some unknown time in the future!

    Cheers.

    0
    Comment actions Permalink
  • Avatar
    Phil Hurd

    Ah didn't realise you were using Windows. I think the Folder/Sub-folder issue is a matter of personal taste. I have to say I like it because it suits my way of working and I'd be quite sad it it wasn't there, though it wouldn't be the end of the world.

    I've looked at pretty much every photo cataloguing/library/DAM there is (for the MAC) and I still come back to Lightroom, though I think that Skylum will get there in the end. There are a couple of apps that are Windows only that look pretty good but I really don't want to go back to running VMware, just for a single Windows app. I also have a complete aversion to subscription only Apps.

    I agree that Luminar 3 should not have been released in its current state but we are where we are. I have read a number of posts that are quite vitriolic about the library function with suggestions that Skylum should never have even attempted such a thing.

    My perspective is different (of course!) Skylum, originally MacPhun were a MAC software house and I think they overstretched themselves when they tried to bring out a Windows version. It certainly slowed the MAC  development to a crawl. For all the angst (rightly) expressed by Windows users, doesn't help when you feel that we would have had a really good product for the MAC without that distraction.

    Good luck with ON1, I never got on with it I'm afraid.

    0
    Comment actions Permalink

Please sign in to leave a comment.