Luminar 3......APPalling!!!!

Comments

4 comments

  • Avatar
    Markus Ottiger

    Exactly the same on my PC:

    Install starts OK edits OK, loads Libraries...all fine

    Close down and restart...image file data appears, histogram appears, all features appear, BUT NO IMAGE(S)

    1
    Comment actions Permalink
  • Avatar
    Dave Palugyay

    You guys aren't kidding!  Fired it up today on my day off, and it took about three minutes to even load this program.

    Now after importing 2018 image directory with about 50 subfolders/20,000 Sony and Oly raw files, it's just now at 7% after 30 minutes.  I will continue trying to use this crapware, but my patience is already being tested.  I can easily seeing this crap getting uninstalled by lunchtime out of sheer frustration.

    EDIT:  So I walk away from the computer while this piece of junk tries to load a folder. for an hour  I come back to the software crashed out.  Who the heck tested this GARBAGE?????

    1
    Comment actions Permalink
  • Avatar
    Trond Hermansen

    Sauken

    Many things here. Opening an image in photoshop from luminar takes several minutes. I use prophoto colorspace, obviously different from what Luminar uses, so the colors are entirely different i LR an PS.  Overall....Deeply dissapointed, this sw show nwvwe never been released!!!!!!

     

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    We released a patch over the weekend (more info here: https://community.skylum.com/hc/en-us/community/posts/360036043011-Luminar-3-0-1-is-here) If you haven't already, please install it and let us know if the issue persists here or by creating a support ticket at http://www.Skylum.com/Support and linking to this thread.

    0
    Comment actions Permalink

Please sign in to leave a comment.