Comments

7 comments

  • Avatar
    Neil Palmer

    I found the same after using it once so deleted it from the PC and then reinstalled it and it appeared to work. The big problem I have is that it will not let me edit any picture and they all look out of focus.

    I have reverted to 2018 for the time being

  • Avatar
    Hans Wahlgren

    I also have this problem. I installed L 3 and it started at first. L 3 had an initial update for my 150 000 photos. The day after that L 3 refused to start any more. It's nothing more then the blue Windows circle spinning indicating "work in progress". After 15 minutes of patient waiting there's nothing else to do but closing it down by force. Now I want to uninstall L3, but I have read that when unistalling L3, the program not only delets itself, but also the photo directories that has been connected to L 3. Can that be true? How do I safe uninstall?

  • Avatar
    Neil Palmer

    I just uninstalled it as I believed that the Libraries were some form of locally held image.
    My files were fine and after reinstalling Luminar 3 all my files were still there.

    I still have it installed, but am using 2018 as that works fine albeit without the catalogue.

    The way I uninstalled it was to open the apps in Windows settings, find Luminar 3 and then click uninstall. (Luckily I had created a separate directory from 2018 so that wa fine)

    Hope this helps a little, Good Luck

  • Avatar
    Richard Boyle

    I had exactly the same problem. It loaded fine the first time, I imported my photos into the library. I even managed to do a little bit of editing. Then I had to restart my computer for some reason other than Luminar and it simply doesn't go past the splash screen. CPU action is 0 and it's taken 430mb of RAM.
    I tried uninstalling 2018, and I trawled through the registry to remove every instance of Luminar. Same problem.
    I can't figure out why it would start first time and work, then die. Perhaps it's something due to the libraries or something that were updated.
    This is obviously a totally screwed release that was not tested properly. A serious disappointment and I hope not a fatal one to the company because Luminar is good, well the 2018 version at least..

     

    This was going to be a Christmas present for a friend, but now someone at Skylum is getting coal.

  • Avatar
    Mark Reierson

    same problem, built Library but then wanted my to "buy" it. Couldn't find anywhere to put activation code and so tried to restart the program. now it wont show anything other than the splash screen....

     ------

     

    UPDATE:

     

    Found this thread:

    https://community.skylum.com/hc/en-us/community/posts/360034996871-Notes-on-defects-with-and-complaints-about-Luminar-3

     

    and I went into my/pictures folder and deleted the Luminar Folder.

    I had at this point uninstalled and downloaded the trail version. I then activated the trial version and it seemed to start up ok.

    I have not rebuilt the catalogue or anything yet. but I am in at least -- for now.

  • Avatar
    Ron DiLaurenzio

    Just adding to the list - my Luminar 3 does not start either.  Has anyone heard a status on this issue from Skylum?  Surprised to see not a single comment from support or a global email to all users...

  • Avatar
    Angela Andrieux

    We released a patch last weekend (more info: https://community.skylum.com/hc/en-us/community/posts/360036043011-Luminar-3-0-1-is-here) If you haven't already, please install it.

    You can also visit the News & Updates section of the forum at https://community.skylum.com/hc/en-us/community/topics/360000158652-News-Updates to read the Luminar 3 Updates From Support (to date there are 6 of them) for an updated list of known issues, estimated fix dates, and workarounds.

    If you’ve encountered a problem not listed please file a support ticket at https://www.skylum.com/support 

Please sign in to leave a comment.