Luminar 3 cannot see photos in library

Comments

41 comments

  • Avatar
    Kirk Osborn

    Hi. Please contact us via https://skylum.com/support and we will figure something out.

    0
    Comment actions Permalink
  • Avatar
    Jack Goral

    https://skylum.com/support?_ga=2.168598690.2036514361.1556493422-1127688064.1556493422 fixed my problem.

    I renamed 'Pictures/Luminar Catalog' folder with Luminar 3 closed, opened Luminar 3 and added folder with my photos again.

    0
    Comment actions Permalink
  • Avatar
    Lars Richter

    Just for your Info, 

     

    Also, I am using a mac; I also have the black pic problem. I am storing my pics on an external hard drive, and there is a crazy workaround to fix the issue: Copying the file on an other drive is fixing the problem.

     

    0
    Comment actions Permalink
  • Avatar
    Michael Ganz

    Luminar 3 works finaly.
    the problem was the WIFI! I don't know why.
    If I switch the Laptop in flight mode or to a VPN it works and the pictures show up in the library

    0
    Comment actions Permalink
  • Avatar
    Teresa Turner-Carter

    Trying to use the trial. It is Friday night, 3 days left and I can't find the photos that were there two days ago. What is wrong and why? 
    I am seeing all the questions above and I don't want to download and keep playing games. I only had a couple folders started to see if I could edit and like. it. 
    I am really wanting to quit Lightroom and Photoshop but I want a seemless change, one that is better but not worse. 

    0
    Comment actions Permalink
  • Avatar
    Terry Rogers

    Hi Teresa! We can reset your trial for you, we'll just need some information about your computer.

    If you're on Mac:

    1. Click the Apple icon in the upper left corner of your screen.
    2. Click About This Mac.
    3. In the window that opens, click System Report.
    4. In the window that opens, make sure Hardware is selected in the column on the left.
    5. Locate the Hardware UUID string, copy it, and paste it into your reply to this email.

    If you're on Windows:

    1. Download this application: https://www.dropbox.com/s/3pf15jdigd0mgt4/ViewHID.exe.zip?dl=0 
    2. Launch it.
    3. Copy HID1 and HID2 codes from the application's window and send them to us.

    If you have any other questions or need technical help with our products, please contact us via https://skylum.com/support so we can better assist you.

    0
    Comment actions Permalink
  • Avatar
    Jonas Dorn

    The support Link which has been posted above just links to the main support page.

    I currently have the same issue, just seeing black rectangles on Windows.

    0
    Comment actions Permalink
  • Avatar
    Anastasia Davis

    Hi Jonas! That is correct, visit that page so to reach our support team. It is hard to track the issue here where we have limited options for sharing files we need from you to investigate it.

    Best regards,

    0
    Comment actions Permalink
  • Avatar
    Jonas Dorn

    Rebuilt the library, now the thumbnails appear, loading is faster than before, but still laggy with local library and remote (smb share) photos.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Jonas,

    Glad you hear you are back up and running. If any other issues arises you can reach us at www.skylum.com/support (the contact form is at the bottom of the page).

    0
    Comment actions Permalink
  • Avatar
    john taca

    Same issue here. Running a mid-level late 2018 PC that works perfectly with Adobe. Sadly, I'm already on Luminar 4. Same issue with Luminar 3 Trial copy. 

    0
    Comment actions Permalink

Please sign in to leave a comment.