Luminar 3 Unusable

Comments

127 comments

  • Avatar
    Tobias Braun

    Same for me, started it for the first time. Added my image location through the wizard. On the last page no progress was shown. Closed then Luminar and then it wont open again. Deleted then the complete catalog folder content and I could open it again. Now without the wizard in place I could add a folder over the Folder + button on the right and it seems to read in the images (I have a lot).

    Lets see when it will be ready.

    0
    Comment actions Permalink
  • Avatar
    Maurits Rietveld

    Just downloaded and installed Luminar 3 on my win10 pc,

    Luminar 2018 works fine on this machine,

    I see the splash screen for a while and then nothing!

    I did try in on my windows 10 laptop. Every thing downloaded and installed....

    Pushed - Launch -  splash screen Luminar 3 ....yaeeeey

    Then nothing.

    So just now  gave it another go on my first machine .... splash screen..... bit of activity in the cpu but then back to 5 % almost idling. 32g mem  stable at 12%,,,

    So this is not working!

    (Day later)
    Maybe run as administrator? No, the same . Briefly it shows up in background processes, then it's gone.

    ..... noticed when in list background processes behind Luminar 3 it flashes 2x : suspended

     1 hour later:

    OK,

    I switched off my Real-Time Protection (W10)

    Luminar 3 did start!

    Protection on L3 could not open the catalog.

    Protection off. L3 starts and I…

    made a new catalog on my second non-system disk.

    Protection on. L3 starts and says database initialization failed

    In Windows Defender added exclusive for the pictures folder –database failed-  no luck

    Allowed in Defender Luminar through controlled folder access no luck

    Database ini failed.

    Even now no luck with protection off.

    Maybe  the problem would be solved if the programm asked:

    Where do you want your database catalog to reside \ be?

     

     

    0
    Comment actions Permalink
  • Avatar
    Stephen Van Patten

    Similar experience as others are having. I will continue to use Luminar 2018 but have uninstalled Luminar 3 since to say it is ridiculous and does not work is the understatement of the century.

    0
    Comment actions Permalink
  • Avatar
    tim roach

    I have the problem of really slow opening of any library of over a few thousand photos. Im i5 Dell Optiplex 7010 quad core 3.2 with 8 gig of ram 512gig SSD and the Photos are on 4tb USB3 drive. I have thousands of RAW photos of offroad races I take each year and for 2018 is over 17000 photos! BUT the folder I am curently editing in is only a little over 1000. I save in a seperate folder by each race class in each event. Then the other item is thmbnails black after an edit. The photo is also black afterwards. quiting and reloading still same on same photo. When I get the chance I will check to see if my mac is doing the same thing on the same folder. Then if I click on any sub folders in the right hand pane all the thumbnails go black. If i quit the program the right pane problem is gone untill i start moving between folders again.

     

    0
    Comment actions Permalink
  • Avatar
    Wing Tam

    I thought I would use a new approach. Rather than cataloging all the images, I will catalogue folders when I need to. 

    So I went about deleting my Image folder from the catalogue. Luminar was still running after 30 minutes and then noticed that it was not responding, so had to force quit. Now Luminar 3 loads in 10 seconds. 

    Which brings me to the point of why the Skylum team thought the version of Luminar at this stage, was acceptable in terms of usability. Clearly the DAM is not ready. I just hope that you guys will bring out a fix soon.

    0
    Comment actions Permalink
  • Avatar
    Satya Raju

    I have had the same issues. Long time to load, then crashing and freezing, windows slowing down.  I thought it was something unique I was doing. I think I will wait for the update before installing.

    0
    Comment actions Permalink
  • Avatar
    Shaun Mullins

    Same problem here. Have contacted support via the Skylum website and waiting for a reply. It worked upon initial install although the initial folder population took hours. After shutting down and later attempting to start back up, it just won't open just like original poster described. My machine is Win-10, Intel I7 8750H, 16gb RAM, SSD System drive, HDD data drive, GTX 1050 4gb graphics. There are less than 25,000 total photos in my library.

    0
    Comment actions Permalink
  • Avatar
    Daniel DiBernardo

    I agree that Luminar 3 is virtually unusable.  I have a Windows 10 Machine, 4. gz, 24 Gig of Ram, NVidia 4 Gig Graphics Card, Intel Core I-7.  Takes 4-5 minutes just to load the program, then takes forever to load the libraries, and then many of my folders are simply grayed out showing nothing in them.  I cannot delete them from the list. Program is so painfully slow on all counts I cannot use it.  Luminar 2018 was much faster.

    Further, I have Aurora 2019 and Luminar 3 does not show up as a plug in, only Luminar 2018 is shown.

    0
    Comment actions Permalink
  • Avatar
    Mitch Kite

    I just wanted to mention that creating the image gallery has been running for over 12 hours and is showing only 70% complete.  I will admit that there are a lot of photos (approximately 100,000).  I'm just trying to understand how long it should be taking.  Is there a way to use Luminar 3 while the image gallery is created in the background?

    0
    Comment actions Permalink
  • Avatar
    Tom Wallach

    Guess I should have checked here before launching L3.  Just started the process and with over 100,000 photos on the external T drive I guess I'm looking at a looooong time.  Time to shut this down and let it run overnight.  Not sure how large that file is going to be but is it possible to have the Picture folder placed elsewhere if size becomes an issue?  I'd probably locate it alongside my Pictures on the external drive.

    0
    Comment actions Permalink
  • Avatar
    Mark Ellis

    Having same issue,  All I get after installing is Splash Screen with a rotating circle.  I let it run for about 10 min and couldn't exit the program.  Luminar 3 didn't even show up in Task Manager to kill the task.  Had to reboot the machine.  Tried this 3 times.

    My System is Windows 10 Pro, Rizen Thredripper 24 core CUP, 32 Gig Ram, Nvidia 1080ti Graphics card.  

    Luminar 2018 Runs just fine.

     

    0
    Comment actions Permalink
  • Avatar
    Reed Radcliffe

    I have a large number of photographs in my catalog -the majority of which are on a NAS storage device. It took the first launch of Luminar 3 almost 3 hours to get to the point where it launched to the application after creating the catalog. It would not let me activate, so I restarted the program. Then it took almost 40 minutes to launch - I was able to activate, so I did and was at odds with the amount of time it took to launch. I figure the huge amount of photos on my NAS was dragging it down, so I looked for a way to take that folder out of the catalog. I was unsuccessful in finding any settings or preferences. Can you let me know how to do this?

     

    0
    Comment actions Permalink
  • Avatar
    Barry Sachais

    Luminar 3 is unusable! On1 Raw, the 3rd piece of software along with LR and PS, run smoothly on my Win 10 OS. Luminar 3 is a disaster and Skylum should never have released it in its current state. Thumbnails take forever to show. Editing is painful to go through. Until this is fixed ON1 RAW will be my go-to program, along with LR and PS. Really, ON 1 RAW could be my only post-processing software; however, Lumenzia, a luminosity masking extension to PS (and reasonably priced) is so good that Luminar 3 will probably end up being a $ loss for me. Skylum, shame on you for releasing this software!

     

    0
    Comment actions Permalink
  • Avatar
    Ferdy Aengus

    I had the same problem, on windows it is impossible to work, 2 hours to load the photos, very slow and every passage from one folder to the other stops and the photos disappear 

    0
    Comment actions Permalink
  • Avatar
    David Ford

    Same problem here - Luminar stuck on splash screen after apparently running ok with my catalogue initially. Have reinstalled three times now and the problem persists.  Pictures folder and catalogue are on D:\Pictures (not C:). Windows Task Manager does not even show Luminar as a running application. Windows 10 latest release and patches.

    0
    Comment actions Permalink
  • Avatar
    yves bonnemaison

    i have the same problem.

    every time I run Luminar 3, the disk is 100% for several minutes making the soft unusable, it looks like it indexes the photos at each boot, of which I do not use it. Fortunately I did not uninstall luminar 2018.i'm in France

    0
    Comment actions Permalink
  • Avatar
    Fraser Thomson

    I'm having problems since I installed Luminar 3 it is useless you cannot see the picture files if you run your mouse pointer over the area you can see there is something there. The Programme takes 3 minutes to load. Computer specs  

    S p e c i f i c a t i o n s: 
    - AMD FX-6300 6-Core Black Editon, 3.5 GHz, turbo core 3.8 Ghz Max turbo core 4.1Ghz 14MB Cache Socket AM3+ "Unlocked"
     
    - Motherboard - M5A78L-M /USB3, Socket AM3+, 760G + SB710, 4 x DDR3, DVI/HDMI/D-Sub, PCI-Ex16, RAID
     
    - 4X DDR3 DIMM sockets can be upgraded to 32G RAM
     
    - Graphics - Integrated ATI Radeon™ HD 3000, Maximum memory of 1G (1024 MB)
     
    - Multi-VGA output support - HDMI/DVI/RGB ports
     
    - 8 Channel high definition audio, Optical S/PDIF out
     
    - GbLAN Ethernet, Broadband Modem ready
     
    - 8x USB Ports in total(4 USB 3.0 ports, 4 xUSB 2.0)
     
    - 32GB DDR3 1600RAM
     
    - 1TB (1000GB) high speed SATA3 6Gb/s Hard Disk
     
    - Optical - 24X Dual Layer CD/DVD Writer
     

    0
    Comment actions Permalink
  • Avatar
    Bruno Choi

    it takes nearly 5 minuets to get start everytime....(stucked at the opening logo...)
    pc: surface pro i5

    0
    Comment actions Permalink
  • Avatar
    Thomas Helzle

    I think this is what's called "Banana Software".

    Ripens at the customers... ;-)

    The grinding harddrive really gives me the creeps. It first happened for hours when the database was created (and the DB is on a separate HD from the actual images...) - not sure how much lifetime this took off the drive.

    It also happens when I open L3 (can take minutes), when I look at a different folder or otherwise change my view. It takes between several seconds and several minutes.

    And it happens - if shortly - each time I change ANY parameter in L3. It seems to do concurrent excessive writes all the time. This slows everything down a lot, is loud and definitely doesn't do any good for the drives involved.
    This surely should be buffered in RAM and written/read in a way that does not drive my HD to extinction.

    I never had any database behave like that before ever and I use several applications that use them.

    I'm back to Luminar 2018.
    This new version is somewhere between an Alpha and Beta stage at best...

    Cheers,

    Tom

    0
    Comment actions Permalink
  • Avatar
    Barry Schwartz

    Looks like the Luminar 3 was not ready to be issued to the masses.  I tried several times with different folders to be used as a catalog and it never worked.  I then opened it after deleting the catalog file as instructed on the web site.  It worked OK, but I could never figure out how to try and create a catalog again from inside the software, once it has been loaded and used.  I don't make a living off my photography, so I can tolerate these types of problems, but if you want folks who are more serious in that they have a financial stake in their processing their images, you have got to be more careful about making sure it works well before issuing it.  Once a person loses trust in the product product, it's hard for you to win their trust back. 

    0
    Comment actions Permalink
  • Avatar
    Jeffrey Hirschl

    Same problem. Upon launch Luminar 3 splash remains on screen for minutes. It is hitting the disk hard. Here's a post I made in a different thread. I've been unable to find a method of stopping the scan for images and loading into the library...

    Installed Luminar 3 and just wanted to see the landing page to look around. I was greeted by a "welcome wizard", and I could find no immediately-apparent way to dismiss this. So I went through it. It ended with Luminar 3 starting to load pictures into its library from an area that I did not want it to load from. Whenever I launch Luminar 3 again, it keeps loading, slowly BTW on a very-performant PC.

    I would have appreciated the welcome wizard presenting a summary page at the end stating what it intended to load and from where, providing me the opportunity to say "no, don't do that". Now I have to turn to manuals and/or tutorials to find out how to stop the loading and remove the photos already loaded from the library, without accidentally permanently deleting them from my disk. I expect a beginner's photo editor to "help" the user in this way; I expect a professional tool to do things when I'm ready to do them.

    When I'm ready I will load over 30,000 images, but I want to do it when I'm ready. Please fix this "welcome wizard" in the fix release in two weeks that has been promised.

    0
    Comment actions Permalink
  • Avatar
    Jeffrey Hirschl

    Sorry, Skylum. Uninstalling and going back to using Luminar 2018.

    0
    Comment actions Permalink
  • Avatar
    Don Hamilton

    I also am unable to use Luminar 3. I get the error message: DATA FILES FAILED TO INITIALIZE. I have tried uninstalling and reinstalling and always get the same result. Luminar 3 will not run.

    0
    Comment actions Permalink
  • Avatar
    Milan Vjestica

    It easily gives the impression that the software was not adequately tested. Judging by the number of people posting it is a serious issue.

    Now my inbox is getting flooded with posts. Time to unfollow and wait for support to respond.

    2018 works fine, just needed the DAM to make it a real alternative to LR. 

    Seriously thinking about alternaitves like C1 or On1.

    0
    Comment actions Permalink
  • Avatar
    Jeffrey Hirschl

    I don't need the Library functionality now. Is there a way to tell Luminar 3 to essentially operate as Luminar 2018 did? Perhaps an initialization file change or Windows Registry change? If there is, I could use Luminar 3 as I did Luminar 2018 without the library function.

    I'm on Luminar 2018 now. But if that ever needs reinstallation or installation on another machine, I'm basically out of luck. I guess I could create a dummy folder with one picture in it for Luminar 3 to "find" and then act like Luminar 2018 from there on out, but I should not have to use a workaround like that.

    Please let me know if there's a way to disable Libraries and make Luminar 3 operate like 2018.

    0
    Comment actions Permalink
  • Avatar
    Heinz Wolf

    I am on Windows 10 and had no issues with the Luminar 3 installation. On first Luminar 3 start I let it use the default Windows folder "My Pictures" which holds only ~600 copies of my originals which are located on network drives. I wanted to start small and ony on local drives as I expected issues with the new library module. It still took a long time to bring these 600 files into the Luminar library but then it turned out not even usable with such a small library. Most times it simply got stuck showing the message "Reading file structure" after Luminar start. Fortunately sometimes the startup did not get stuck ao I managed to remove the top level folder from the library again (this was also only successful after several tries).

    Now I am using Luminar 3 only for single image editing without any library function. I like the editing capabilities of Luminar but this library module is worst piece of software I have ever seen. This will damage the reputation of Luminar significantly and highly recommended not to release such untested and useless software in the future. Better fix these quality issues (plus the still horrible performance compared to Lightroom) with first priority.

    I am really pissed off.

    0
    Comment actions Permalink
  • Avatar
    Jeffrey Hirschl

    I found a further problem... I reinstalled Luminar 3 and pointed it to an empty folder, so it wouldn't try to look for anything. When I opened a single image for "Quick Editing", the scrollbar under the Luminar Looks was inoperative. It was always very thin and hard to use in even 2018, but now I'm unable to scroll through the Luminar Looks. Has anyone else seen this?

    O/S is Windows 10.

    Also I'm wondering if anyone from Luminar looks at this thread, and if not, how do I report bugs to them?

    0
    Comment actions Permalink
  • Avatar
    Nick Barber

    No joy at all with the first update for me. My previous issue was that Luminar 3, after importing all my images, doesn't go beyond the initial splash screen - I just get a spinning wheel. As per the email, instructions I uninstalled the programme and reinstalled using the previous installer which would download the latest version. Did that and tried to start Luminar 3, only to get exactly the same problem as before. Looking at Task manager (Windows 7, 16 gig of RAM, i7 processor) the memory bloating is actually worse - about 10% more usage than before the supposed fix.

    0
    Comment actions Permalink
  • Avatar
    Darryl Brooks

    Yeah, new update crashed building initial gallery same as the original.

    0
    Comment actions Permalink
  • Avatar
    Bert Schmitz

    When I installed L3 and had downloaded my 42000 images, it could not be opened anymore.  After complaining, Skylum send me an e-mail that told me to remove my images from L3 and download them as separate folders. What was crazy as I have hundreds of folders.  After the latest update all my images downloaded but it takes a long time to open a file.  Working in L3 is extremely SLOOOOW and a few times the whole program has stopped working while editing an image.  This program is not ready and uses their customers as Beta testers.  (See how much so called fixes there are in the first update, and it still does not work correct.)  I for one have enormous buyer's remorse, I had hoped that this could replace my "Lightroom 6" but even as that is slow, it is still much faster than L3 and never stops or crashes.  I don't think you will stay long in business with releasing a buggy program like this.  I think you should consider giving people for whom the program does not work there money back.  I have Windows10 with the latest update.

     

    0
    Comment actions Permalink

Please sign in to leave a comment.