Luminar 3 crashing on MacBook Pro

Comments

37 comments

  • Avatar
    David Medeiros

    I've quickly checked the forum and found several other users complaining if the exact same issues with their Macs and Luminar 3. This is obviously a bug. I'd love to hear from Skylum to know that they are seeing these reports or would like us to report some other way. Luminar 3 looks very promising but this is a significant obstacle to properly evaluating the application or doing s deep dive into setting it up permanently as my image library.

    3
    Comment actions Permalink
  • Avatar
    Denis Kotsee

    There's a bunch of critical issues that we'll fix in an update by the end of this month. Another update targeting more broad performance and stability issues is scheduled for the end of January - beginning of February. With these updates we're hoping to address most of the concerns we've been hearing over the past week.

    Let us know if the issues you reported in this thread persist after you've updated to Luminar 3.0.1 in the end of this month.

    2
    Comment actions Permalink
  • Avatar
    David Medeiros

    Official response from Skylum team on my issue is that I was scrolling my library too fast and that's causing the crash.

    Presumably Luminar can't dump the image previews in cache fast enough to keep up with my scrolling the library. This seems plausible, but there is no way I'm overtaxing the software in any un anticipated way. I have a relatively small library of 1100 images, most pros will have an order of magnitude more images than I do and will certainly expect to be able to move rapidly through the library. Still I want to give them the benefit of the doubt so I tested their advice that I slow down my scrolling and after 60 seconds of slow as I could reasonably go scrolling I still get the same crash. This is absurd. This software is beta at best and Skylum is suggesting that users are to blame (in my case at least) for their crashes. Very unhappy with how this has gone so far after high expectations from the software and the company. Holding out hope they will turn this around quickly and offer some frank apologies to their customer base. I'm a Luminar 2018 customer so I didn't pay for L3 outright and for that I'm thankful. I can't imagine having paid money for this software as it is right now.

    2
    Comment actions Permalink
  • Avatar
    David Medeiros

    No change. Stability is very fragile. This is so frustrating!

    2
    Comment actions Permalink
  • Avatar
    Nigel Turley

    I'm seeing the same behaviour (and it looks like we're not alone from other posts in the forum) - iMac Retina 5K, late 2014, 32GB RAM, Mojave 10.14.1, around 55,000 images- don't feel I can't rely on Luminar 3 for serious work at the moment...

    1
    Comment actions Permalink
  • Avatar
    Lloyd O'Daniel

    +1 on my 2015 rMBP and 10.14.2.

    1
    Comment actions Permalink
  • Avatar
    Wolfgang Jarcik

    I have the same Problem on my MacBook Pro with same configuration, crash - crash, crash, crash,...... so it is not possible for me to work with this version.

     

    1
    Comment actions Permalink
  • Avatar
    mary riley

    yup same here 6 so far in the past 2 days not including lock ups. I have the same specs as you.

    1
    Comment actions Permalink
  • Avatar
    Benno Pütz

    can't even get that far yet

     

    1
    Comment actions Permalink
  • Avatar
    David Medeiros

    Has anybody heard from Skylum on this yet? I've sent one direct message to them and have also tracked the same complaints on their Twitter and FB feeds, but so far I can't find any responses from Skylum that they are seeing these posts or collecting any crash logs etc.

    1
    Comment actions Permalink
  • Avatar
    David Medeiros

    Glad to hear there will be a patch coming soon. I was able to submit my crash info this morning. Fingers crossed that the crashes a lot of Mac users are having will be ab easy fix.

    1
    Comment actions Permalink
  • Avatar
    David Medeiros

    Update 3.0.1 installed, no change in crash behavior. Planning to uninstall and re install from scratch to be sure. As well as rename my photo folders in case there is an issue with naming conventions (I use date first then location and I know some software can't handle folder or file names with numbers up front).

    Will continue to update here but not looking great so far.

    1
    Comment actions Permalink
  • Avatar
    David Medeiros

    Is there a best practice for uninstalling L3 from a Mac? I want to make sure I get a full clean uninstall.

    1
    Comment actions Permalink
  • Avatar
    James Doyle

    Luminar 3 will not run. Uninstall, reinstall, delete, empty trash, download to a different drive, pull out hair, throw the whole damn laptop into the shredder, burn down the house...

    1
    Comment actions Permalink
  • Avatar
    Mark Hertel

    James you forgot drink heavily somewhere in that sequence......

    1
    Comment actions Permalink
  • Avatar
    David Medeiros

    @James Doyle My official L3 work around is as follows: deep uninstall via AppCleaner, re install latest version w patch, re load catalog, Launch L3, cry, throw laptop in bushes, throw rocks at bushes, set fire to bushes.

    1
    Comment actions Permalink
  • Avatar
    David Medeiros

    Wiped L3 again, reinstalled, pointed catalog to smaller image collection, simpler file structure. Same f@&king thing. L2018 has no issues on my machine. Neither do Adobe AI or PS. I also run ArcGIS with massive files and complex analysis process, and never get crashes on this computer. L3 crashes reliably after 30-60 seconds, anytime I use it (every time I use it). I've had it, looking for other options for asset management. Luminar was such a promising app. Very bummed about this not working.

    1
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi David,

    Thanks for sharing the update!

    Luminar 3 should be able to read L18 .lmnr files (https://skylum.com/luminar/user-guides/chapter-8-opening-luminar-2018-files). However, there are known issues with .lmnr files where the Save Original Resources checkbox had not been ticked when originally saving the .lmnr which we are working on.

    1
    Comment actions Permalink
  • Avatar
    Mark Hertel

    I use “AppCleaner”.  Drop and drag an application into it and it gives you back a list of all components and checkbox options to delete.  Haven’t deleted L3 with it but perhaps you could keep the catalog and replace the new one created with the new install if/when you try again.

    0
    Comment actions Permalink
  • Avatar
    David Medeiros

    Thanks Angela. I'm re installing now. FWIW, AppCleaner left behind the Luminar Catalog w cache and history. 

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hello, David. Please, accept my apologies for the temporary inconveniences. Most stability issues will be addressed in the next update 3.1.0. which is supposed to be released at the end of January-beginning of February. We'll keep you posted.

    0
    Comment actions Permalink
  • Avatar
    David Medeiros

    Fingers crossed, though I'm losing my enthusiasm at this point. Seemed like I was being told the first patch would address the core Mac issues. I really hope you guys can get this working in the next release, every time I run the app for even a few minutes I can see how much help the library will be to my workflow... then it crashes!

    0
    Comment actions Permalink
  • Avatar
    James Doyle

    Mark- I forgot to *write* drink heavily.

    0
    Comment actions Permalink
  • Avatar
    mary riley

    Ya know i JUST want to edit images.  If i right click an image to open in luminar to edit .. i should be able to darn well edit it .. but NOOOOOO i have to wait for it to freaking parse my folders.. (and yet still get the content wrong) and update all the background stuff... 

     

    I'm so sick of this... we paid for working software.  We are not beta . or worse ALPHA testers.  Fix it please.

     

    (and my fav it didnt even OPEN the image i asked it to)

     

     

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Mary,

    I'm really sorry about your experience.

    The update 3.0.2. should fix these performance issues. It will be released in about a week.

    Meanwhile, you can remove your Luminar Catalog and open your images for Quick Edit.

    Here's how to remove Luminar 3 Catalog:

    1. Make sure Luminar is closed.
    2. Locate your Luminar Catalog folder. The default location is %username%\Pictures\. If you specified a custom location for your Catalog, search your custom location.
    3. Remove the Luminar Catalog folder.

    Have a great day and please, accept my apologies for the temporary inconveniences. I hope you will take all the advantages of Luminar 3 soon.

    0
    Comment actions Permalink
  • Avatar
    James Doyle

    Hi Helena-

     

    Thanks for responding. I followed the directions above. After removing the catalog as suggested, this dialog box appears and I must make one of three choices. (1st screenshot).

    All are failures, but I was able to get to the point I was allowed to choose a single photo. I chose a random .jpg file and it froze exactly the same place as when I choosing a folder. "Opening images 0% " and that's it (2nd screenshot).

    At this point, nothing else happens until I force the program closed. I have never been able to close the program in a normal way...by choosing 'quit'.

    I hope it's useful information.

    James

    SCREENSHOT 1

     

     

     

     

    SCREENSHOT 2 

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi James,

    I'm sorry that my colleague's instructions didn't get you up and running. Please contact us at www.skylum.com/support and we'll investigate further. Please be sure to include a link to this thread in your message. Thanks in advance!

    0
    Comment actions Permalink
  • Avatar
    mary riley

    found another bug... filter doesnt work. I marked off a bunch of photos in a folder w/ ratings. filter by 3 or more .. nope nothing happens...

    Version 3.0.2 (2953)

     

    Sort by rating at least works

     

     

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Mary,

    An updated build of 3.0.2 will be released this week. Please let us know if the issue persists after running the update.

    0
    Comment actions Permalink
  • Avatar
    David Medeiros

    Updated to 3.0.2 just now. Re connected to my image catalog, briefly scrolled through image library being careful to go slowly and crashed in about 30 seconds. Nothing has changed for me since the initial release. Nothing I have done has made any difference in the applications behavior, and none of the patches or updates from Skylum has had any effect.

    I'm basically in a holding pattern waiting for access to the L3 library functions so I can start properly organizing my library, but I can't wait much longer. I absolutely hate the idea of going to Lightroom, but that's probably what I'll have to do if I can't get this resolved soon.

     

    0
    Comment actions Permalink

Please sign in to leave a comment.