Install Error "The internet connection appears to be offline"

Comments

18 comments

  • Avatar
    Angela Andrieux

    Hi Tom,

    Please also make sure you are logged in as an Administrator. You can also try this alternate installer:

    https://luminar3.s3-accelerate.amazonaws.com/win/Luminar_3_Release_1533.msi

    0
    Comment actions Permalink
  • Avatar
    Graeme Forbes

    I'm having the exact same problem - logged in as administrator and absolutely nothing.

    Latest (hotfix) update bricked Luminar 3, and now can't re-install on Windows 10 (Surface pro 6) - fine on my mac.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Graeme,

    Try reinstalling Luminar. Follow the steps below:

    Uninstall Luminar.

    How to uninstall an app on Windows 7 (click this text to open link).

    How to uninstall an app on Windows 8 (click this text to open link).

    How to uninstall an app on Windows 10 (click this text to open link).

    Clear your registry:

    • Visit https://www.ccleaner.com/ccleaner/download?pc
    • Scroll down to the bottom of the table and click Download from CCleaner.com in the first column.
    • Once the download has finished, launch the file and install CCleaner on your computer.
    • Launch CCleaner.
    • Click Registry on the left.
    • Click Scan for Issues in the lower left. Wait for the scan to finish.
    • After the scan has finished, click Fix Selected Issues in the lower right.
    • Close CCleaner.

    Reboot your PC.

    Download the latest version of Luminar from here (click this text to open link).

    Once the installer has finished downloading, locate it in your Downloads folder (or wherever you chose to save it), right-click the file, and click Run As Administrator. A prompt might appear asking you whether you wish to confirm your action, click Yes and wait for the installer to load. Then, follow the instructions on screen.

    I hope this helps.

    0
    Comment actions Permalink
  • Avatar
    Shane Williams

    HI

     

    can anyone confirm this resolved this issue?

    I had Luminar 3 all installed and running great (after the update due to its slow running speed).

    Updated a few days ago to the latest version following the update email and the program icon exe does not exist now.

    Tried to run exe from install folder and nothing.

    Tried to install again and starts at 1% install then says pc is off line.

    Removed, CCleaned etc etc as above and tried again - nothing.

    Turned off all firewalls tried again, nothing.

    Any ideas?

    Never had this much issue with Adobe :-(

    0
    Comment actions Permalink
  • Avatar
    Kirk Osborn

    Please try using this alternative installer:

    https://luminar3.s3-accelerate.amazonaws.com/win/Luminar_3_Release.msi 

    0
    Comment actions Permalink
  • Avatar
    Sudeesh Kumar

    Yes, this is an issue, still not resolved. I am not able to use luminar for last 4 months.

     

    The MSI download worked well to complete the installaiton

    0
    Comment actions Permalink
  • Avatar
    Javier Gómez

    Still the same problem. Can't install Luminar on Windows 10 PC because of an internet access error. Please, solve it or return our money

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Javier,

    Please try using the alternative installer link provided by my colleague, Kirk Osborn, above. If that doesn't work please reach out to us at www.skylum.com/support and we'll be happy to assist you further.

    0
    Comment actions Permalink
  • Avatar
    Member

    Hi.. I just download the link you send to me after I purchase the (LUMINAR 3 + 4 EARLY BIRD), I check my firewall, the installer have full access. Kirk Osborn alternative link is dead!.

    0
    Comment actions Permalink
  • Avatar
    Member

    I check your installer in Kaspersky Application Advisor, Your installer don't have the Vendor's name to authenticate and issue a certificate by my Internet Security software, I believe even I set for full access, still the Luminar installer will be block to access internet.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi - Please reach out to www.skylum.com/support and we'll be happy to look into this for you.

    0
    Comment actions Permalink
  • Avatar
    Glenn Pope

    I have this issue as well when installing 3 on a new Win 10 PC. Had no issues on older PC when last updated several months back. The only way I can get the software to install on the new PC is to use my works VPN connection. The only change I've made to my network since the old PC is switching my DNS setting to DNS over TLS. This is set in the router so setting the PC to use the VPN would get around this. Don't know if this adds any insight to the issue.

    1
    Comment actions Permalink
  • Avatar
    Safak Yavuzlar

    I have the same connection error while installing Luminar 4, I started setup as administrator...

    Can you please help me regarding to this problem?

     

    Best Regards,

    Safak Yavuzlar

    0
    Comment actions Permalink
  • Avatar
    Vita Bergman

    Hi Safak! 

    Please contact our support team https://skylum.com/support we will be happy to help.

    0
    Comment actions Permalink
  • Avatar
    Safak Yavuzlar

    I already did, thank you.

    0
    Comment actions Permalink
  • Avatar
    Jesús Montiel Maillo

    Same issue here. Already contacted support also.

    0
    Comment actions Permalink
  • Avatar
    vladarb .

    решение проблемы следующее: 

    1. Открываете сайт https://www.comss.ru/page.php?id=1984  и скачиваете и устанавливаете

    F-Secure Freedome VPN

    2. Запускаете F-Secure Freedome VPN и нажимаете большую круглую кнопку в центре окна программы, чтобы включить VPN-соединение (5 дней -бесплатно).

    3. Запускаете установленную ТРИАЛ версию Luminar 4 (полная версия не активируется), нажимаете большую кнопку "Активировать", вводите адрес электронной почты и код активации, который пришел вам на почту сразу после оплаты.

    Все. Работает 100%.

    VPN можно больше не включать и удалить с компьютера

    -1
    Comment actions Permalink
  • Avatar
    Glenn Pope

    So after further testing, found out it was the Trend Micro's AiProtection on my Asus router that was blocking the installer from connecting. Looks like it was possibly marking it as spam.

    2
    Comment actions Permalink

Please sign in to leave a comment.