Can't update Luminar 1.3.1 to 1.3.2

Comments

7 comments

  • Avatar
    Anna Veres

    Hi Allan,  NET Framework 4.7.2 is required to install the app. Please try uninstalling the Frameworks you have and download and install NET Framework 4.7.2 from the link below:

    http://go.microsoft.com/fwlink/?linkid=863265

  • Avatar
    Fernando Ariznavarreta

    It seems clear that you don't have the required .NET framework, so you have to install it from Microsoft (the runtime version not the developer version).

    You can download it from here: https://www.microsoft.com/net/download/dotnet-framework-runtime

    But it seem you have windows 7.

    As windows 7 is a deprecated system and Microsoft does not support it any more (as long as I know) I am not sure if the framework would work in it, but you can try.

    The message appears to say that you need windows 7 SP1 (Service Pack 1) installed in your system. Check first that you have SP1 installed, first.

     

    I don't recomend you to uninstall other previous versions of .NET framework, as it may affect other software that use them.

    You can have several .NET framework versions in your system, and each application would select the one it needs.

     

  • Avatar
    Allan Kingsbury

    Thank you Anna for your reply :)

    Thank you Fernando for your reply also :)

    I downloaded .NET Framework (I didn't uninstall the other Frameworks) however it seems that version 4.7.2 is not compatable with with my OS, in which I do have Windows 7 Service Pack 1 installed. Nevertheless I am planning to upgrade to windows 10 in approximately 6 weeks time which will obviously solve my problems in the future.

    Once again: Thank you both for your assistance!

  • Avatar
    Tony Collins

    According to microsoft, 4.7.2 should be OK with win 7 sp1

    https://support.microsoft.com/en-gb/help/4054530/microsoft-net-framework-4-7-2-offline-installer-for-windows

  • Avatar
    Allan Kingsbury

    Thanks for the link Tony, but for some unknown reason things are not working correctly. When I go to install 4.7.2 it asks me if I want to repair 4.7.2 or delete it. Obviously this means that 4.7.2 is installed on my PC but not enabled. I have looked at the check box that shows a tick next to version 3.5 .NET Framework and that's all I see.

    I will upgrade to Windows 10 soon, simply because Windows 7 will no longer be supported in the near future, if not now.

  • Avatar
    Fernando Ariznavarreta

    So it seems that you have a mid way installed 4.7.2 framework.

     

    You should try the option of delete it first, and then reinstall.

    Don't unistall previous versions of the framework as they may be used by other programs.

  • Avatar
    Allan Kingsbury

    Thanks Fernando, but I am not bothering about system 7 anymore. Time for me to get onto 10 with a clean install onto an SSD.

    I appreciate your time and that of others here as well :) 

Please sign in to leave a comment.