Curves filter effect disappears from photo

Comments

8 comments

  • Avatar
    Angela Andrieux

    Hi Piotr,

    We'd like to look into this issue but need some additional information from you. Please send the following information to support@skylum.com:

    Your computer specifications:

    • Press the Windows logo key + R.
    • Type msinfo32 in the dialog box that opens and hit Enter on your keyboard.
    • In the window that opens, make sure you have System Summary highlighted on the left.
    • Click File > Export.
    • Type the name of the file and save it somewhere where you can easily find it

     

    A detailed description of the process that leads to XXXError/Issue:

    A numbered list of steps would be the most convenient. For example: 

    1. Launch Luminar.
    2. Load the file named X with an extension Y.
    3. Apply Z filter.
    4. Set S slider to U value.
    5. etc. etc.

    The more detailed the description is the quicker we'll be able to figure out what might be causing the issue.

     

    Your original file(s):

    This will help us test the issue on our side. If the files are too large to email you can use WeTransfer.com and then send us the download link.

    1. Visit https://wetransfer.com/
    2. If it's your first time visiting this website, it might ask you to purchase a subscription. Simply select to proceed with the free version.
    3. Click Add your files.
    4. Select the file(s) on your computer.
    5. After you see all the files you need to send appear in the list, click the icon to the left of the Transfer button (the icon looks like a circle with three dots in it).
    6. In Send As select Link.
    7. Click Transfer.
    8. After the files have finished uploading, click Copy Link and paste it into your email.

    Thanks in advance! We look forward to receiving your email.

     

    0
    Comment actions Permalink
  • Avatar
    Piotr Derkowski

    I'm not sure if I can provide the exact steps that leads to this bug as I might not remember all of them, what is more I did this on my trial version that is now deactivated.

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Piotr,

    Since you were having trouble with the trial we'll be happy to reset it and give you another 14 days so we can figure this out.

    In order to reset your trial we need some additional info about your PC. Please download this program, unzip and launch it. 

    https://www.dropbox.com/s/xz3p1hi2ze6j50x/ViewIDE.exe?dl=0  

    Copy MID, PID and HIDE codes and send it to us in an email to support@skylum.com

    We look forward to hearing from you!

    0
    Comment actions Permalink
  • Avatar
    Piotr Derkowski

    I think I found the problem.

    Steps to reproduce:

    - load sample photo from Luminar (tested on different jpegs with same results)

    - zoom a little on the photo with mouse scroll 

    - add Curves effect and modify it (add more light)

    - drag photo with the mouse to scroll it (Curves filter stays on the photo during scrolling)

    - add new Curves filter and modify it (add shadows)

    - drag photo with the mouse to scroll it (second Curves filter disappears from photo for as long as the mouse button is held)

    - reset second Curves filter

    - change all color channels in second Curves filter (only Red, Blue and Green, not the neutral one. All RGB channels curves should be modified in the same way.)

    - drag photo with the mouse to scroll it (second Curves filter eather disappears completly from the photo and doesn't appear when the mouse button is released OR second Curves filter works half way and renders pseudo cross-processing colors)

    - modify second Curves filter (second Curves filter appears on the photo and works as expected)

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Piotr,

    Thank you for the detailed description of the steps. I'll be sure to pass them to our developers to see what is going on with this. Did you already email us with the computer info requested above?

    0
    Comment actions Permalink
  • Avatar
    Julia Kot

    Hi Piotr,

    There is the issue with cashing in Curves filter. 

    The bug report is already created. Our devs will check it soon. 

    The fix should be in the upcoming updates. 

    0
    Comment actions Permalink
  • Avatar
    David Isaac

    I am having a related problem.  I am looking to move from LightZone to Luminar to get the luminance mask.  But if I use the Curves filter to create a high-contrast (B&W) then create a luminance mask on the layer, the Curves filter is ignored and effectively reset until I touch the curves setting.  I only have one day on my trial, and this is a critical feature for me.  Please advise.  Dell Inspiron 7000, Windows 10 fully updated, Luminar fully updated (2291).  

    0
    Comment actions Permalink
  • Avatar
    Dmytro Boyko

    @ David, can you please contact us at support@skylum.com? We can reset the trial for you, so that you have another 14 days to test the software. In the meantime we'll try to troubleshoot your problem.

    0
    Comment actions Permalink

Please sign in to leave a comment.