Can't save document

Comments

34 comments

  • Avatar
    Daniel Klingler

    Hi Skylum Team,

    I'm having the exact same problem as Rob describes here. 

    Unfortunately, this issue is so bad that I can't use Luminar until it's resolved.  I must be able to save files!

    Please consider this a Severity 1 issue!

    Kind Regards,

    Dan

     

    1
    Comment actions Permalink
  • Avatar
    Denis Kotsee

    This usually occurs when you start applying filters while in the mask paint mode. We're already working on the fix.

    In the meantime, to make sure you can normally save your projects, please exit the mask paint mode (click Done) before applying any other filters.

    0
    Comment actions Permalink
  • Avatar
    John Comiez

    I'm having the identical problem.  No issues saving and opening files as long as I don't apply any filters using the brush painting mode. 

     

    Whenever I apply a filter with a brush I get a 'Can't save file' error although it does save a .lmnr file.  When I try to open the file up it opens most of the time.  All the filters are present with the correct levels, but the filters that were used with a brush don't have the brush information.  Instead, they are applied on 100% of the picture.

     

    I did try Denis' suggesting of making sure that I exit the mask paint mode before applying any other filters and it didn't work for me.  It still gave me the can't save error while saving a .lmnr file.  When opening the .lmnr file that filter that was applied using the brush was applied to the entire picture

    0
    Comment actions Permalink
  • Avatar
    Daniel Klingler

    Hi Denis,

    Thanks for your quick reply!

    I tried your suggestion (exit mask paint mode) and it did not resolve the problem for me.  Brush Masks are still not saved.

    FYI, there doesn't seem to be any issue when using Gradient, Radial or Luminosity masks.

    I look forward to the fix!  Until it's available, I'm forced to downgrade to Version 1.2, unless you have an alternate suggestion.  That makes me sad.

    0
    Comment actions Permalink
  • Avatar
    Susan Wiethorn

    Denis Kotsee,

    I recommend you make the older release available until Luminar stable again.

    Not able to save and open files is a critical path operation of any software tool.

     

    0
    Comment actions Permalink
  • Avatar
    Denis Kotsee

    Give me a few hours, I'll come back with a link soon.

    0
    Comment actions Permalink
  • Avatar
    Denis Kotsee

    Also, to anyone who tried the solution I posted above, and it didn't help - could you please send us a screen recording of your workflow, beginning with launching Luminar, and ending in the error?

    You can record you screen with OBS Studio: https://obsproject.com/download

    Here's how to use it: https://obsproject.com/wiki/OBS-Studio-Quickstart

    Upload a recording and post a link to it here:

     

    1. Visit https://wetransfer.com/
    2. If it's your first time visiting this website, it might ask you to purchase a subscription. Simply select to proceed with the free version.
    3. Click Add your files.
    4. Select the file(s) on your computer.
    5. After you see all the files you need to send appear in the list, click the icon to the left of the Transfer button (the icon looks like a circle with three dots in it).
    6. In Send As select Link.
    7. Click Transfer.
    8. After the files have finished uploading, click Copy Link and paste it into the reply to this email.

    We just want to make sure that this is one bug, and not two that look the same on the surface.

     

    1
    Comment actions Permalink
  • Avatar
    Daniel Klingler

    Hi Denis,

    In real life, I'm a QA tester, and fully defining this bug has eluded me - but I believe I've got my hands around it now.  Someone over there in Skylum land owes me a beer if I got this right.  :)

    Definition of the bug: Upon saving the luminar file (.lmnr) the user sees an error box "Can't save document" (as shown in Rob's original post).  A luminar file is actually saved, but any masks associated with a layer are not saved.

    There are 2 scenarios where the bug manifests itself:

    1. User creates a new layer, adds a mask to that layer, and saves the file without first hitting the "Done" button in Layer Mask Mode.  (You suggested this as a bug scenario above.  Nothing new here.)
    2. Below is scenario #2 (which is probably just a permutation of #1)
    • User creates a new layer A
    • User adds a mask to layer A
    • (Without hitting the "Done" button)
    • User creates a new layer B
    • User adds a filter set to layer B
    • (At this point, the Layer Mask Mode for layer A "goes away")
    • Any attempt to save the file after this point will manifest the bug.

    In a post above I said that I only saw the bug when using the brush mask tool.  I was incorrect.  I was able to manifest the bug when using the brush, radial mask and gradient mask in the two scenarios above.  (I didn't try a luminosity mask.)  So I now believe that the mask type is not relevant.

    That's it.  Those were the only two scenarios where I could get this bug to manifest.  Everything else perfomred as expected.

    I hope this is helpful, and I hope we can get a fix soon.  In the meantime, anyone reading this post - Remember to hit the "Done" button before saving your file or creating a new layer!!

    Regards,
    Dan

    1
    Comment actions Permalink
  • Avatar
    Rob Morice

    @Dan,

    Nice work on summarising the issue.    

    Regards

    Rob

    0
    Comment actions Permalink
  • Avatar
    Rob Morice

    I'm finding that it is best to save every time you do a mask. This way if you forget to press 'Done' or get lost, especially with painting in Dodge and Burn, at least you know what was the last step you did.  I just call up the file again if it has issues saving and redo the mask and press 'Done' and save again.  I notice whilst in the masking you can not turn on/off the filter to look at the results as you need to press 'Done' first.  Then you can.

     

    1
    Comment actions Permalink
  • Avatar
    Susan Wiethorn

    Nice Job  @Dan,

    I'm not a tester, I write the use-cases and requirements, so I appreciate the dedication the testers have.

    I will buy you a couple of beers :)

    -S

    0
    Comment actions Permalink
  • Avatar
    Susan Wiethorn

    Oh, Dan,

    if you have the energy, here is another use-case that I think is related to this case.

    https://community.skylum.com/hc/en-us/community/posts/360016606452-Corrupted-lmnr-file-after-update?page=1#community_comment_360001687272

    near the bottom of the thread, I think the key is using the Crop tool.

    I too did a crop (https://www.instagram.com/p/BlOAjwohdKj/)

    and then tried to save the file. That's when the errors started occurring.

    -Susan

     

    0
    Comment actions Permalink
  • Avatar
    Dave O'Connor

    Same problem for me. Done tool does not work. Did 2nd layer, hit done, tried Control S and immediately received the same Documents can't be saved.

    Dave

    0
    Comment actions Permalink
  • Avatar
    Denis Kotsee

    We're going to release a hotfix for this issue very soon.

    1
    Comment actions Permalink
  • Avatar
    Javed Jeetoo

    I am having the same issue which I reported to the support desk. I was told that they will release a hotfix in a few days. I just hope that this comes by end of this week. I have hundreds of photos to edit and the only alternative would unfortunately look for a Luminar alternative :(

    0
    Comment actions Permalink
  • Avatar
    Daniel Klingler

    Hey Javed,

    In one of my posts above, I've outlined the steps that cause this error.  In short - never leave mask mode without hitting the Done button.  That's the current workaround.

    If you forget, you can still save a file that will include the filters for each layer, but the masks will be missing.  Quit Luminar, open your saved *.lmnr file again and you can re-create the masks and then save the file successfully (but don't forget the Done button!).  Rob mentioned this in a post above.

    Yeah, this is a huge pain, but with some dilligence, you can work around it.

    Hope this helps!

    0
    Comment actions Permalink
  • Avatar
    Daniel Klingler

    Hey Denis Kotsee,

    Can we get an update on the promised fix?  Not looking for a committment here, but your current outlook would be helpful.

    -Dan

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Daniel - No promises, but we are anticipating releasing it sometime this week.

    0
    Comment actions Permalink
  • Avatar
    Susan Wiethorn

    Hi Daniel,

    I clicked 'Done' on a filter mask, and then went and applied a new layer and applied a new filter/slider, and I still got the error.

    -S

    0
    Comment actions Permalink
  • Avatar
    Razvan Stancu

    Same issue here. I already reported to support, but silence after my response. In my case an easy way to reproduce it is applying a preset, then create new adjustment layer and a filter (advanced contrast, no masks), then add another adjustment layer, add exposure filter with or without a radial mask, then boom! I also had multiple other cases, especially involving layers, cloning and crop. If lmnr files cannot be saved, the software is for my workflow, useless.

    Video Link : https://youtu.be/SkqcwpMXLbA

    1
    Comment actions Permalink
  • Avatar
    dankron01 .

    Same issue here, seems like Skylum wasnt the best choice for a professional work after all :(

    2
    Comment actions Permalink
  • Avatar
    Rob Morice

    Nice work Skylum team.  I've just downloaded the latest version (1.3.1.2291)  and the bug with the masking and saving appears to have been resolved.    

    I've tested it out on the steps I know that would cause the error and now I can successfully save the file and call it back up with all the masks intact.

    Now I can get back to loving the software again.

     

     

     

     

    1
    Comment actions Permalink
  • Avatar
    Javed Jeetoo

    Daniel - thanks for the tips. Meantime the Skylum Team has released the hotfix :)

    @Skylum Team: Wonderful support ! The bug(s) are gone and I am now able to save my files. Thanks a ton !!

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    @Javed - Thank you!! Glad to hear you are back up and running. :)

    0
    Comment actions Permalink
  • Avatar
    Michal R

    Hi,

    after an update Luminar 2018 to Version 1.3.1.2291 I have the same problem with saving project. Every time after click to SAVE buton I see the message Can´t save document. I have WIN 10, please how can I repair it.

    Thank you a lot

    Michal

    0
    Comment actions Permalink
  • Avatar
    Angela Andrieux

    Hi Michal,

    Were you having this issue prior to installing the 1.3.1 update?

    In order to look into this further we need some additional info about your PC. Please send the following to support@skylum.com:

    • Press the Windows logo key + R.
    • Type msinfo32 in the dialog box that opens and hit Enter on your keyboard.
    • In the window that opens, make sure you have System Summary highlighted on the left.
    • Click File > Export.
    • Type the name of the file and save it somewhere where you can easily find it

    Thanks in advance!

    0
    Comment actions Permalink
  • Avatar
    Jacques Van Der Westhuizen

    I am in the market for new photo editing software as I have been using Capture NX 2 for a long time. I have downloaded Luminar 2018, Version 1.3.1.2291 and is currently only using the trial version as I want to try before I buy.

    I can export an image in JPEG after I have made the necessary changes, but when I save, I get the error "Can't Save Document". And there is NO .lmnr file anywhere!

    I have looked at all the steps above, clicked on Done when finished with a mask edit (brush), but still receive the error.

    I am using Windows 10. Short workflow: 1. Open image, 2. Do some RAW editing, 3. New layer, 4. Used brush to mask eyes, 5. Clicked Done. 6. Tried to save but received error.

    If I cannot save, then I cannot purchase the software.

    Thanks in advance

    0
    Comment actions Permalink
  • Avatar
    Denis Kotsee

    @Jacques Van Der Westhuizen if you have an antivirus, try adding Luminar to the list of exclusions, and try saving or exporting one more time.

    0
    Comment actions Permalink
  • Avatar
    Jacques Van Der Westhuizen

    Thanks Denise, but I tried adding Luminar to the exclusion list, but I still received the same error.

    0
    Comment actions Permalink

Please sign in to leave a comment.