MAC OS Update Breaks Luminar 4 Catalog Again

Answered

Comments

6 comments

  • Avatar
    Kate Williams

    Hi Jeremy,

    I'm very sorry for this inconvenience. 

    The issue you've faced is a known one. Our team is currently investigating it and checking how it can be fixed. 

    While we're looking for a solution, here's what you can try:

    1) The following workaround that helped one of our artists:

    - Add Luminar 4 to have "Full Disk Access" in System Preferences.
    - Open Luminar 4 , then close it.
    - Remove the "Full Disk Access" permission in System Preferences.
    - Open Luminar 4 again

     

    - Working with a new catalog. You can create a new catalog via File > Catalog > New.

    (In case you need to finish important edits in the previous catalog, you can revisit it by clicking File > Catalog > Open (recent). 

    I do understand that this isn't an ideal solution at all and how frustrating it is to start from scratch. However, for now, this solution is the most efficient one. We hope to ship the fix as soon as it is ready in order to get this issue permanently resolved. 

     

    0
    Comment actions Permalink
  • Avatar
    Jeremy Soto

    Hello Kate, 

    I tried step 1. This fixes the duplicating issue with new photos from what I've seen so far. However all the duplicates that were created before the fix that are in Luminar's trash can't be removed because of the error stating that the file doesn't exist (211 new photos became 2200 duplicates)

    Is there a way to manually purge Luminar's Trash? "Empty Trash" within the program doesn't work.

    0
    Comment actions Permalink
  • Avatar
    Tony Collins

    I think it was the fourth time I lost a catalogue (going back a couple of years now) that I gave up on Luminar. I check back in the forums every few months to see if catalogue reliability has been fixed.

    Sadly - it seems it still hasn't. A catalogue system is completely unusable if it can't be relied upon to keep my edits secure *forever* (I can still access my edited files in Lightroom at least 19 years after I first started using it, and that, even though I no longer subscribe).

    I still use L4 occasionally for individual edits, but that is rare. Perhaps one day I can come back. Though it is not looking hopeful.

    0
    Comment actions Permalink
  • Avatar
    Thomas Gass

    Howwowow - this "problem" still persists in Luminar AI with BigSur 11.4 M1
    I just thought to give it a try if its a L4 and previous versions are mentioned here.

    Guess my 7 day trail, will not be very successful. :( already a rough start.

    0
    Comment actions Permalink
  • Avatar
    CSCOM

    I also created a new catalog and put a lot of work in it to recreate my edits. Now after just a week the problem is the same! Creating a new catalog is a waste of time and will NOT solve the issue! So please don't recommend it constantly for months and months without fixing the bug! When can we expect an update?

    0
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hello!

    Our tech department is currently investigating what is possibly causing the issue.

    We will do our best to provide a solution as soon as possible!

    Your patience on this matter is greatly appreciated!

    0
    Comment actions Permalink

Please sign in to leave a comment.