Luminar 4.3.3 not working in Photoshop

Answered

Comments

9 comments

  • Avatar
    Anastasia Davis

    Hi Michael!

    Our technical department is investigating this issue at the moment. Could you reach our support team with more details? Write an email to support@skylum.com

    0
    Comment actions Permalink
  • Avatar
    Lance Lenoir

    Every time I try and run the plugin I get a layer that is either solid black or it looks like black and white noise.

    Running the latest version of Luminar and Photoshop 22.4.1

     

     

     

    0
    Comment actions Permalink
  • Avatar
    Erwin Chung

    I am also experiencing the same issue.

    I'm running Luminar 4.3.3 (8840), Photoshop 22.4.1, Catalina 10.15.7.

    Funny thing is that my DXO Nik Collection plugins do not work as well when I bring up the plugins using the same 'old' way, i.e. when in PS, clicking on the Filter / Skylum Software / Luminar 4. When I finish editing in Luminar 4 plugin (or Nik Collection plugin), the changes are not applied when going back to PS.

    You can refer to this post from DXO's forum: https://feedback.dxo.com/t/nik-collection-3-3-not-working-with-photoshop-cc-2021/17003/9

    Fortunately for Nik Collection plugins, there is another way of invoking the plugins, by File / Automate / Nik Selective Tool 2. Using this method for Nik Collection, it works again. However, I am not aware of any other way of invoking the Luminar 4 Plugin within Photoshop. My current remedy is to save the PS file back into Lightroom and then invoking the Luminar 4 Plugin from there. Please provide a fix for all of us soon, Skylum!

    0
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hello Erwin,

    Could you please specify if this issue has started after the latest macOS Catalina security update?

    0
    Comment actions Permalink
  • Avatar
    Erwin Chung

    Austin Miller, I am not sure what updates I did caused this problem. I last used my Intel iMac 27" 2020 back in early January 2021, and I had to go abroad for 4 months. When I came back two weeks ago, I had a bunch of updates that I needed to perform, including Luminar 4, Photoshop, Catalina, Lightroom. So I'm not sure what's the culprit here. Please let me know if I can be of more assistance at any time.

    0
    Comment actions Permalink
  • Avatar
    Alina Skylum

    Hello Erwin,

    I believe that the problem you mentioned did appear after the latest Catalina security update. That one caused the issues with plugins unfortunately. This has been already reported to the team and our colleagues are currently investigating that issue. Meanwhile I would kindly ask you to contact us here https://skylum.com/support, so that we can figure out what can be done to improve the current situation. Thank you!

    0
    Comment actions Permalink
  • Avatar
    Erwin Chung

    Alina Skylum This is comforting to know you guys are on top of it! Thank you!! Will follow up with support team

    0
    Comment actions Permalink
  • Avatar
    Cecilia Clark

    I have the same issue with the Luminar 4 adjusted image returning as a black layer in PS. It probably began after my OS update to Catalina. Luminar 4.3.3, PS 22.4.3, Catalina 10.15.7

    In PS/Filter/Skylum/Luminar 4:can make adjustments in Luminar but image comes back as a black layer.In LR/Photo/Edit In/Luminar 4: works

    Is there a fix for the Luminar issue when using PS?

    0
    Comment actions Permalink
  • Avatar
    Margaret Bright

    Hi Cecilia,

    We've discovered that the issue you encountered connected with the last Catalina update which introduces new security settings. At the moment our technical department is investigating the issue.

    Are you able to update your OS to Big Sur? It should resolve the issue you're facing.

    0
    Comment actions Permalink

Please sign in to leave a comment.