Luminar AI PS plugin - stopped working

Answered

Comments

20 comments

  • Avatar
    Katherine Nelson

    Hi Greg! Please let us know what version of Photoshop you're using. Does it happen with all images? You can reach our support team and we will do our best to help you: https://skylum.com/support 

    0
    Comment actions Permalink
  • Avatar
    Grzegorz Bukowski

    Thanks, Katherine. I've reached out to the support team accordingly.

    Greg

    0
    Comment actions Permalink
  • Avatar
    Grzegorz Bukowski

    Hi,

    Following the solution provided by Skylum I was able to fix this problem. I'm not relying on the catalog feature of Luminar, so I was not impacted by the necessity to delete my catalog being part of the solution proposed. Others, who may use cataloging, might be potentially bothered by this.

    Greg

    0
    Comment actions Permalink
  • Avatar
    Marcin Piontek

    Hi Katherine,

    I've got the same problem. I've contacted you via https://skylum.com/support  but haven't got any confirmation mail, therefore I am not sure whether my request was sent and delivered or not. Luminar AI as a plugin (both for Lr and Ps) looks like that: 
    Both Templates and Edit are blank. Please help.
    Kind regards

    Marcin 

    0
    Comment actions Permalink
  • Avatar
    Victoria Grace

    Hi Marcin, 

    This is a known issue we're currently working on a fix. Thanks for all your patience.

    Also, we've located your request and will get back to you asap.

    0
    Comment actions Permalink
  • Avatar
    C Holt

    Same problem here. Worked fine in photosop on old laptop. Trying to install in photoshop on new laptop and have no edit or template panel after purchasing another seat for the new laptop. 

     

    0
    Comment actions Permalink
  • Avatar
    Member

    I too am having this issue. I see that this is a known issue, and that Skylum is working on a fix. What I want to know, but do not see here, is what I need to do as a work-around ot temporary "fix.". The OP stated that they were able to get it working for them, with the help of support, but does not seem to have shared the information in this thread. Does everyone need to go through support for the information?
    Edit: I also do not use LuminarAI cataloging features

    0
    Comment actions Permalink
  • Avatar
    Margaret Bright

    Hi,

    Please kindly try the following solution:

    • Close Luminarᴬᴵ, LR, and PS apps.
    • Please, rename the CommonSettingsPlugin.xml into CommonSettingsPlugin_old.xml. - https://prnt.sc/10tgq4p 
    • Copy the CommonSettings.xml file and rename this copied file to CommonSettingsPlugin.xml https://prnt.sc/10tgqi3
    • Try to use Luminarᴬᴵ as a plugin now.
    0
    Comment actions Permalink
  • Avatar
    Member

    Ok, so I started my PC and went to:
    - C:/Users/*username*/AppData/Roaming/Luminar AI
    - I renamed "CommonSettingsPlugin.xml" to "CommonSettingsPlugin_old.xml"
    - Next I copied "CommonSettings.xml" to the Desktop, and renamed it to "CommonSettingsPlugin.xml"
    - Finally, I moved that copied file back into the folder.
    After trying to open Luminar AI from both Lightroom and Photoshop, nothing appears to have changed. Still the blank interface. Did I do something incorrectly?

    0
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi Member,

    Everything seems to be done correctly; perhaps, in step 3, I'd skip copying to the Desktop and create a copy directly in the "Luminar AI" folder. However, this shouldn't affect the results.

    Could you please confirm that Luminar AI and Photoshop were closed while you were following these steps?
    If not, you may want to delete both CommonSettings...files, then launch Luminar in the standalone mode, then as a plugin, close both apps and try renaming the files again. 

    If the issue persists, delete the "Common Settings..files" again, and roll back to the previous Luminar AI build: https://downloads.skylum.com/luminarai/win/1.0.1/Win_Luminar_AI_1_0_1_Release_7521.zip

     You'll get a .zip folder with a pre-installed copy of Luminar. Extract the folder from the .zip. 

    Check out this page if you need help extracting the file:

    https://support.microsoft.com/en-us/help/14200/windows-compress-uncompress-zip-files

    After you've successfully extracted the folder, open it, locate LuminarAI.exe, right-click it and click Run As Administrator.

    When the 1.3.0 update ships, you'll be notified via an email and an in-app notification. 

    0
    Comment actions Permalink
  • Avatar
    Member

    Ok. About to try this new approach. And yes, I can confirm that nothing had been opened at the time I followed the steps. I had just restarted the PC. Thank you

    0
    Comment actions Permalink
  • Avatar
    Member

    Ok, so I just tried your most recent suggestion, and deleted all of the "CommonSettings" and "CommonSettingsPlugin" files. Next, I opened up Luminar AI stand alone program, then as plugins in Lightroom and Photoshop, respectively. Just doing that seems to have remedied the situation. Opening the plugin from both Adobe apps now shows the full Luminar interface as it should. It appears there was no need to go through the deleting and renaming this time. Thank you for your assistance!

    0
    Comment actions Permalink
  • Avatar
    Elena Blum

    Member,

    Great to hear it works!

    0
    Comment actions Permalink
  • Avatar
    Adrien McGuire

    This problem has happened to me now and as I am no computer expert I cannot follow the instructions as laid out above and cannot find the common settings as mentioned, 
    Does anyone have a step by step solution , from the very beginning to the end ,that can be followed by a dummy ? 

    If it is a known problem , then why hasn't Skylum issued a patch to fix it  ? 

    0
    Comment actions Permalink
  • Avatar
    Katherine Nelson

    Hi Adrien McGuire,

    Please note that the issue was fixed in the latest update. Please check if you are running the latest version: Open Luminar AI> in the Top Menu Bar, choose LuminarAI > Help > Check for Updates

    1
    Comment actions Permalink
  • Avatar
    Adrien McGuire

                        Katherine Nelson     
    Hi katherine , I did check the update and it tells me I am running the latest version (1.3.0 (8125). 

    I have since deleted/uninstalled Ai and downloaded it again but it is still doing the same thing. 
    What next ?       
    Very frustrating but your assistance is appreciated

    Thanks  

    0
    Comment actions Permalink
  • Avatar
    Helga Rowles

    Hi Adrien,

    Thanks for your reply.
    Could you please try the following steps?

    1. Make sure LuminarAI is closed.
    2. Press the Windows logo key+R.
    3. In the box that opens, paste %appdata%\Luminar AI
    4. Locate the file Common Settings.xml > right-click it > Open with > Notepad. 
    5. Find the string <RightPanelVisibility>false</RightPanelVisibility> and replace the word 'false' with true
      It should look like this:
    6. Save the file. Launch LuminarAI and check how it works for you.

    Here's the video tutorial that can also be helpful: https://www.loom.com/share/39d43ee14bd64b6f8f0a5d0c6d7e98b4

    I really hope it helps. 

    0
    Comment actions Permalink
  • Avatar
    Adrien McGuire

    @HelgaRowles

    Helga,

    Yay, It now seems to be working again. 

    Thank you for your kind assistance

    0
    Comment actions Permalink
  • Avatar
    william tyre jr

    YES thank god i found this been driving me crazy.....the true to false

    thing worked

    0
    Comment actions Permalink
  • Avatar
    Luis Perez

    Hi, had the same problem going from Aurora to luminar AI and back to Aurora using the plugin option. No mention of the LeftPanelvisibity, but I had to changed the false to true on both the RightPanevisibility and LeftPanevisibity line as they both read false. It works. Don't know if I will try the Aurora to Luminar AI plugin again. Lost too much time just to get AI working again.

    0
    Comment actions Permalink

Please sign in to leave a comment.