Discover the new Luminar 4.3.3 update!

Pinned

Comments

23 comments

  • Avatar
    Member

    I have update the software 4.3.3... However it still do not support the CR3 file from my Canon R3... What give?????? The update notes say it support but it does not... the file still look funny and color all went crazy

    0
    Comment actions Permalink
  • Avatar
    Elena O'Brien

    Hi,

    I am truly sorry to hear that you are facing issues with the latest update!

    Please reach out to us at http://skylum.com/support and we'll get that sorted out for you ASAP.

    0
    Comment actions Permalink
  • Avatar
    Member

    Is it possible to get an offline installer for 4.3.3, please?

    Does version 4.3.3 now run natively on Apple Silicon?

    1
    Comment actions Permalink
  • Avatar
    Member

    > Does version 4.3.3 now run natively on Apple Silicon?

    Sadly not yet.

    Running Luminar with Rosetta 2 works, yet allocates huge amounts of RAM which makes it perform poorly.

    0
    Comment actions Permalink
  • Avatar
    Xavier Merut

    Since the last update I don t have the red dot anymore for the edited photos
    I have to select manualy each one to export them
    Is that a problem customers already report to you?
    Yours cincerly

    0
    Comment actions Permalink
  • Avatar
    Victoria Grace

    Hi Xavier Merut

    Could you please reach our support team via https://skylum.com/support so that our techs could better assist you?

    0
    Comment actions Permalink
  • Avatar
    Alain DUCHESNE

    Hello,

    Please, where can I find the Luminar 4.3.3 offline installer

    Thank you

    0
    Comment actions Permalink
  • Avatar
    Helga Hufflepuff

    Hi Alain,

    You can use the following link to download Luminar 4.3.3 offline installer: 

    https://downloads.skylum.com/luminar4/win/Luminar4Setup_offline.msi 

    0
    Comment actions Permalink
  • Avatar
    Henri Nagelhout

    Will we see iPhone 12 / Apple ProRAW support?

    0
    Comment actions Permalink
  • Avatar
    Agatha Winter

    Hi Henri,

    There is no ETA for Apple proRAW support for now, however, it's in our plans already.

    -1
    Comment actions Permalink
  • Avatar
    Humberto Coga

    when I use the luminary as a plugin in photoshop I save the photo it comes as a black layer

    0
    Comment actions Permalink
  • Avatar
    Agatha Winter

    Hi Humberto,

    Could you please let us know your hardware configuration? Click on Apple logo in the upper left corner of your screen, click About This Mac, and make a screenshot of the window that opens. Check out this article (click this text to open link) about making screenshots on Mac if you need help with that. Attach the screenshot to your request via https://skylum.com/support

    Here is the video tutorial on how to retrieve your system infohttps://www.loom.com/share/4542009fcdb74570832982215caec9a1  

     

    0
    Comment actions Permalink
  • Avatar
    Lance Lenoir

    Currently running Mac OS 10.15.7 and Luminar 4.3.3 and I'm getting a black layer whenever I export from the photoshop plugin. Images are located on a Rocket XTMO 4TB Thunderbolt 3 external drive.

    Screenshot of system below. 

    1
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Lance,

    Could you please reach our support team via https://skylum.com/support so we could look deeper into this?

    0
    Comment actions Permalink
  • Avatar
    Tero H

    FYI a couple of bugs I encountered after upgrading to 4.3.3.

    First, my Mac (latest Big Sur) froze completely with the very first touch to the image, adjusting its saturation. The Mac dropped the external drive and all the Bluetooth stuff. Only hard power off helped me to get out of the situation. This was exceptional behavior, haven't seen this for a long time (haven't been using Luminar for a year or so).

    After powering the thing up, non of Luminar's image adjustments worked, they did not have any effect on the image. The looks worked, however. Then I applied the erase function, which also worked, and after that all the image adjustments started to work. There were no layers in the image which could explain this behavior.

    0
    Comment actions Permalink
  • Avatar
    Austin Miller

    Hello Tero,

    We need to be able to reproduce the issue on our end in order to understand at which point it occurs. Please send us a screen recording of what you do in the software before encountering the issue. Here's how to record a screen on Mac:

    https://support.apple.com/guide/quicktime-player/record-your-screen-qtp97b08e666/mac

    Here's how you can send us the file:

    1. Visit https://wetransfer.com/
    2. If it's your first time visiting this website, it might ask you to purchase a subscription. Simply select to proceed with the free version.
    3. Click Add your files.
    4. Select the file(s) on your computer.
    5. After you see all the files you need to send appear in the list, click the icon to the left of the Transfer button (the icon looks like a circle with three dots in it).
    6. In Send As select Link.
    7. Click Transfer.
    8. After the files have finished uploading, click Copy Link and paste it into your support request at https://skylum.com/support 

    Looking forward to hearing back from you. 

    0
    Comment actions Permalink
  • Avatar
    Al Shinogle

    It finally works!!!! after months of issues with OS updates trashing all the links and photo updates....I have been thru two OS updates and the photos (edits and links) are intact.

    My faith in the product is back to 100%. 

    Way to go team.....awesome

    0
    Comment actions Permalink
  • Avatar
    Markus Zuber

    Good for you. Still does not work here - and on other Macs running 10.15.7.

    We have checke all Photoshop updates but no improvement so far. Come on guys: this is not a good customer service and if we would have to use Luminar AI, we would probably quit! 

    0
    Comment actions Permalink
  • Avatar
    Elena O'Brien

    Hi Markus Zuber,

    So sorry to hear that you are still facing issues with Luminar!

    Please email us at support@skylum.com and we'll be happy to assist you.

    0
    Comment actions Permalink
  • Avatar
    Markus Zuber

    Hi Elena

    I have done so more than once - and already months ago - and nothing happened.

    0
    Comment actions Permalink
  • Avatar
    Elena O'Brien

    Hi Markus Zuber,

    I can see that you have encountered a known issue.

    We will make sure to keep you updated on the progress.

    0
    Comment actions Permalink
  • Avatar
    Tricia Hayden Burns

    I am getting the same black screen as everyone else. Running Catalina, using 8 bit images, it's not the graphics card. Please advise.

     

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Tricia,

    In this case, please, reach us via skylum.com/support so we could help you with this.

    0
    Comment actions Permalink

Please sign in to leave a comment.