Luminar AI ... So slow!!!

Answered

Comments

12 comments

  • Avatar
    Elena Blum

    Hi Cuong Cao,

    Please contact our support team https://skylum.com/support and we will do our best to take a closer look at what’s going on right away.

    0
    Comment actions Permalink
  • Avatar
    Member

    Hi Cuong Cao, we have with our iMac the same Problems. I‘ve contacted the Support, but no answer yet. I‘ve seen a video and another guy has the same problem with the new MacBook air M1. So I guess Skylum has to confirm an update as soon as possible.

    0
    Comment actions Permalink
  • Avatar
    Black Eyes

    Luminar AI offers interesting features, it makes pictures easier ... but unfortunately it is really painful slowly. Each operation cannot be in "real-time", mostly there is a delay 5-15 seconds between the operation and the result.

    I hope Skylum's team can solve this problem quickly. It's really pity that support is very slow ... or almost absent.

    2
    Comment actions Permalink
  • Avatar
    Black Eyes

    Support team recommends to perform a PRAM Reset (https://support.apple.com/en-us/HT204063) ... unfortunately I do not notice any speed improvement.

    Any others more efficient solutions?

    0
    Comment actions Permalink
  • Avatar
    Black Eyes

    Skylum support team have just answered that if PRAM reset doesn't help, then there is no other solution to solve the problem of slowness. We must wait for the update.

    I am wondering how a software with such slowness can be released !!!

    0
    Comment actions Permalink
  • Avatar
    Black Eyes

    I have noticed when using Templates of Luminar AI, the sped is ok. When using 3rd-party templates, then the speed drop dramatically!

    Personally I don't like very much most of templates in Luminar AI.

    0
    Comment actions Permalink
  • Avatar
    Elena Blum

    Hi Black Eyes,

    Which exactly Templates do you mean? Could you send us some of them at https://skylum.com/support ?

    0
    Comment actions Permalink
  • Avatar
    Roberto Ferreira

    I have an IMAC 2017

    With Big Sur, the LUMINAR took me a few seconds to open (about 3 or 5). For certain reasons I have returned to mojave, restoring Backup from time machine and now LUMINAR takes between 15/20 seconds to open.

    I have tried to uninstall Luminar and reinstall it but it still takes a long time (It takes longer than when I had HD instead of SSD that I have now)

    Do you know how I can fix it?

     

    Do not tell me to contact support, since they always answer the same thing:

    That they are very busy and will take as little time as possible, but the answer never comes

    0
    Comment actions Permalink
  • Avatar
    Victoria Grace

    Hi Roberto,

    Our support agent will email with the solution asap. Please, check your inbox (the Spam and Social folders as well).

    0
    Comment actions Permalink
  • Avatar
    Member

    @Roberto Ferreira, I have a 2017 IMac with 32Gb RAM and Big Sur also. This Luminar AI takes so long that I'm ready to ask for a refund. It takes forever for me to adjust one item and see the result, how can you edit if it takes so long just to see what each affect does??? You don't. I hope the update is soon and fixes this problem. I can run 4k videos on Final Cut Pro with NO lag or slowness and this simple photo app is so frustrating...

    0
    Comment actions Permalink
  • Avatar
    Member

    Great, now it keeps closing unexpectedly and giving me this message:

     

    Process:               Luminar AI [4080]
    Path:                  /Applications/Luminar AI.app/Contents/MacOS/Luminar AI
    Identifier:            com.skylum.luminarAI
    Version:               1.2.0 (8884)
    Code Type:             X86-64 (Native)
     
    Please help Skylum...
    Parent Process:        ??? [1]
    Responsible:           Luminar AI [4080]
    User ID:               501
     
    Date/Time:             2021-04-14 18:34:30.435 -0600
    OS Version:            macOS 11.2.3 (20D91)
    Report Version:        12
    Anonymous UUID:        90C956BD-B9C2-B6FF-A778-1D531ACF5DAA
     
    Sleep/Wake UUID:       2CD41D5E-B63B-4DB3-A9ED-4E1D5B9E7A16
     
    Time Awake Since Boot: 22000 seconds
    Time Since Wake:       2500 seconds
     
    System Integrity Protection: enabled
     
    Crashed Thread:        0  Dispatch queue: com.apple.main-thread
     
    Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000500002d8a
    Exception Note:        EXC_CORPSE_NOTIFY
     
    Termination Signal:    Segmentation fault: 11
    Termination Reason:    Namespace SIGNAL, Code 0xb
    Terminating Process:   exc handler [4080]
     
    VM Regions Near 0x500002d8a:
        CoreData Object IDs         124d2e000-124d2f000    [    4K] ---/rwx SM=NUL  
    --> 
        MALLOC_NANO              600000000000-600008000000 [128.0M] rw-/rwx SM=PRV  
     
    Application Specific Information:
    abort() called
     
    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0   io.sentry.Sentry               0x000000010985a773 containsValidROData + 102
    1   io.sentry.Sentry               0x000000010985ae62 isValidClass + 70
    2   io.sentry.Sentry               0x000000010985addd isValidObject + 165
    3   io.sentry.Sentry               0x000000010985abc7 sentrycrashobjc_objectType + 56
    4   io.sentry.Sentry               0x000000010981e1cb writeMemoryContentsIfNotable + 115
    0
    Comment actions Permalink
  • Avatar
    Margaret Bright

    Hi Member,

    Please get in touch with our support team at skylum.com/support. They will be happy to investigate this for you and help you get your Luminar up and running.

    0
    Comment actions Permalink

Please sign in to leave a comment.