Luminar 4 image preview does not refresh after edits are made

Answered

Comments

18 comments

  • Avatar
    Chris S

    Hey,

    I face the exact same issue on my laptop.

    I have also installed Luminar 4.3.0. build 7119. But I couldn't find any differences using the laptop screen or an external display.

    I have Luminar running also on my gaming computer with the same version number but here it works fine.

    So, any suggestions are much appreciated :)

    edit: I just realized that you (@rb) also have the Intel Xe graphics in your computer. I really suspect that the issue is related to this graphics since I have the same hardware.

    0
    Comment actions Permalink
  • Avatar
    David SIMON

    issue is related to Skylum coding versus new GPU Intel IRIS Xe on 11th gen CPUs (TigerLake)

    see my reply in that post for solution:

    https://community.skylum.com/hc/en-us/community/posts/360010168459/comments/360002577020

    1
    Comment actions Permalink
  • Avatar
    Anja T.

    Same issue here with Luminar 4.3.0 (7119) on Lenovo Yoga slim 7i with i7-1165G7 processor and Intel Iris Xe Graphics, 16 GB RAM. All drivers and updates (Windows, Lenovo, Intel) are installed. Problem occurs as well with as without hardware acceleration for Luminar (set in the graphics settings).

    0
    Comment actions Permalink
  • Avatar
    David SIMON

    Anja

    how did you set graphic settings for hardware acceleration to be disabled ??

    0
    Comment actions Permalink
  • Avatar
    Roy Blackwell

    To the best of my knowledge the lastest version of Luminar 4 on Windows is 4.3.0 (6886). If you are using a version 4.3.0 (7119), that quite possibly is a hacked version and has compromised you computer in some way. At a minimum, you may have spent money for an invalid product.

    See this post:

    https://community.skylum.com/hc/en-us/community/posts/360010072380/comments/360002575740

    0
    Comment actions Permalink
  • Avatar
    David SIMON

    Tks Roy

    my version is a genuine Trial version of Luminar and it resulted with Luminar4.3.0_(7119) as reported to Skylum Support

    the issue has been CONFIRMED by Skylum - replying to me via direct email from support though...

    I don't understand why they don't better communicate and share, on that particular issue, on these community posts where more and more users with 11th gen CPUs & Intel Iris Xe will experience the exact same problem

    0
    Comment actions Permalink
  • Avatar
    Anja T.

    David

    Now that you ask I am not sure if I really deactivated hardware acceleration. This is what I tried:

    First I tried to activate hardware acceleration. I opened graphics settings in Windows, klicked on "Desktop App", added Luminar 4 and confirmed "Best Performance" or so.

    Thrn, in order to deactivate hardware acceleration again, I deleted the settings for Luminar there.

    Neither of it helped.

    0
    Comment actions Permalink
  • Avatar
    David SIMON

    Anja

    try this - that will work... although not ideal solution, that helps pending Skylum to fix it.

    --

    just run Registry Editor = type-in REGEDIT command

    browse registry tree down to HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics

    you will probably need (as I had) to create a new DWORD type key and name it = DisableHWAcceleration.

    Once created - double click for opening and set Value to 1(disable) or 0(enable).

    See below - is 0 because I ran video editing last night and tried to set 0 for enabling hw acceleration

    2
    Comment actions Permalink
  • Avatar
    rb

    David SIMON - You got it! Thank you! Disabling hardware acceleration does indeed fix the issue. So it seems like Intel/Microsoft or whoever is responsible for the issue is going to have to fix the issue on their end sooner or later (perhaps that's why they are giving away luminar for free to Xe graphics, so we can beta test it for them ;) 

    Roy Blackwell - Thanks! Yes I was a bit suspicious of version 7119 at first, but it seems like when I use the offline installer it installs 6886, but when I use the online installer version it installs 7119 (may only be a thing for folks with intel Xe graphics though).

    Anja T. and @~!C!~ - Like David mentioned you'll need to mess around with the Windows Registry in order to get things to work. Usually it's not recommended to touch any of these settings since the side effects can be pretty bad. I'm also not sure 100% if this causes any issues with other applications either, so will probably just re-enable hardware acceleration and stick to using my external monitor where things magically seem to be working ok (as long as the luminar window is completely maximixed).

    To all who have recently bought a laptop with intel graphics you can get a single-seat license of luminar for free from Intel here: https://softwareoffer.intel.com/Campaign/LearnMore/873fbd13-4346-4501-8be2-fa5bcac8921a (not sure who's footing the bill for this, but if it's skylum then I suspect my post is going to get deleted real soon, as soon as the mods are back from vacation :P )

    0
    Comment actions Permalink
  • Avatar
    Anja T.

    rb David SIMON

    I followed the steps in the Windows Registry now - and indeed it works. Thank you very much. So at least I can use Luminar with the workaround until the problem is properly resolved by Skylum.

    0
    Comment actions Permalink
  • Avatar
    David SIMON

    rb

    tried the maximized Luminar window under external monitor = trick does not work for me :(

    0
    Comment actions Permalink
  • Avatar
    Member

    wow, this is real bad....I was going nuts trying to figure out why my previews on SKY replacement were not rendering, sometimes they would if I tried different zoom ratios......
    Sounds like right now you must do a REGEDIT to disable hardware acceleration.....
      Maybe I should return my brand new HP ENVYwith the Intel 11 generation which I actually like,, more than my old Dell XPS, it's very very fast.... 
    I don't play games or do any other graphic heavy stuff but will this be an issue with other editing s/w??? I hope some solution is worked out but I thought on the Skylum end they arent really supporting Luminar 4, having "replaced" it with AI.  I really wasn't up for "investing" in AI now and don't even know if that will work.
    I have used the Photoshop Sky Replacement and must say, Luminar is more flexible and intuitive, when it works

    1
    Comment actions Permalink
  • Avatar
    Kate Williams

    Hi Member,

    This behavior is a result of a Microsoft WPF or Intel driver bug. 

    A quick search shows that a number of other apps using the same graphical subsystem are also affected. 
    Thus, a Microsoft / Intel is expected to ship a fix. Meanwhile, our techs are checking whether something can be done on our end to improve the situation. 

    The steps below only disable hardware acceleration for WPF applications, not your whole system: 

    1. Type CMD in the search field on your Taskbar, right-click on the Command Prompt line and choose Run as administrator. See the screenshot: http://prntscr.com/xcv2l1 
    2. In the Window that opens, copy and paste the line below:
    reg add HKCU\SOFTWARE\Microsoft\Avalon.Graphics /v DisableHWAcceleration /t REG_DWORD /d 1
    3. Press Enter on your keyboard.
    See the screenshot: http://prntscr.com/xcv0tb 
     
    (No worries, you'll be able to reactivate hardware acceleration anytime in the following way: 
    1. Type CMD in the search field on your Taskbar, right-click on the Command Prompt line and choose Run as administrator
    2. In the Window that opens, copy and paste the line below:
    reg delete HKCU\SOFTWARE\Microsoft\Avalon.Graphics /v DisableHWAcceleration
    3. Press Enter on your keyboard.
    4. The command prompt will ask you to confirm whether you'd like to delete the registry value by typing Yes or No. 
    Type Yes and press Enter on your keyboard.
    See the screenshot: http://prntscr.com/xcv4wd )

     

    0
    Comment actions Permalink
  • Avatar
    Member

    Hi,

    I also have the same issue with an Iris xe computer.

    Disabling the hardware acceleration also worked for me.  But could you elaborate on what might be the side effects if we leave hardware acceleration disabled all the time ? 

    The previous note indicates that this will only affect WPF apps, what are WPF apps  and what apps might be affected ?

    Also is there a way to create a file (ex: .bat)  that would disable the hw acceleration  automatically on invoking Luminar and re-enabling it when we exit Luminar ?

    Thanks again

     

     

    0
    Comment actions Permalink
  • Avatar
    Member

    Fyi, I read Kate Williams' solution and got an email response to my help ticket a month ago but it's a  non-starter for me.

    I'm simply not going to mess around with with my registry. Why should we need to?  I get the impression that Sklylum isn't going to address it with an update. I'm not going to fork over $$ for AI... b/c I don't know if the same issue exists with it and there's no free trial

    Maybe updated intel graphics drivers will help 

     Anyone try that? There's an intel generic driver out there but I'm waiting for the OEM specific driver (I have HP).

    Meanwhile without access to a desktop, I have to make do with Photoshop' s sky replacement tool. Frankly I like Luminars. interface a lot more for this tool. But Adobe works. 

    1
    Comment actions Permalink
  • Avatar
    Elena Blum

    Hi Member,

    It looks like you're facing an issue caused by a global problem with Iris XE graphics as discussed here: https://github.com/dotnet/wpf/issues/3817 

    Our team is currently checking whether something can be done on our end to fix the issue. 

     

    Meanwhile, you can try to disable hardware acceleration following the steps above.You'll also be able to reactivate hardware acceleration anytime.

    0
    Comment actions Permalink
  • Avatar
    Member

    Hi Elena,

    Thanks for the info

    But could you specify what disabling the Hardware acceleration might do to the other applications on my laptop ?

    Thanks in advance

    0
    Comment actions Permalink
  • Avatar
    Chris S

    Hey guys,

    sorry for the reactivation of this old topic, BUT:

    I just installed the newest Intel graphics driver and now everything seems to works as expected.

    So just follow this link and install the newest version:

    https://www.intel.de/content/www/de/de/download/19344/intel-graphics-windows-dch-drivers.html

     

    0
    Comment actions Permalink

Please sign in to leave a comment.