Luminar AI as plugin for Lightroom

Answered

Comments

7 comments

  • Avatar
    Gaurav Areng Chakraverti

    Been facing the same issue since the launch. The other two methods outlined in their FAQs to round-trip between LR and Luminar work fine, but the "Edit In" option creates that second file in LR, and opens a copy in Luminar, but doesn't allow me to "Apply" and send the file back to LR. 

     

    If you/anyone come across a fix for this please do let e know :) 

    0
    Comment actions Permalink
  • Avatar
    Alina Skylum

    Hi!

    Please note that the recommended way to invoke Luminar AI as a plugin is to right-click on an image > Export > Luminar AI > Open Source Files/Edit Copy with Lightroom Adjustments.

    After you hit Apply, the photo should appear under Catalog>All Photographs in Lightroom.

    If the issue remains:

    1. Make sure Photoshop/Lightroom is not runningIf the app was running, reboot your Mac before proceeding. 
    2. In the top-bar menu click Luminarᴬᴵ > Install Plugins.
    3. Click Uninstall next to Photoshop/Lightroom
    4. Reboot your Mac and launch Luminarᴬᴵ.
    5. Click Luminarᴬᴵ > Install Plugins.
    6. Click Install next to Photoshop/Lightroom.

    You may be prompted to enter your Mac user password at some point, please do so.

    Let us know how it goes.

    Best regards,

    0
    Comment actions Permalink
  • Avatar
    Robert Brodeur

    I have tried this method several times with no luck.  Should I remove Luminar AI then reinstall?

    Thanks for your help,

    Robert

     

    1
    Comment actions Permalink
  • Avatar
    Alina Skylum

    Hi Robert,

    Could you please confirm whether you've tried sending an image to Luminar this way?
    Right-click on an image > Export > Luminar AI > Open Source Files/Edit Copy with Lightroom Adjustments.

    0
    Comment actions Permalink
  • Avatar
    Robert Brodeur

    Alina,  Yes I did try it and it worked. Thank you so much.

    Robert

    0
    Comment actions Permalink
  • Avatar
    Eric Feigenson

    I just ran into this as well. Using Export does work as described. However, I have dozens of Lightroom plugins and to round trip an image from Lightroom to any of my plugins, I always use Edit In... It feels like a bug to me that this isn't how Luminar works.

    In fact, the Luminar User Guide online states:

    Choose Photo > Edit In > LuminarAI. A new dialog box will open.

    It lists the Export options as other valid ways to edit in Luminar, but no distinction is made.

    0
    Comment actions Permalink
  • Avatar
    Dennis Stick

    Yes it worked.  changing %appdata%\Luminar -  commonsettingsplugin.xml using the "old" rename fixed the problem.  Thanks

    0
    Comment actions Permalink

Please sign in to leave a comment.