Will not run - "Faulting module path: C:\WINDOWS\System32\uctbase.dll"

Answered

Comments

12 comments

  • Official comment
    Avatar
    Margaret Bright

    Hi Dave,

    Sorry to hear you've faced this issue. Please try reinstalling the app in the following way:

    1. Go to “Apps and Features” by right click on the Start button;
    2. Find Luminar there and click [Uninstall] (you can also uninstall from the Control Panel);
    3. Type %appdata% in Search (folder Roaming should open);
    4. Find the folder “LuminarAI” and delete it (it deletes your license for LuminarAI too. Please, note that your Custom and downloaded Looks/templates will be removed, so make sure to save them somewhere);
    5. Go to Pictures and rename the folder called Luminar AI Catalog (if you have your Catalog anywhere else, find it and rename it).
    6. Install the app once again and launch it: https://downloads.skylum.com/luminarai/win/Win_Luminar_AI_1_0_0_Release_7348.msi
    7. Choose to Create a New Catalog and add a small folder with images or a single image for editing. 
    Comment actions Permalink
  • Avatar
    Dave Wallin-Eddy

    Thank you Margaret.

    I did all of that and nothing happened still. Installs fine (always has) but unable to launch. No errors, just nothing happens. Looked in the application logs and the only Application error is the exact same as I listed.

    "Faulting module path: C:\WINDOWS\System32\uctbase.dll"

    1
    Comment actions Permalink
  • Avatar
    Roy Blackwell

    The file is ucrtbase.dll, correct? That file on my Windows 10 machine is version 10.0.19041.546 and is 1021KB in size. Luminar AI is working on my machine. What version is your file? What version of Windows are you using? If Windows 10, what version is it?

    0
    Comment actions Permalink
  • Avatar
    Mark Haskell-Cooper

    Just to confuse matters further or help? My version of this file is 10.02.21277.1000 different again windows 10 pro version 21277.1000 vers 2004. size 1098Kb

    Mark

    0
    Comment actions Permalink
  • Avatar
    Roy Blackwell

    I am running Windows 10 Pro version 20H2. 

    0
    Comment actions Permalink
  • Avatar
    Dave Wallin-Eddy

    @ Roy Blackwell and @Mark Haskell-Cooper :After doing research this dll shows up in other programs when crashing too. Not on my machine, just based  on other threads all over on this dll.

    To cause more confusion:
    The current dll is version 10.0.194.685 with a date of 12/2/2020
    The version in my System 32 folder is 10.0.19041.546 with a date of 11/12/2020
    The version installed with LuminarAI is 10.0.17134,12 with a date of 4/20/2018. Of note this is the same version in Luminar 4, which works fine.

    Also Roy, in reply: Windows 10 Pro, 1904.684 V20H2

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Everyone,

    If the issue remains, please try the following solution:

    • Press the Windows key + S on your keyboard and type in Add or remove programs. Windows will suggest the matching app, open it.
    • In the list of installed applications locate all entries that have Microsoft Visual C++ 2013 Redistributable in the title and uninstall them one by one.
    • In the list of installed applications locate all entries that have Microsoft Visual C++ 2015 Redistributable in the title and uninstall them one by one.
    • In the list of installed applications locate all entries that have Microsoft Visual C++ 2017 Redistributable in the title and uninstall them one by one.
    • In the list of installed applications locate all entries that have Microsoft Visual C++ 2019 Redistributable in the title and uninstall them one by one.
    • Download Visual C++ 2013 Redistributable here (click this text to open link). Select your preferred language, click Download, mark vcredist_x64.exe with a checkbox, and click Next to download it.
    • Download and install vc_redist.x64.exe from here: https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads  (it already has packages 2015, 2017 and 2019).
    • Reboot your PC
    0
    Comment actions Permalink
  • Avatar
    Dave Wallin-Eddy

    Well Helena, this is interesting. I did the above and NOW I no longer get that error. NOW I get these 2 messages:

    .NET Runtime error
    Luminar AI.exe
    CoreCLR Version4.700.19.60701
    .NET Core version 3.1.1
    "An attempt was made to load a program with an incorrect format"

    Application error
    LuminarAI.exe  version 10.0.0.7348
    KERNELBASE.dll version 10.0.19041.662

    EDIT: Just to clarify - I uninstalled the C++ that you said. But I did NOT uninstall any earlier ones. 2005,2008,2010, 2012. DO I need to uninstall those as well?

    DOUBLE EDIT: Now Luminar 4 does not open either, with the same messages in Application log,

    TRIPLE EDIT: Reinstalled .NET from 3.1 up to latest, version 5. Also Reinstalled C++

    Luminar 4 now works again

    LuminarAI does NOT open and once again ply returns the "original" error regarding the ucrtbase.dll

    Thought - if I am basically being a beta tester here why should I need to pay for 2 seats when the program does not work? This is insane, I have NEVER had this sort of issue with getting a program to work, even going back to my Amiga days and beta testing Studio 16 Hardware and software..

    1
    Comment actions Permalink
  • Avatar
    Dave Wallin-Eddy

    UPDATE: Tech support told me to also uninstall Luminar 4 and reinstall. So I did, but no changes. They said they were forwarding to the development team because others have the same issue with the uctbase.dll. Maybe this phantom 1.0.0,1 update people have talked about solves it? Guess we will see when it really is released.

    0
    Comment actions Permalink
  • Avatar
    Dave Wallin-Eddy

    UPDATE 2/01/21

    Got the "update"  but it will not install. Keeps giving an error about not being able to uninstall the older version. It is uninstalled.

    0
    Comment actions Permalink
  • Avatar
    Agatha Winter

    Hi Dave Wallin-Eddy,

    I'm sorry to hear about the issue you encountered. Please reach out to us at www.skylum.com/support and we'll be happy to help sort this out for you.

    0
    Comment actions Permalink
  • Avatar
    Dave Wallin-Eddy

    UPDATE: 3/16/2021

    Uninstalled and reinstalled with 1.2 and still same error. Never fixed issues.
    Asking for a refund now. Tired of paying to be a beta tester on software the never has worked.

    0
    Comment actions Permalink

Please sign in to leave a comment.