Luminar AI won't work on Mac

Answered

Comments

10 comments

  • Avatar
    Jeff Schwartz

    not sure if this would help. So far seems to have solved my problem.

    Please try the following:

    • Make sure Luminar AI is closed.
    • Locate your Luminar AI Catalog folder. The default location is %username%\Pictures\. If you specified a custom location for your catalog, search your custom location.
    • Rename the Luminar AI Catalog folder as well as Luminar AI Catalog.luminarai file inside this folder. Choose any name you like. 
    • Start Luminar and choose to Create a New Catalog.

    Please note that you should be able to re-open your previous catalog later via File > Catalog > Open.

    If the issue persists, please get in touch with our support team at skylum.com/support and they will help you sort it out.

    I must also inform you that due to a high amount of requests, it may take some time for them to get back to you so I would like to kindly ask for your patience.

     
    1
    Comment actions Permalink
  • Avatar
    Robert Burns

    I checked what you suggested, same results as Justin. Program freezes and the quit button is greyed out. Working on 2020 27" iMac with 40gb memory.

    0
    Comment actions Permalink
  • Avatar
    Helga Hufflepuff

    Hello Justin,

    I'm very sorry to inform you that your computer does not meet system requirements. Let me enclose them below:

    • MacBook, MacBook Air, MacBook Pro, iMac, iMac Pro, Mac Pro, Mac mini, early 2010 or newer
    • CPU Intel® Core™ i5 or better
    • Memory 8 GB RAM or more (16+ GB RAM is recommended)
    • macOS 10.13.6 or higher. IMPORTANT: macOS 10.12 is not supported.
    • Hard disk 10 GB free space; SSD for best performance
    • Display 1280x768 size or better

    We would kindly ask you to try installing Luminar AI on another computer if possible. In case you do not have another computer, please, reach us via https://skylum.com/support, so we can help you with refund. Thank you

    -1
    Comment actions Permalink
  • Avatar
    Justin Mikkelsen

    Helga Hufflepuff, help me out. Which system requirement do you see isn't meeting requirements? Core I5 and Intel Xeon are comparable, the Early 2009 model is basically just parts, it was built about 5 years ago. It meets technical requirements in every other way. Can you provide a rationale other than that? 

    1
    Comment actions Permalink
  • Avatar
    Justin Mikkelsen

    Jeff Schwartz, thanks for commenting. Unfortunately that didn't work. 

    0
    Comment actions Permalink
  • Avatar
    Alex Young

    Same with mine. This is the last time I putting money into this company... would like a refund.

    Late 2009
    3.06 GHz Intel Core 2 Duo
    12GB 1067 MHz DDR3
    High Sierra 10.13.6
    389GB available

    0
    Comment actions Permalink
  • Avatar
    Stephen Scharf

    I can't get Luminar AI to launch. I'm using MacBook Pro (mid-2015) with MacOS Mojave 10.14.6 and 16GB ram. 

    Installer installed Luminar AI, but upon launch I get the SBBD (spinning beach ball of death). App will not even open so that I can install the license key. 

    I have Luminar 4 and it works fine. 

     

     

    1
    Comment actions Permalink
  • Avatar
    Justin Mikkelsen

    Stephen Scharf, I'm totally with you. I don't think this is an issue of the hardware models being built in 2009, they keep telling me that it is, but at the end of the day software operates on technical specifications for performance, not just the year it was built. My machine exceeds all other operating requirements, the parts just originated from 2009. They've got something screwy going on with this software their support is refusing to acknowledge, and other people like yourself with a newer model has the same issue that I do. I've asked them for a refund, I was excited about this software but they can't get their crap together so I'm out. 

    1
    Comment actions Permalink
  • Avatar
    Lynne Pariseau

    I read a few days ago, a post from one of the Skylum employees that they acknowledge a problem with LuminarAI launching with the Mojave OS - and were talking about the techs updating it.  Haven't seen anything since.

    1
    Comment actions Permalink
  • Avatar
    Stephen Scharf

    Well, that would explain it. Thanks, Lynne. 

    0
    Comment actions Permalink

Please sign in to leave a comment.