Changes on image are not showing - Luminar AI

Answered

Comments

52 comments

  • Avatar
    Rodney Brown

    Same issue for me.  Luminar worked for the first few days, but now it won't show any changes I make until after i move to another tool or some other trigger I can't quite figure out.

    0
    Comment actions Permalink
  • Avatar
    Helena Carter

    Hi Wentai L, Rodney Brown,

    Please, reach out via https://skylum.com/support so we could assist you in a more effective way and investigate this.

    0
    Comment actions Permalink
  • Avatar
    Member

    Same issue and cannot disable hardware acceleration. Going round in circles and getting nowhere!

    0
    Comment actions Permalink
  • Avatar
    Member

    Same issue and cannot disable hardware acceleration. Going round in circles and getting nowhere!

    0
    Comment actions Permalink
  • Avatar
    Richard Harrington

    This is often a GPU issue.  Make sure your driver is up to date and that your GPU meets system tech specs

    -4
    Comment actions Permalink
  • Avatar
    Rodney Brown

    Thanks Richard, all of my drivers are up to date.  I'm using the integrated GPU from an 11th gen Tiger Lake processor which should have more than enough power for this.

    Rod

    0
    Comment actions Permalink
  • Avatar
    Rodney Brown

    Ah, this works connected to a monitor. Looks like some kind of scaling bug on a smaller screen like a laptop!

    Bonus fact, the bug exists in Luminar 4 as well...

     

     

    1
    Comment actions Permalink
  • Avatar
    Member

    Problem still not solved. 

    0
    Comment actions Permalink
  • Avatar
    A B

    Same issue here with Luminar 4. Intel 11gen CPU with Iris XE graphics.

    0
    Comment actions Permalink
  • Avatar
    M K

    I am having the same problem since 15th December. The supports replys to my mails every three-four days. Unfortunately no real help until now. I tried everything even reinstalling windows on my notebook. Its a new notebook, and the second app installed after the anti virus app was luminar AI. Same problem with Luminar 4

    Intel Iris XE

    2
    Comment actions Permalink
  • Avatar
    Member

    Skylum support seems to be grasping at straws half the time and hoping users will solve the numerous problems for them.

    3
    Comment actions Permalink
  • Avatar
    M K

    Yes after 16 days I do think the same. I already mentioned once, how I do not understand why the app is not working properly. The team behind skylum is able to make a great app (when working) but the technical expertise helping their customers seems to be very poor. Of course, when you launch a new app there are some problems that could occur and some minor issues but hey, 30% of the Luminar AI users are not even possible to launch the app. 

     

    1
    Comment actions Permalink
  • Avatar
    David SIMON

    Dear ALL = running new 11th gen CPU associated to Intel XIRIS Xe GPU.

    Had exact same issue with my brand new Dell XPS13, and got an answer from Skylum support on 29Dec, referring to  the following page = https://docs.microsoft.com/en-us/previous-versions/dotnet/netframework-4.0/aa970912(v=vs.100)?redirectedfrom=MSDN

    worked well for me immediately after disabling Hardware Acceleration Option = creating new Registry DWORD key =

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics\DisableHWAcceleration and setting it to 1 (disabled)... set it back to 0 for Enabled.

    No system reboot required = immediate effect on Luminar (app may required restart).

     

     

    0
    Comment actions Permalink
  • Avatar
    Rodney Brown

    Hi David, that appears to disable hardware acceleration for everything.  I don't suppose they mentioned an actual fix for the issue?

    Rod

    0
    Comment actions Permalink
  • Avatar
    David SIMON

    Hi Rodney

    that was also my guess (=disables hw acceleration for everything) and so was my reply to Skylum Support for them to clarify.. but had no answer so far.

    I use the trick with disabling when required for Skylum apps... REGEDIT command gets back to the last key you've edited so it is literally few seconds only to enable(0)/disable(1).

    I don't really expect them to come back with a fix on their apps, as they claim this is rather an issue with the GPU driver, hence INTEL should work on it - I "kind of" agree...

    Leaving on disabled(1) for few days, I've not noticed significant graphic performances reduction... but I'm not on gaming. Will do some tests with video editing shortly, and see how much that would affect my editing performances with Premiere or Filmora.

    0
    Comment actions Permalink
  • Avatar
    Rodney Brown

    David,

    that works well!

    As for Intel, graphics acceleration works fine on Capture One and On One, plus gaming, so I'm suspicious of the claim that it's an Intel issue.  If it is, I hope Skylum have submitted it as they have all of the details on how they coded the use of acceleration.

    Rod

    0
    Comment actions Permalink
  • Avatar
    David SIMON

    just ran some tests,

    to be frank, even with disabling hardware acceleration, the performances on Premiere for video editing of my 4K_30fps drones videos, remains very good... do not observe lags so far..

    will need to play edited video exports with and without acceleration, to compare and see if any difference in performance for generating final video.

    1
    Comment actions Permalink
  • Avatar
    Member

    To be honest, and with no disrespect to people commenting here, we should not have to be doing regediting, disabling etc if Skylum had their act together. Photoshop requires none of this!! It just works. Am I being simplistic in saying the real issue is poor coding on Skylum’s side? YouTube is full of people promoting Luminar Ai. Maybe it is time for a video that exposes all the issues!!!!

    4
    Comment actions Permalink
  • Avatar
    M K

    I am also running Luminar AI on my new DELL XPS13 - having the problems since December 15th. 

    Since I am not an IT-Expert I really do not know hot to disable hardware acceleration. Now I looked up several videos online and the Troubleshoot button is missing and I am not able to change anything.

    How can I disable the hardware acceleration? 

     

    0
    Comment actions Permalink
  • Avatar
    David SIMON

    MK

    this is very easy (although I agree we shouldn't have to do so, and competitors software do not face such issue with new XIRIS Xe GPU - Skylum's coding is for sure one of the reasons for that issue !!)

    Not even mentioning the Adobe products, simple freeware apps such as FastStone Image Viewer, handles the real-time display of your modifications to the image using the cursors (brightness, contrast, others..)

    --

    just run Registry Editor = type-in REGEDIT command

    browse registry tree down to HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics

    you will probably need (as I had) to create a new DWORD type key and name it = DisableHWAcceleration.

    Once created - double click for opening and set Value to 1(disable) or 0(enable).

    See below - is 0 because I ran video editing last night and tried to set 0 for enabling hw acceleration

    1
    Comment actions Permalink
  • Avatar
    M K

    Hi David,

    thank you very much!!!!!! This really did solve my problem. I am really a noob regarding this kind of IT problems. Is there any disadvantage of disabling the HWA? Can it be a security problem?

    I really do not know how to thank you David! You have really saved my day.

    Best regards

    MARKO

    0
    Comment actions Permalink
  • Avatar
    David SIMON

    you're welcome Marko

    was just lucky I had a reply from Skylum Support leading to that trick.

    No security issue with disabling HW acceleration, but "possibly" some reduced performances with other applications requiring high graphics resources.

    I've done few tests on my side with apps quite demanding in GPU (4K videos editing with Premiere and Filmora) and have not noticed really significant reduction in graphics performances. In doubt, I turn it back on anyway.

    It takes only few seconds, because as soon as you type-in REGEDIT again, it gets back automatically to the last key you've modified - so you just have to put it back to 0 for enabling HW acceleration again. Very quick.

    This is however hopefully a temporary solution only, and I hope Skylum will fix their code because ALL of their apps have the same issue, while competitors do not !!!

    1
    Comment actions Permalink
  • Avatar
    Member

    Merci beaucoup, David.

    Managed to disable HW acceleration but am still annoyed at Skylum.

     

    0
    Comment actions Permalink
  • Avatar
    Pat Baranitsky

    David, would I change all the 0's in the screen shot above to 1 or just the one in the brackets?

    0
    Comment actions Permalink
  • Avatar
    Rodney Brown

    Pat, after you create the new DWORD, just double click on it and enter a single 1 digit.

    Likewise, to enable HW acceleration again, double click on it and change the 1 to 0.

    0
    Comment actions Permalink
  • Avatar
    Pat Baranitsky

    Disabling it helped. It unlocked the drop down features in the top left of my screen under the Luminar Ai icon. Now when I do any edits, the changes aren't visible when I make any adjustments using the sliders, etc. For example, when I try to select a set of clouds, my image doesn't change after I make my selection but if I zoom in on the image and then back out to normal, the clouds are added. I couldn't make any changes before I disabled the hdw acceleration. Its a step in the right direction but no where close to where it should be. I can't zoom in and out to see the effect of every change I want to make. 

    1
    Comment actions Permalink
  • Avatar
    David SIMON

    Pat

    the symptoms you describe with zooming in/out in order to reflect modifications done through sliders, are exactly what I had BEFORE I disabled hardware acceleration with setting the key [DisableHWAcceleration] to 1 in the registry.

    Do you confirm you set key registry to 1 ?

    0
    Comment actions Permalink
  • Avatar
    Pat Baranitsky

    Yes I did that. I couldn't make any changes before I did that. Now with the registry set to 1, I can make the change but I don't see them unless I zoom in and out after making the change. 

    0
    Comment actions Permalink
  • Avatar
    Miles

    Thank you to all for contributing to this thread! 

    I found the same issue, along with the before/after slider not working unless I zoom.

    I'm glad there is a workaround, though not thrilled to have to disable acceleration on my new laptop.

    I created a support ticket, hopefully everyone that has this issue will do the same so it is addressed properly.

    One note for others, you may have to exit the application and re-launch in order for the Regedit to take effect.

    Again, thanks all for posting this!

    Cheers,

    Miles.

     

    0
    Comment actions Permalink
  • Avatar
    Kathy

    I am having this problem and I just bought the software, they haven't fixed it?  Very frustrating, guess I have to do the work around.  What's up Skylum?  Lots of people have this issue

    0
    Comment actions Permalink

Please sign in to leave a comment.